3 posts in this topic

So I've been reading up on the spec sheet for a few spare 15K seagate/HP SCSI hard drives I've got lying around, thought it'd be a good idea to sling them together for a software RAID0 (Please go and moan ELSEWHERE before even thinking of posting anything about RAID0 reliability - I don't care about it nor what you have to say about it).

So on said spec sheet there was mention that the 18.2GB SCSI drives are actually 23.5GB unformatted and that the extra data is used as spare blocks and whatnot, 18.2GB is the formatted size when the drive is setup with a block size of 512 bytes per sector, and the spec sheet says it can be changed to any even number between 512 and 704 - so I was interested to hear if anyone has ever changed the block size on a SCSI drive and any pros or cons they've got from doing so? There was mention on the man page of the linux utility sg_format (used for changing block size) of 'short stroking', reducing the block size to give you less space but much better performance.

So as these are kinda oldish 15Krpm 18.2GB Ultra 160 SCSI drives I was thinking of changing the block size to give around 20GB of space on each drive then installing arch linux on them using software RAID0.

I'd be interested to hear from anyone that's tried to do this or done it or had problems trying to do it (but again - no RAID0 reliability talk - read enough threads from all over the internet where something is asked about RAID0 and every response is exactly the same saying 'dont do it bad reliability')

Share this post

Link to post
Share on other sites

OK well as unexciting as this topic seems to be... I've loaded up the drive marked as 'ARCH X330' on an old IBM server and stuck a blank compaq 18.2GB SCSI drive in the other bay, booted it up and got sg3_utils installed and issued a command to format and change the block size from 512 to 520 to see how it went, I cancelled on the 10 second countdown before the 5 second countdown appeared and something managed to mess up, got screen spam for about 20 seconds giving invalid sector data... So there you have it, DO NOT TRUST it to actually stop because it looks to have sent the SCSI commands before the countdown even began!

Anyway reissused the command and am letting it run, the seagate PDF said it'd take between 30-60 minutes for a quick/full format so I'll leave this running and see what happens.

EDIT: Interesting, after completion there were a load more kernel error messages, tried fdisk and parted on the drive, parted just exited and fdisk said there was a problem, rebooted and same problems... Going back to 512 blocks now to see if the drives had it or if 520 is too much or if the tools don't support 520 or what really.

Edited by n_K

Share this post

Link to post
Share on other sites

OK block size of 512 works fine (this on the compaq drive), 502 works fine too but 520 doesn't work at all, not sure if it's the drive or what yet, will try again with the HP/Seagate drives when the converters arrive... Pretty shocking if it is the drive though, means compaq either didn't bother with any spare blocks or intentionally stopped the user from using them.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.