Sign in to follow this  

Trouble installing Razer Game Booster

Recommended Posts

Guth    104

I wanted to try out the game booster as my old core 2 duo is struggling with online gaming, I've clocked it as high as I can but its still not great so until I can upgrade Ill just have to suffer it out. Though I would give this a try. I had it installed before but I uninstalled it before I tested it.

Now every time i try to install I get this error:


I've tried re-downloading twice and tried downloading from another host too but every time I get the same error. I tried compatibility and running as admin.

Not sure what else to do.


I went to the temp file in question and tried running it directly from there and I'm getting the same error. Even though the file its saying it can't read is the one I've opened.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.