2 posts in this topic

So, after the fiasco of the GX280, I managed to find a cheap dell 745 (they're the only manufacturer I know that still ships with LPT and COM ports), so, got this earlier, thought I'd try hackintosh on it for a laugh as there's loads of reports of it working... No, it doesn't. So I gave up with that, tried my old GX280 drive using a HighPoint PCI card (as there's no PATA on the 745) and wow, that card is a pile of complete ****, nothing but problems and after I eventually got it booting using a live usb and doing an fsck, it said my drive was littered with errors, and kept failing to reply to commands... I will be dumping that card very shortly, breaking it into a few pieces first to make sure no-one finds it and mistakes it for being something useful.

So, I tried a SCSI drive using an unopened adaptec 2940U PCI card... Wow, another failure, drive spins up but card refuses to pick it up - getting pretty ****ed off now. So, lastly I've resorted to a jmicron PATA -> USB device and used an arch live usb to sort out the kernel so it'd boot properly and wahay, I've got a working arch install once again, well, mostly...

There appears to be a problem with this dell (like most others), I'm not able to reboot (I haven't tried a shutdown yet but from what I've read it won't work). So it's a known problem with this PC that you need to add reboot=bios to the kernel command line, I've tried reboot=b and reboot=bios, neither do anything and neither make the system able to reboot, so I'm stuck with a pretty much useless PC I can't turn off without shorting out 2 points on the board using a screwdriver which has really displeased me.

Does anyone have any clue how the hell to sort this quite frankly pathetic problem out? I'm using arch with a vanilla 3.8.7 kernel and all the bug reports about this say the problem was fixed in the 2.6.x kernels yet it obviously wasn't.

(I've also got spares from the GX280 if anyone wants them, free, just pay for shipping and they're yours)

Thanks again!

Share this post

Link to post
Share on other sites

Fixed this problem, have to add 'reboot=b,s,t,k,e,w,c,p' to the bootloader, reboot=b or reboot=a doesn't work so it's one of the other options that does, and frankly can't be bothered to go through them and find out which one it is. Glad to see that dell provided the code for their little hack to apparently get it working in the kernel and their own code doesn't work, nice one dell, quality as usual....

Quite lame how it won't work with any live USBs though and I'd have to manually add it to the command line.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.