Baffling (at least to me) DLNA Issue

Recommended Posts


Hello, all. I'm hoping someone here may have some idea about an issue I've run into, if nothing else for my peace of mind.


Some brief background information, which may be relevant.


I have two physical drives, the first being the system boot-up drive, the second divided into two partitions, d: for my personal files and e: for my music, mostly ripped from my CD collection. I got Windows 7 when it came out, and I have reinstalled the o/s twice - the first time because of having to replace a crashed HD. Note: I did not have either of these issues the first time I reloaded the o/s.


The first issue I noticed after this latest reload was that when I tried to access the data drive (d:) it said I didn't have permission for about half of the folders. Best I could figure out, it thought it still belonged to the admin account from the last o/s load. I was able to regain control of most of them by changing owner back to me - that is the admin of the current o/s load - but it wouldn't work for about 3 of them. To cut to the end of this issue, I ended up (very reluctantly) formatting my data drive after making sure there were two backups in place. I copied the files back from the external drive, and then it worked.


The second issue was when I tried to set it up again to stream to my Sony Blu-ray player. I enabled streaming in WMP just like before, but it didn't work right. To skip to the end of a bunch of testing, I found out that it would stream from about 3 of the folders, but for the rest it said that there were no playable files. Of course there were playable files, it always worked before, so it must be a problem with the sharing settings for the folders. Again - even though it always worked before. I spent some time with it, but in the end verified that the properties were the same for the folders that worked and the ones that didn't. The only difference between the two was that the ones that worked were .WAV files I created by recording the midi music from early 90's games (7th Guest, 11th Hour, Doom, Descent, if you're curious!) and the other folders were ripped from my CDs. So I even tried recording a .WAV file from playing a song and putting that in a separate folder to see if it would stream, but it still said "No playable files found." I got to thinking that maybe there were some properties on my other drives leftover from the previous o/s load messing it up, so I reformatted the drive (thankfully, after making backups of the folders that worked), with the idea that I would just rip my CDs again. Well, even with a reformatted drive, set to share, a CD ripped fresh to the drive, it still wouldn't stream. I copied over the folders from the backup drive, and those folders continue to stream fine.


Here's what I ended up doing just to make it work. I found out that any folder I created under one of the ones that worked would also stream. So now, all my music folders are under the root directory of e:7th guest soundtrack\.  I was going to change the name to something like, "Miggy's Music", but it warned me that this might mess up sharing, so I didn't dare do it.

Link to post
Share on other sites

Sorry for the double post. It somehow posted before I was finished, and I tried to edit it to add the final sentences. I guess it ended up creating a separate thread.

Link to post
Share on other sites

I have verified it is not a problem with the folders not being shared.


I copied one of the music folders back to the root directory and made sure it was shared. I can access that folder on my wife's laptop, as well as the other music folders that are streaming successfully. The Sony player still won't access it. I went through the security properties of the working and non-working folder side by side and made sure they were exactly the same. I can't think of anything else to try.


My next system reload should be the next time I upgrade, and I plan on getting SSD for the o/s drive. I guess I will get a new SATA drive to put my music on and see if it will work if I start completely from scratch.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.