• 0

Static IP won't work


 Share

Question

patseguin

I have a home network with a router address of 192.168.1.1 and want to set up a static IP for my htpc for using an iPhone app remote for xmbc. I am putting in 192.168.1.15 as the address, 255.255.255.0 as the subnet and the router's address of 192.168.1.1 as the default gateway. I then set Google's DNS servers. I OK out of it and can't access the internet. I redo it and validate settings and what it does is just make it dynamic again, What am I doing wrong?

Link to post
Share on other sites

Recommended Posts

  • 0
+BudMan

well there is some other ways to work out the letters.. F'd Up Disinformation is my fav.. I think we agree with here " spreading misinformation"

The fact part is just normally people not knowing any better, and parrots do what parrots do ;) They see something on the interwebs and next thing you know its everywhere and people think it true because they see it everywhere.

Another one of my favorites that spread like wildfire was not broadcasting your SSID.. One on the worst pieces of FUD ever, and you still hear parrots repeat it.. That one also needs to die with fire!!

Even the makers of the routers themselves spread that nonsense.

Link to post
Share on other sites

  • 0
riahc3

Hello,

It all depends on the DHCP implementation. To be perfectly honest, you aren't really even suppose to set static IPs within a DHCP range. It is just that typical DHCP servers will check to see if the address is already taken via an ICMP broadcast before assigning any IP even if they haven't handed it out. Unfortunately, this can cause issues if the server hands out the address and then later a statically set computer comes online. If you have a poor DHCP server implementation, it may not even go that far, it might just outright fail if you try setting a static route within the dhcp specified range (and that's where weird gotchas come into play). I actually know of a few BSD based firewall/router solutions that specifically warn you to not set static IPs within the range because of unexpected behavior if you do (one of which I use to use back in 2007-8 in place of a consumer router).

I looked it up and you are correct :) I thought static assignment in a DHCP server is actually standard, just not correctly implemented by most manufacturers. But it seems it is not part of the standard:

http://tools.ietf.org/html/rfc2131

"weird gotchas" when you are doing something not in the standard is normal. 

 

It's a Netgear R6300. I looked at my DHCP settings and the range is 2-254. So, I'm not sure why 15 didn't work and 100 did.

Edit: What us FUD?

I read the manual for your router and I can't really see any limitations. Try what virtorio (16 or 14) and tell us if that works or not.

What Budman said is true: A DHCP server by itself cannot change a client from static to dynamic automatically.

I was going to post something about lease times and IP/mac reservations but seeing as the router is new, I imagine that it has nothing to do with what's happening here.

  • Like 1
Link to post
Share on other sites

  • 0
patseguin

I wonder if it was something stupid like a device on my network already had a dynamic address with 15. I'll bet that's it.

Link to post
Share on other sites

  • 0
+BudMan

Simple way to find out if something has .15 already - is you should of gotten a warning sim to my example when I set mine to my routers.

But even then it doesn't set it back to dhcp.. So not sure what you actually meant by that statement.

You can try pinging 192.168.1.15, even if you do not get an answer right after the ping command look in your arp table - do you see a mac listed for .15 ?

C:\>arp -a

Interface: 192.168.1.100 --- 0xb

Internet Address Physical Address Type

192.168.1.8 00-0c-29-55-4f-95 dynamic

192.168.1.40 2c-76-8a-ad-f6-56 dynamic

192.168.1.50 00-15-99-21-1c-a0 dynamic

192.168.1.97 00-1c-c3-09-05-7a dynamic

192.168.1.98 00-26-24-08-8a-ed dynamic

192.168.1.99 00-06-dc-43-ad-78 dynamic

192.168.1.253 00-50-56-00-00-02 dynamic

192.168.1.255 ff-ff-ff-ff-ff-ff static

224.0.0.22 01-00-5e-00-00-16 static

224.0.0.251 01-00-5e-00-00-fb static

239.255.255.250 01-00-5e-7f-ff-fa static

255.255.255.255 ff-ff-ff-ff-ff-ff static

Link to post
Share on other sites

  • 0
patseguin

Hello,

Very very likely. Did you test a address with 14 and 16? Did it work?

BTW, please mark as Best Answer whoever gave you a answer that was most detailed and explained everything.

I see I can mark it solved but not who gave the best answer. How do I do that?

Link to post
Share on other sites

  • 0
+BudMan

We don't know what the answer as yet.. Since from what I make of it the whole thing was operator error in you setting the static the first time.

I clearly went over the what and how, etc.

Here is the thing it is IMPOSSIBLE for anything on the router to set your client back to dhcp.. So clearly you were doing something wrong there.. Now you mention you had validate your settings on

post-14624-0-62466300-1388244418.png

If that is the case if there was a duplicate you would of gotten something like this right away

post-14624-0-05614700-1388244446.png

Then it would of changed you back to dhcp

post-14624-0-89008600-1388244463.png

So just trying a different IP, sure ok -- but you really should understand what is on your network.. Is there a .15 on your network? Depending on your dchp scope sure, or did you set something else static and forget about it?

If you want to use static IPs set on the client, then I suggest you write down all your machines your going to set static so you don't step on each other. And I would also suggest you make sure you understand what your current dhcp scope is .100 to .150, .50 to .100 .2 to .254? What and make you don't step on any IPs in that range with a static.

As also mention, an another option if you just want a machine to always get the same IP, which is better for say a laptop that changes networks vs setting it static on the device is a dhcp reservation. This is when on your router you setup by the mac of the machine an IP the dhcp server always gives it

Link to post
Share on other sites

  • 0
riahc3

Hello,

I see I can mark it solved but not who gave the best answer. How do I do that?

Each post has a "Mark Solved" button next to it, near the bottom-right. If you click that button, it will mark THAT POST as the marked answer.

I have helped you nothing and really backed up theories on why you are having problems. I do not have the best answer at all. On my post: https://www.neowin.net/forum/topic/1194017-static-ip-wont-work/page-2#entry596183365 you should now see a "Mark Unsolved" button. Reclick that since that post is not a solution and, like BudMan said, this problem really doesnt have a solution yet.

There are great explanations such as this one which you could mark as the best answer but it isnt the solution:

NO!! Sorry every single soho router I have ever seen uses a /24.. Most wont even let you change them to anything else. And if your router is 192.168.1.1 -- If your network is 192.168.1.0/24 then 192.168.1.15 is valid, unless you already have a .15 on the network.

Tell you what -- let me teamviewer in take a look, because what your saying is just nonsense plain and simple.

/24 or 255.255.255.0 gives you the last octet as your hosts, and the first 3 as your network. So

192.168.1.0/24 gives you

192.168.1.1 to 192.168.1.254 as viable host addresses with .0 being the wire or network and .255 the broadcast address

Does not matter what your dhcp server might be set to for scope .2 to .254 or .100 to .150, etc. .10 to .15 this is just what it hands out.. All the addresses are still valid. The only reason they would not be valid is if something else is already using it!!

Another thing, BudMan has repeated that he wouldnt mind to TV into your computer. Im not sure if you know what that means: There is a program called Teamviewer where you install it on your PC and giving a randomly generated ID and password, you give it once to BudMan and he can remotely connect to your PC and troubleshoot your problems. You ALWAYS see what BudMan is doing so if you feel what he is doing is not right or you arent comfy with it, simply disconnect and he will not be able to access your PC again.

This is the best way BudMan can troubleshoot your problem exactly as he know exactly what to do.

Take a look (its free): http://www.teamviewer.com/en/index.aspx

Link to post
Share on other sites

This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.