6 posts in this topic



I'm running into a bit of a problem at work with my new laptop and I'm hoping that someone will have a bit more experience and be able to help me.


I just got my new laptop at work yesterday and it's running Windows 8.1 Enterprise 64 bit. So far everything works great, except for one program which I use on a regular basis that doesn't seem to want to work properly, most likely due to a compatibility issue.


We use Exchange Server 2010 SP1 with rollup 8. I managed to install the management tools without too much of a headache, and when I run the management console, it does connect to the Exchange server, but I'm not able to do anything and I don't seem to have access to any functions to modify user mailboxes or distributions lists or public folders and what not. It worked perfect fine on my Windows 7 Pro desktop that I was using previously, but no luck so far on Windows 8.1.


Check out the attachment to see what I get when I access the Microsoft Exchange On-Premises portion.


Everything has loaded but I'm not able to access any other functions.


I'm pretty sure that Exchange 2010 SP1 management tools are not supported under windows 8.1 and as far as I can tell, only SP3 is supported, but I don't have the authority to upgrade our Exchange servers to 2010 SP3 or even 2013 since I'm just an IT Support guy.


Is anybody aware of any workarounds or fixes for this, besides RDC to a Windows 7 machine or accessing the servers directly?


Thanks in advance!


Share this post

Link to post
Share on other sites

Hold on, I have to pull the code from a server I have ...


create a .bat file with the following:


set COMPLUS_Version=v2.0.50727
"C:\Program Files\Microsoft\Exchange Server\V14\Bin\Exchange Management Console.msc"


Obviously replace the path with the correct one.


You will need powershell and .net framework 2.0.

Edited by episode

Share this post

Link to post
Share on other sites

Awesome! That works perfectly! Thank you!

Share this post

Link to post
Share on other sites

Hi I have exactly the same problem with my Windows 8.1 Enterprise x64 and Exchange Server 2010 SP1 Management tools. Created the .bat file as above but when I execute it I get this error (file attached)


What did you do different to fix it?

Share this post

Link to post
Share on other sites

I seem to remember getting a similar error until I ran windows update and got my exchange management tools updated to the same version as the exchange server. Another good tip is to run the .bat file as administrator otherwise you'll have trouble access the public folder management tool within the exchange management tools.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.