• 0

Virtual Machine unable to connect to the internet


Question

Suburban Errorist    6

I installed Mint Linux on VMWare player, and set the VM to use a bridged connection and to replicate a physical network state.

nwsettings_zpsf006a547.jpg

nwsettings2_zpsc55caef2.jpg

Initially, it worked fine, but somehow, after attempting to install Snort and restarting the VM, it could no longer connect to the internet, despite no changes were made to the VM's network connection settings, like in the screenshots below:

nwsettings4_zps1a2528d7.jpg

nwsettings5_zpsad663f40.jpg

nwsettings6_zps58cb05ab.jpg

I even checked Windows' firewall settings, but, that too appears to be unchanged.

nwsettings3_zps3bcfff2d.jpg

Does anyone have any idea what might have caused this problem and any suggestions on how to fix this?

 

Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0
+BudMan    3,748

So your vm got that info from dhcp?  Can you ping the gateway?  Why would you be bridging all 3 interfaces on your host machine?  is your host machine connected to internet via wire or wireless?  That is the only one that should be bridge.  And bridging wireless can have issues.

 

First thing to troubleshoot is to see if the linux vm can ping other devices on the network its on and can it ping the gateway (your router IP on that 192.168.1.0/24 network

Link to post
Share on other sites
  • 0
TDT    291

Try to use NAT and see if that's working :)

Link to post
Share on other sites
  • 0
Aergan    624

I would pick one adapter for starters, bridging all 3 (especially wired/wireless) is not going to bode well for reliability. Or create multiple NIC's on your VM and bridge individually if you need access to multiple networks.

Link to post
Share on other sites
  • 0
Arachno 1D    7,992

What IP address is the Mint install showing internally?

Link to post
Share on other sites
  • 0
Suburban Errorist    6

Try to use NAT and see if that's working :)

Oh yeah I forgot to tell you, I tried changing it to NAT and that didn't work too.

Link to post
Share on other sites
  • 0
Suburban Errorist    6

So your vm got that info from dhcp?  Can you ping the gateway?  Why would you be bridging all 3 interfaces on your host machine?  is your host machine connected to internet via wire or wireless?  That is the only one that should be bridge.  And bridging wireless can have issues.

 

First thing to troubleshoot is to see if the linux vm can ping other devices on the network its on and can it ping the gateway (your router IP on that 192.168.1.0/24 network

 

Well, I'm usually connected to the internet via wireless. Also, I actually removed and reinstalled Linux on the VM, but I don't think it'll be consider solved, since I'm wary that it might happen again.

Link to post
Share on other sites
  • 0
Suburban Errorist    6

Well, sorry to resurrect this thread after almost a week. So, I've reinstalled Linux MInt and was installing Snort, when the problem reared its ugly head again.

 

I've followed the previous advice of sticking to only one adapter, as advised earlier:

 

VMwareissue_zpsc3e0b91c.jpg

 

And it worked fine, before it somehow wouldn't connect to the internet again.

 

So, I checked ifconfig in linux:
 

VMwareissue2_zps0bd1f573.jpg

 

And I could ping it from the host machine, as shown below:
 

VMwareissue3_zpsf003e085.jpg

 

So I checked to see if I could ping the host machine from the guest machine:

 

VMwareissue4_zps521a3c11.jpg

 

and I got this:

VMwareissue5_zps9c05e722.jpg

 

But then I noticed this:

 

VMwareissue6_zps084add95.jpg

 

and this is what happens when I tried to ping it:

 

VMwareissue7_zpsb15af3c9.jpg
 

Does anyone have any idea why this happened?

Link to post
Share on other sites
  • 0
StarkWiz    12

It seems you have some confusion about how VMnet adapters work.

By default the VMnet adapters are selected as below:

VMnet0 - Used when bridging option is selected

VMnet1 - Used when you select the host only mode

VMnet2/8 - Used when you select the NAT option. (You cannot ping 192.168.136.1 because you are connected to VMnet0)

 

If you go to Edit -> Virtual Network Editor.. you'll see how each of the adapter is configured and indeed change the default configuration completely as you need.

If you are using the default configuration, you should see VMnet1 and VMnet2/8 in your windows network connection.

VMnet0 cannot be seen because it is bridged with your physical adapter directly and Windows Firewall doesn't affect the connectivity between your VM and physical network.

 

I am not quite sure which version of VMware you are using but if you often switch between wifi and lan, I would like you to suggest selecting atheros ethernet adapter as well and in VM settings untick "Replicate physical network state", so that the VM doesn't see the network link getting disconnected when you switch.

 

I am using VMware 9 and it works flawlessly when I switch between the 2 :)

 

I hope this helps.

Link to post
Share on other sites
  • 0
Suburban Errorist    6

So...how do I do that in VMWare Player?  :s  That sounds like something out of VMWare workstation, to be honest.

Link to post
Share on other sites
  • 0
offroadaaron    231

1) Okay so you can bridge all the network adapters because it will automatically choose the one connected and has the best metric.

2) 192.168.136.1 is most-likely for the NAT you can't ping that address because it's in a different subnet and there'll be no route to it.

3) Can you ping google DNS 8.8.8.8, if yes, then it's a DNS issue.

4) If you can't ping 8.8.8.8 then it's most-likely a default gateway issue and you should look up make sure you can ping the gateway first (192.168.1.1)

5) if you can ping the gateway then local LAN connectivity to the gateway is fine and you need to check the correct gateway is set (netstat -rn)

6) Reinstalling will do nothing.

 

Well, sorry to resurrect this thread after almost a week. So, I've reinstalled Linux MInt and was installing Snort, when the problem reared its ugly head again.

 

I've followed the previous advice of sticking to only one adapter, as advised earlier:

 

 

 

And it worked fine, before it somehow wouldn't connect to the internet again.

 

So, I checked ifconfig in linux:
 

 

 

And I could ping it from the host machine, as shown below:
 

 

 

So I checked to see if I could ping the host machine from the guest machine:

 

 

 

and I got this:
 

 

But then I noticed this:

 

 

 

and this is what happens when I tried to ping it:

 

 

Does anyone have any idea why this happened?

Link to post
Share on other sites
  • 0
Suburban Errorist    6

Well, I followed the instructions, and here are the results:

 

Ping 8.8.8.8:

 

VMWareissue8_zps5e301041.jpg

 

Ping 192.168.1.1:

 

VMWareissue9_zpsd9cbe0d5.jpg

 

and running netstat-rn:
 

VMWareissue11_zps00ba6a02.jpg

So by the looks of it, it's a DNS issue. Any suggestions on how to fix it?

Link to post
Share on other sites
  • 0
+BudMan    3,748

You do understand 192.168.1.1 was telling you cant get to 8.8.8.8

 

Do you have mac filtering on your router?  As stated before bridging wireless can bring its own pain.  You can look into why you can not get to 8.8.8.8 -- but wouldn't you just be using your router as your dns?  In your min what does your resolve.conf show for your name server?

 

example

root@observium:/tmp# cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.1.253
search local.lan
 

If you do a nslookup or dig or host on mint what does it show you for your nameserver?

 

budman@observium:~$ nslookup www.google.com
Server:         192.168.1.253
Address:        192.168.1.253#53

Non-authoritative answer:
Name:   www.google.com
Address: 173.194.46.50
Name:   www.google.com
Address: 173.194.46.49

 

Its quite possible your issue is related to dns - but you need to understand what exactly your using for dns, and why is it not resolving - can you not get there like your ping shows, is your router blocking you from the internet because your bridging wireless?  etc. etc..
 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.