• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Fix : Windows 10 accessing network drives : Password incorrect

Recommended Posts

C.H. Tech Man    1

Yes, I was wondering WTF was going on with windows 10...the usual 'user name and password only' would not work as it did in previous windows versions. Well some of the previous versions anyway. Windows 10 does indeed need the computername/username combo in the user box for GUI shares. Thanks Guys for clearing this up. I was sitting here hitting the pipe and thinking WTF and then turned to google and found this blog, completely forgetting my training about good practices to use the combo\combo technique when dealing with remote shares/logins etc. Not sure why windows 10 requires this but all that matters is that we know NOW how it works...trying to understand 'why' is something i am not sure even Microsoft knows. LOL

Edited by C.H. Tech Man
  • Like 1

Share this post


Link to post
Share on other sites
HawkMan    5,230

Yes, I was wondering WTF was going on with windows 10...the usual 'user name and password only' would not work as it did in previous windows versions. Well some of the previous versions anyway. Windows 10 does indeed need the computername/username combo in the user box for GUI shares. Thanks Guys for clearing this up. I was sitting here hitting the pipe and thinking WTF and then turned to google and found this blog, completely forgetting my training about good practices to use the combo\combo technique when dealing with remote shares/logins etc. Not sure why windows 10 requires this but all that matters is that we know NOW how it works...trying to understand 'why' is something i am not sure even Microsoft knows. LOL

Well it doesn't, but sometimes it does... but usually it doesn't. there is somethign special about the cases where it does. 

Share this post


Link to post
Share on other sites
Max    50

I think I encountered the same thing a couple of months ago - I ended up redoing the Homegroup from scratch on a small network and that sorted it.

Share this post


Link to post
Share on other sites
+BudMan    3,197

homegroups.. Yeah that could throw a wrench into it.. Who said anything about homegroups?? OP sure didn't make any mention of it -- but since windows like to fire it up with really asking you if you want it..  That could mess up fire sharing for sure.

Share this post


Link to post
Share on other sites
electriac    1

I give up returning to Win7

  • Like 1

Share this post


Link to post
Share on other sites
HawkMan    5,230

I give up returning to Win7

what? give up what, you haven't even posted in this thread?

  • Like 1

Share this post


Link to post
Share on other sites
WarnerL    0

You are the best +warwagon. I was also wondering WTF was going on but once I tried your solution, it worked perfectly. But I discovered the problem only arises when the first Win10 machine is logged into a microsoft account and trying to access the network shares of another Win10 machine. The Win10 machine that is logged into a microsoft account can access the network share of my Win7 machine with just the straight username/password but trying to access the Win10 machine requires your solution. If the first Win10 machine is logged in using a local account instead of the microsoft account, then it can access the Win10 and the Win7 machine with just the username/password with no need for your solution.

Share this post


Link to post
Share on other sites
Borhan Uddin    0

Thank you very much, worked like a charm!

Share this post


Link to post
Share on other sites
BinaryData    777

I'm reading this, and all the posts. It doesn't make sense why people would have issues. Even if you use the same username, which I do for all of my VMs, i.e. vmubu / winadmin. I've never had this problem, occasionally I have issues with devices being shown on the network, specifically my laptop, but that's just some settings that need to be changed.

 

Oh well.

Share this post


Link to post
Share on other sites
Jared-    575

<machine name>\<user name> ALWAYS best practice. Can't think of a time where i haven't entered credentials like <. 

 

 

Share this post


Link to post
Share on other sites
offroadaaron    225
52 minutes ago, Jared- said:

<machine name>\<user name> ALWAYS best practice. Can't think of a time where i haven't entered credentials like <. 

 

 

I can't remember I time that I have...

Share this post


Link to post
Share on other sites
Jared-    575

So if you're working on a domain joined machine, and you want to authenticate using a local account, how would you go about it?

 

 

Share this post


Link to post
Share on other sites
offroadaaron    225
31 minutes ago, Jared- said:

So if you're working on a domain joined machine, and you want to authenticate using a local account, how would you go about it?

 

 

.\username

 

You didn't think I'd have an answer to your question did you ;) 

Share this post


Link to post
Share on other sites
Jared-    575

On a local machine that'd work, but what if I was on a remote machine wanting to authenticate using a local account?

 

^^

Share this post


Link to post
Share on other sites
offroadaaron    225
28 minutes ago, Jared- said:

On a local machine that'd work, but what if I was on a remote machine wanting to authenticate using a local account?

 

^^

Are you sure about that? I'll give you a pro tip ;) 

 

Spoiler

it works remote and local

 

Share this post


Link to post
Share on other sites
Jared-    575

I can use .\ to authenticate to a remote machine using a local account that's living on the remote machine? 

 

I would've thought using .\ would tell Windows to try and authenticate using a local account that's living on my machine?

 

Cool! You learn something new every day ;) 

  • Like 1

Share this post


Link to post
Share on other sites
offroadaaron    225
2 hours ago, Jared- said:

I can use .\ to authenticate to a remote machine using a local account that's living on the remote machine? 

 

 100% you can.

 

I would've thought using .\ would tell Windows to try and authenticate using a local account that's living on my machine?

What do you think it does when you're not on a domain then? .\ makes It authenticate exactly the same as if you weren't on a domain.

Share this post


Link to post
Share on other sites
+Thayios    229
On 9/20/2015, 8:36:39, BudMan said:

And is NOT required if box your authing to is not a member of a domain..  As you clearly see from multiple examples sending BS as domain\computername still auths since the machine can only check its local account base.  Yes if your going to auth to a member of a AD machine, then you would have to specify which you want to use its account or domain account or you could run into problems.

Normally if your on AD, then your machines would both be members and you wouldn't have to get a popup since your domain account have been given permissions by the admin of the domain.

This is correct, it only matters if you're on a domain (so you need to specify DOMAIN\UserX), otherwise you can use WHATEVER\UserX and it'll connect just fine.

 

If you've got HomeGroup Sharing turned on is the only other thing I can think of that would mess with Auth (and even then I'm not 100% sure it does change anything)

Share this post


Link to post
Share on other sites
+BudMan    3,197

homegroup sharing woudln't have any issues.. I take it these users are using MS accounts vs local..  Which changes everything..  Really need to clarify if your talking apples or oranges...   This is EXACTLY how FUD gets started and spreads... Someone thinks they found a solution, when really does not even apply..

 

Waiting for someone to say they need to be in the same workgroup ;)

Share this post


Link to post
Share on other sites
Jared-    575

Yeah I'm talking Domain accounts vs local accounts here. I should've prob made myself clear. 

 

Whatevs, I forget the reason this thread is here anyway lol

Share this post


Link to post
Share on other sites
offroadaaron    225

For home use with Microsoft logins (whatever you call it) you know you can use credential manage to manage connections, right? So say I connect to my NAS and it's named fileserver I can go to credential manager under that account (the MS account) and add in the network address (fileserver) and then the username and password, that way if I want to have a login script to map drives or browse to fileserver I don't need to type a password in under that account.

 

I think I might be a bit off-topic though, but it's an option that might help.

Share this post


Link to post
Share on other sites
Packet1009    49

posting here just to agree with everything that BudMan says (he's doing the Lord's work in keeping you lot on the straight and narrow)
 

Share this post


Link to post
Share on other sites
offroadaaron    225
7 hours ago, Packet1009 said:

posting here just to agree with everything that BudMan says (he's doing the Lord's work in keeping you lot on the straight and narrow)
 

Are you just blindly saying that without technically knowing what he is saying? Because it seems so.

  • Like 2

Share this post


Link to post
Share on other sites
Jared-    575
9 hours ago, Packet1009 said:

posting here just to agree with everything that BudMan says (he's doing the Lord's work in keeping you lot on the straight and narrow)
 

LOL! Yeah and I wouldn't take half of the advice he spits out sometimes too...

 

Share this post


Link to post
Share on other sites
Packet1009    49

*sigh* and here we go again...

 

i am not aware of any posts of his where his advice has been incorrect - however, i do not follow every dashed thing he posts.

 

 

in this case, however, he's spot on - specifying a workgroup is absolutely pointless and unnecessary.


 

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.