Windows 10 Taskbar Icons look awful


 Share

Recommended Posts

The icons are also messed up in the Group Policy Editor. They don't seem to honor the transparent background of the ICO resources and instead shows an unsightly black background:

 

iVM3qIi.png

 

Though Taskbar icons are working OK for me. I like how compact they are per row:  http://i.imgur.com/siDem1Y.png

[Not using IMG code for that one because its super wide] 

I have that issue as well on a clean retail install.

Link to comment
Share on other sites

The icons are also messed up in the Group Policy Editor. They don't seem to honor the transparent background of the ICO resources and instead shows an unsightly black background:

 

iVM3qIi.png

That's just MS messing thing up, also see it here :p

The black behind the icon might just be a msstyles thing, I'll look into it with windowsstylebuilder when I'm fixing the aerosnap borders too.

Link to comment
Share on other sites

Yeah, I see the same with GPEdit.

Still no idea what's wrong, or how to fix it. It's not a huge problem as I'll likely not be using most of the ModernUI apps anyway. The only ones I'm likely to open are Map and Store.

I just noticed something else, if I open the Start menu, and type out the app I want - say 'Map' - it also gets the icon wrong, completely wrong for ModernUI apps. However desktop apps it gets right. There is something really wrong with how it reads and/or displays the main icons of ModernUI apps.

 

startmenu.png

startmenu2.png

Link to comment
Share on other sites

Hello! Found this thread from a Google search since I had the exact same problem, but I got it solved on my end so I figured I should share.

Chances are it's caused by a shell extension like SageThumbs, Icaros or Media Preview. It was Boo Berry's post that got me on the right track. I have SageThumbs, which I use primarily to give Photoshop docs thumbnails, but I found it was also messing with the thumbnail icons of these ModernUI apps, which are stored as .pngs.

I disabled SageThumbs and deleted the thumbnail cache (run cleanmgr.exe), and after a restart, all the icons look like they should, and they show up when searching in the Start menu too. Hope this helps!

  • Like 3
Link to comment
Share on other sites

Thanks parmesanforever. I did have SageThumbs installed, so I've removed it. It's fixed the problem of the icons not appearing correctly in the Start menu, but not on the taskbar, they're still as broken as ever.

 

I've no idea why MS thought these black and white icons were a good thing either. There is mountains of research (even conducted by MS) that shows that colour cues are hugely important for helping people recognise and navigate user interfaces. Unless we've all changed drastically in the last 5 years (I haven't) then this new look won't work.

Link to comment
Share on other sites

Hi, my english is bad, but...

When start Windows 10 in Safe mode, the icons on taskbar are look good.
Maybe, some services have bugs in Windows 10.

Atention: I did upgrade from Windows 7, on 2 august.

Link to comment
Share on other sites

That looks like a driver problem.

I have an Nvidia GTX970 and I'm using the driver that came through Windows Update. No problems at all. I don't even know which version it is to be honest.

Link to comment
Share on other sites

Try going into device manager, right-click your graphics card, click "uninstall driver", reboot (may require several re-boots).

Was about to post this, I had the same troubles with my Nvidia (560 GTX) card, and eventually Windows installed the proper driver on the 3rd boot automatically. You may have to open the action bar and click "Finish installing device drivers".

Link to comment
Share on other sites

Was about to post this, I had the same troubles with my Nvidia (560 GTX) card, and eventually Windows installed the proper driver on the 3rd boot automatically. You may have to open the action bar and click "Finish installing device drivers".

They updated the drivers one or two days before the RTM. When I was playing around with the preview, I was having all kinds of problems. Now everything runs 100% smooth.

Kinda neat that we get them through Windows Update now. I wonder how close they are to the Nvidia releases. 

I do have sound problems, though, but only in Chrome. Audio is choppy for some reason. 

Link to comment
Share on other sites

They are pretty close now, but that is mainly because there were a lot of issues with the mobile chip versions. The issue I kept having is that the second monitor would randomly disconnect, only a reboot fixed it.. but it has been OK this past week. I had it more often with the Insider preview (also the Insider RTM).

Link to comment
Share on other sites

I just installed the latest Windows updates, including KB3081424, and the icons are fixed! Yay!

I mean the black and white ones are still ugly as hell, but at least they're the ugly ones that MS intended rather than ugly corrupted ones. Still can't get over the fact that MS thinks they look good, and are ignoring their own research (and others) that show that colours are a vital part of UI navigation and recognition.

Link to comment
Share on other sites

I just did the upgrade from Win7 Pro today, which didn't go all that smoothly. Despite having updated drivers for my sound and graphics neither worked after the update and had to be fixed manually. But they seem to be working now. However the taskbar icons for the built in apps seem to be broken. Half of the, are just white squares, or just really ugly icons. I'm not a fan of the black/white icons in the system tray but they looks positively gorgeous in comparison.

How do I fix this?

Screen shot shows the icons for Edge, Mail, Groove, Get Started, Film & TV, Contacts, Calendar, Alarms, 3D Builder, Calculator, Solitaire, XBox, Store, and Maps.

Taskbar Icons.png

I found the solution!

The problem is in sagethumbs...

...so go in sagethumbs and disable png support, then clear both cashes,  (system thumbnail cash and sage cash)

 

 

  • Like 1
Link to comment
Share on other sites

I found the solution!

The problem is in sagethumbs...

...so go in sagethumbs and disable png support, then clear both cashes,  (system thumbnail cash and sage cash)

 

 

Except that I had already uninstalled SageThumbs and it made no difference. Applying the latest updates/fixes however did fix it.

  • Like 2
Link to comment
Share on other sites

If you cleared your IconCache (which rarely works nowadays), have you tried rebuilding your Windows Profile? Create another account and see if the issue persists. If it works correctly, remove your old and recreate it.

Link to comment
Share on other sites

  • 2 weeks later...

1. Uninstall any 3rd party shell extension that handles PNG image format (SageThumbs, Icaros, etc.)
2. Run: cleanmgr.exe to clear your thumbnail cache
3. Run: taskkill /F /IM explorer.exe (or restart the computer)

Icaros will fix this issue soon.

Link to comment
Share on other sites

Again, as I already stated, this was fixed 11 days ago by a Windows Update.

1. Uninstall any 3rd party shell extension that handles PNG image format (SageThumbs, Icaros, etc.)
2. Run: cleanmgr.exe to clear your thumbnail cache
3. Run: taskkill /F /IM explorer.exe (or restart the computer)

Icaros will fix this issue soon.

Link to comment
Share on other sites

  • 3 months later...

I just made an account to say thanks for the suggestions, this one worked for me after having this issue since one of the more recent windows 10 updates. 

 

On 8/21/2015, 8:55:06, Awesoft said:

1. Uninstall any 3rd party shell extension that handles PNG image format (SageThumbs, Icaros, etc.)
2. Run: cleanmgr.exe to clear your thumbnail cache
3. Run: taskkill /F /IM explorer.exe (or restart the computer)

Icaros will fix this issue soon.

Slugsie i imagine when you disabled png support in sagethumbs then got a recent update the cache may have been cleared in the process.

 

But for anyone having the issue still with Sagethumb 2.0.0.22 the above should work for you. Thanks again!

Link to comment
Share on other sites

On 10/08/2015, 17:36:49, dunkel_Stern said:

I found the solution!

The problem is in sagethumbs...

...so go in sagethumbs and disable png support, then clear both cashes,  (system thumbnail cash and sage cash)

 

 

Thanks a lot man it worked...! i used ccleaner and sage thumbs 64bit options..................!:D

Link to comment
Share on other sites

This topic is now closed to further replies.
 Share