• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Can't search settings

Recommended Posts

ViperAFK    797

All of the sudden, search got borked on my main windows 10 pc. I can't get results for ANYTHING from the new settings app (e.g. windows update etc...). doesn't matter if I search from the start menu, or directly within the settings app, I can't get any results for anything in the modern settings app, only desktop apps, store apps and classic control panel results. Here's some examples of what I'm seeing:

 

menu.thumb.png.9f7b4589bcb698ed6033dae83settings.thumb.png.1c68fb14f6ec6236ac2a0

I've tried everything I could think of. I've totally re-indexed several times from the indexing pane, verified the correct locations are set to be indexed, and also tried totally resetting indexing to factory defaults by going to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search and setting SetupCompletedSuccessfully to 0 and letting it index.

I've run sfc scannot and DISM check, they both report no errors. I really don't understand why this is happening :( Has anyone else ran into this?

EDIT: I've also run the windows search troubleshooter as admin which reported everything was fine

Edited by ViperAFK

Share this post


Link to post
Share on other sites
TAZMINATOR    12,416

To solve this, here what to do:

1. Go to settings

2. Go to Update and Recovery

3. Click on Recovery

4. Click on Restart now button.

5. Once it is restarted, click Troubleshoot > Advanced > Reset

6. Follow the instructions on the screen when Reset starts. (Note, you can keep your data or keep nothing... if keep nothing, make sure you have backup already, if not, do it first before doing this reset steps)

7. You get back on Windows and you check and see if problems are solved.

Share this post


Link to post
Share on other sites
Anibal P    2,055

Question is, what did you disable? something had to happen, as cranky as windows can be it rarely just "stops working" for no reason, not since Vista at least

 

What "tweaks" are you running or what have you disabled? Last couple of programs installed after the upgrade? 

Share this post


Link to post
Share on other sites
ViperAFK    797

As someone that works in tech support that's normally my first response too lol, however I'm really at a loss as to what could have caused this.

no 'tweaks', no tweaking/cleaning apps, no messing around in services or registry (well at least until I tried resolving this issue when it appeared), very few apps installed (just steam, origin, gog, firefox, opera, flash player, libreoffice, paint.net, foobar2000, onenote).

Edited by ViperAFK

Share this post


Link to post
Share on other sites
ViperAFK    797

ended up having to reset as TAZMINATOR suggested, and that did the trick (as expected)

Share this post


Link to post
Share on other sites
dms666    0

I have the exact same problem ! !

It just stopped working properly on its own. One day it was fine, the next, phhhht! 

I get the exact same result, for example, when searching for "update" in PC Settings. Items that I used to be able to search for, no longer appear!

I would really like to solve this without having to reset and reinstall all my apps. I already did that to get to Windows 10 in the first place.

 

 

All of the sudden, search got borked on my main windows 10 pc. I can't get results for ANYTHING from the new settings app (e.g. windows update etc...). doesn't matter if I search from the start menu, or directly within the settings app, I can't get any results for anything in the modern settings app, only desktop apps, store apps and classic control panel results. Here's some examples of what I'm seeing:

 

menu.thumb.png.9f7b4589bcb698ed6033dae83settings.thumb.png.1c68fb14f6ec6236ac2a0

I've tried everything I could think of. I've totally re-indexed several times from the indexing pane, verified the correct locations are set to be indexed, and also tried totally resetting indexing to factory defaults by going to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search and setting SetupCompletedSuccessfully to 0 and letting it index.

I've run sfc scannot and DISM check, they both report no errors. I really don't understand why this is happening :( Has anyone else ran into this?

EDIT: I've also run the windows search troubleshooter as admin which reported everything was fine

Share this post


Link to post
Share on other sites
ViperAFK    797

I have the exact same problem ! !

It just stopped working properly on its own. One day it was fine, the next, phhhht! 

I get the exact same result, for example, when searching for "update" in PC Settings. Items that I used to be able to search for, no longer appear!

I would really like to solve this without having to reset and reinstall all my apps. I already did that to get to Windows 10 in the first place.

 

 

 

Hi dms666, try this:

navigate to C:\Users\YOURUSERNAME\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState

Right-click the 'Indexed' folder > Properties > Advanced > Check 'Allow files in this folder to have indexed in addition to file properties'. Click Apply and Exit.

If it's already checked, try unchecking it > apply > recheck it > apply

I've seen this fix it for a few others that ran into this

  • Like 1

Share this post


Link to post
Share on other sites
dms666    0

THIS SOLUTION WORKED!!   :woot:

Thank you!

 

 

Hi dms666, try this:

navigate to C:\Users\YOURUSERNAME\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState

Right-click the 'Indexed' folder > Properties > Advanced > Check 'Allow files in this folder to have indexed in addition to file properties'. Click Apply and Exit.

If it's already checked, try unchecking it > apply > recheck it > apply

I've seen this fix it for a few others that ran into this

Share this post


Link to post
Share on other sites
TGS    0

I have the same problem as dms666 had and you, but my situation is different.

I started trying to solve this problem according to your solution (ViperAFK) and then I found out that I don't have such folder as 'Indexed' WTF

Can I fix it by downloading this folder and files?

How do I fix it?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.