• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Just upgraded to FF 42 X64, now I can not access https sites

Recommended Posts

jnelsoninjax    12,561

When I attempt to access sites such as YouTube. I get this:

Firefox.thumb.PNG.f45eea843188d37044fe4f

What can I do to get around this issue?

Share this post


Link to post
Share on other sites
Som    430

check if your date and time are set correctly

Share this post


Link to post
Share on other sites
jnelsoninjax    12,561

Date and time are automatically set and they are correct

Share this post


Link to post
Share on other sites
Circaflex    3,580

are you running adguard by chance?

I did a quick google for your username, it seems you have adguard. I have had this issue before, here is what you need to do:

First, I would uninstall the current version of adguard you have installed.

Next, download this version from their website (they have fixed some of these issues that make this error happen) https://github.com/AdguardTeam/AdguardForWindows/releases, download the .487 beta

Now, make sure you restart the PC after uninstalling adguard. Once back up, make sure you DO NOT OPEN FIREFOX. Install adguard. Once it is finished, try going to a https website. if you still get an error, go into adguard settings, under general at the very bottom there is an option to reinstall the certificate, do that and test again. Best option is uninstalling and reinstalling adguard though, chances are adguard was running when you upgraded firefox and it corrupts the certificate.

Share this post


Link to post
Share on other sites
jnelsoninjax    12,561

Actually no, I am not running adguard on the PC, I am running it on my Android. I am using uBlock Origin on the PC

Share this post


Link to post
Share on other sites
Circaflex    3,580

The file cert8.db in your profile folder may have become corrupted. Delete this file while Firefox is closed.

  1. Open your profile folder:

    Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show Folder. A window with your profile files will open.
  3. Click the menu button New Fx Menu and then click Exit Close 29 .

  4. Click on the file named cert8.db.
  5. Press Delete.
  6. Restart Firefox.

This should fix it.

Share this post


Link to post
Share on other sites
jnelsoninjax    12,561

Already tried that. :( still does the same thing.

Share this post


Link to post
Share on other sites
Circaflex    3,580

Have you tried backing up your book marks, uninstalling firefox and reinstalling? What AV do you use?

Share this post


Link to post
Share on other sites
jnelsoninjax    12,561

I am about ready to uninstall! I should mention: I did not 'upgrade' per se, I was using Cyberfox and now I installed FF X64 and copied my profile over. I am using Kaspesky Total Security 16

Share this post


Link to post
Share on other sites
Circaflex    3,580

More than likely something within the profile has become corrupted. I would backup what you can from cyberfox or firefox, uninstall both. Delete any left over folders they had and reinstall.

  • Like 1

Share this post


Link to post
Share on other sites
Torolol    926

I am about ready to uninstall! I should mention: I did not 'upgrade' per se, I was using Cyberfox and now I installed FF X64 and copied my profile over. I am using Kaspesky Total Security 16

is FF without copied-profile from Cyberfox works?

Share this post


Link to post
Share on other sites
jnelsoninjax    12,561

is FF without copied-profile from Cyberfox works?

No, I just made a new blank profile, and it still will not work.

Share this post


Link to post
Share on other sites
jnelsoninjax    12,561

OK, I just did a fresh install, I used IOBit uninstaller to completely remove it, re-installed, and it still does the same thing, even before recovering my profile.

Share this post


Link to post
Share on other sites
Circaflex    3,580

do any other browsers work? ie/edge?

Share this post


Link to post
Share on other sites
Night Prowler    132

Same thing here. Other browsers work fine...

Share this post


Link to post
Share on other sites
Circaflex    3,580

That is very strange. I know this might be a hassle, but it would be a great troubleshooting step. Create a temporary local account for windows and test FF within the new profile and see if it works.

Share this post


Link to post
Share on other sites
+devHead    2,014

I've always had this issue with older Firefox builds at work, but never at home. But the same thing - nearly every site I got the page saying it was untrusted.  I finally gave up and use Chrome at work now.  But at home, Firefox works fine. But if this is happening with the x64 build, I'll probably avoid it for now.

Share this post


Link to post
Share on other sites
Circaflex    3,580

Have you ever had family settings turned on?

Share this post


Link to post
Share on other sites
jnelsoninjax    12,561

do any other browsers work? ie/edge?

Yes, as I stated Cyberfox works as does Edge

Have you ever had family settings turned on?

No.

Share this post


Link to post
Share on other sites
Obi-Wan Kenobi    1,121

Same thing happening here, fresh FFx64 install (Fresh, as in it's never even been installed on this machine until now).....all other browsers work just fine....so....hmm......(thought I'd retry firefox after several years, but this is leaving a bad taste in my mouth.....)

Share this post


Link to post
Share on other sites
jnelsoninjax    12,561

The million dollar question is " Is it Firefox? or Windows, etc." It is very strange that my roommate just installed FF 42 X64 and it (ssl, youtube, etc.) works just fine for him.

Share this post


Link to post
Share on other sites
Obi-Wan Kenobi    1,121

Hmm....this is strange. I do use adguard (please don't come down hard on me, fellas), but I've tried everything mentioned here, and that didn't work either. Oh well, I'm sure it'll get sorted out soon. (Error code: sec_error_unknown_issuer is what I'm seeing just by trying to visit youtube in FF. So it has to be some security cert issue or something, IDK)

Share this post


Link to post
Share on other sites
Circaflex    3,580

i have also been running it, for a while, without this issue. the only time I did, was because of adguard

Share this post


Link to post
Share on other sites
Torolol    926

Youtube use "GeoTrust Global CA" as the CA issuer,
that CA issuer should be shown in the built-in CA list.

Just checking, are you able to see the built-in CA list on FF?
Option | Certificates | View Certificates | Authorities

Share this post


Link to post
Share on other sites
Obi-Wan Kenobi    1,121

I see the certs, and GeoTrust GlobalCA is listed....so IDK, I'm going to disable adguard and try again. 

 

EDIT: Yep, disabled adguard, worked flawlessly. Guess I'll go file a report.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.