Script for youtube that disables autoplay and annotations?


Recommended Posts

+jnelsoninjax

I find myself watching allot via YouTube but the thing that annoys me the most is the stupid annotations and the insistence of auto playing the next video that might be related to what you're currently watching.  Is there a script or something for FF that I can add to stop this? I already have html5 video not playing automatically, but inside of YouTube this doesn't mater after the first video. I know that it can be turned of per session but I'm looking for a permanent fix, if such a thing exits. Thanks!

 

  • Like 1
Link to post
Share on other sites
Jose_49
2 minutes ago, jnelsoninjax said:

I find myself watching allot via YouTube but the thing that annoys me the most is the stupid annotations and the insistence of auto playing the next video that might be related to what you're currently watching.  Is there a script or something for FF that I can add to stop this? I already have html5 video not playing automatically, but inside of YouTube this doesn't mater after the first video. I know that it can be turned of per session but I'm looking for a permanent fix, if such a thing exits. Thanks!

 

You can disable autoplay in the right corner. 

Autoplay disable.PNG

 

Edit:

Rereading your post... I don't know if you have already turned off or not, but I've never seen another video after I had this thing off. It works wonders.

Link to post
Share on other sites
Jose_49

Click on your picture (top-right corner), and click the gear button. This will bring you to YouTube Account Settings. 

 

Hit Playback, and uncheck "Show annotations and in-video notifications"

anno.PNG

Link to post
Share on other sites
TDT
2 minutes ago, Jose_49 said:

Click on your picture (top-right corner), and click the gear button. This will bring you to YouTube Account Settings. 

 

Hit Playback, and uncheck "Show annotations and in-video notifications"

anno.PNG

Maybe he doesn't have a YouTube account? :)

Link to post
Share on other sites
The Evil Overlord

I just tried this in ff, no addons

 

I'm not sure if it helps, but this was not signed in neither

 

Image1.jpg

  • Like 1
Link to post
Share on other sites
  • zhangm changed the title to Script for youtube that disables autoplay and annotations?
+jnelsoninjax
12 minutes ago, Jose_49 said:

Click on your picture (top-right corner), and click the gear button. This will bring you to YouTube Account Settings. 

 

Hit Playback, and uncheck "Show annotations and in-video notifications"

anno.PNG

I never knew about this, thanks!

 

7 minutes ago, Jose_49 said:

This will work, thanks!

  • Like 1
Link to post
Share on other sites
+jnelsoninjax
13 minutes ago, The Evil Overlord said:

I just tried this in ff, no addons

 

I'm not sure if it helps, but this was not signed in neither

 

Image1.jpg

I know about this option, however I am looking for a permanent solution, not just a per video.

Link to post
Share on other sites
+Zagadka

FlashControl (formerly FlashBlock? Meh, same thing) tends to take care of all pages loading video.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.