Can't get 5.1 sound working between PC and AV receiver

Recommended Posts

Elliot B.    1,220

Soundcard: Asus Xonar DSX

AV receiver: Pioneer VSX-324-K-P

 

I've connected the two together via. an optical cable.

 

On the AV receiver, I've followed the instructions on pages 15 and 20 of the manual above to switch to optical input.

 

In Windows, I've right-clicked on "S/PDIF Pass-through Device" in Sound and chosen "Set as Default Device".

 

In the "Xonar DSX Audio Center" program, I've used the following:

 

eb_xdac-1.png

 

Audio Channel: 6 Channels

Sample Rate: PCM 96 KHz

Analog Out: 5.1 Speakers

SPDIF: PCM (though I've also tried DTS Interactive)

 

Using the settings above, if I click on the front left or front right speakers,  they both come out of the correct speakers that are connected to the AV receiver.

 

However, if I click on the rear, center or sub speakers, I hear nothing.

 

Any ideas?

Share this post


Link to post
Share on other sites
xendrome    4,749

Do you have the receiver on a 5.1 profile?

Share this post


Link to post
Share on other sites
Elliot B.    1,220
11 minutes ago, xendrome said:

Do you have the receiver on a 5.1 profile?

I just press DVD then Signal Select until O1 appears, as per the manual.

 

I'm not sure about profiles.

Share this post


Link to post
Share on other sites
xendrome    4,749
8 minutes ago, Elliot B. said:

I just press DVD then Signal Select until O1 appears, as per the manual.

 

I'm not sure about profiles.

Each input should have different sound profiles, like 2 channel stereo, straight 5.1, 5.1 stereo, etc. Check the manual

Share this post


Link to post
Share on other sites
Hahaiah    296

I have a Pioneer running direct from PC also as TVs only pass 2 ch stereo (at least the ones I have).

When you right click your speaker icon in the task tray and get into the settings of your playback devices (the optical out of the sound card), under advanced you should see DTS at the bottom of the drop down menu as a choice, if not, you may need proper drivers as W10 naked installs don't do it.  Also for my system, I use 48khz.  When DTS sound is playing, if your Pioneer is like mine, you'll get a visual indicator on the receiver saying so. 

 

Side note: I have to run an audio file in the background looping constantly to avoid the lag of windows switching back to 2 ch when no sound is being played...this also threw me off when listening to test sounds as the first 2 wouldn't be heard due to the lag.  Had the same problem with another completely different system using this receiver so it may be a "Pioneer thing" (mine's a cheap one)

 

I've read numerous people having issues with DTS still not working on windows 10, I'm using an Asrock Tai Chi board so I feel lucky.  Hope you get it figured out.

 

Share this post


Link to post
Share on other sites
Elliot B.    1,220
8 hours ago, xendrome said:

Each input should have different sound profiles, like 2 channel stereo, straight 5.1, 5.1 stereo, etc. Check the manual

Oh. The AV receiver is set to Auto Surround, which is definitely the correct setting.

 

7 hours ago, Hahaiah said:

I have a Pioneer running direct from PC also as TVs only pass 2 ch stereo (at least the ones I have).

When you right click your speaker icon in the task tray and get into the settings of your playback devices (the optical out of the sound card), under advanced you should see DTS at the bottom of the drop down menu as a choice, if not, you may need proper drivers as W10 naked installs don't do it.  Also for my system, I use 48khz.  When DTS sound is playing, if your Pioneer is like mine, you'll get a visual indicator on the receiver saying so. 

 

Side note: I have to run an audio file in the background looping constantly to avoid the lag of windows switching back to 2 ch when no sound is being played...this also threw me off when listening to test sounds as the first 2 wouldn't be heard due to the lag.  Had the same problem with another completely different system using this receiver so it may be a "Pioneer thing" (mine's a cheap one)

 

I've read numerous people having issues with DTS still not working on windows 10, I'm using an Asrock Tai Chi board so I feel lucky.  Hope you get it figured out.

 

This is what I see:

 

eb_xpt-1.png eb_xpt-2.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.