2 posts in this topic

I am trying to see why my system is running so slow with Firefox.  I know it is probably the browser and plugins - but here are the specs first.

 

Quote

inxi -F
System:    Host: Helm Kernel: 4.10.0-26-generic x86_64 (64 bit)
           Desktop: Xfce 4.12.3 Distro: Ubuntu 17.04
Machine:   Device: desktop System: Dell product: OptiPlex 745
           Mobo: Dell model: 0RF703 BIOS: Dell v: 2.6.6 date: 06/26/2011
CPU:       Dual core Intel Pentium D (-MCP-) cache: 2048 KB
           clock speeds: max: 3400 MHz 1: 2400 MHz 2: 3400 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]
           Display Server: X.Org 1.19.3 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD CAICOS (DRM 2.49.0 / 4.10.0-26-generic, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.0.3
Audio:     Card-1 Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Caicos HDMI Audio [Radeon HD 6450 / 7450/8450/8490 OEM / R5 230/235/235X OEM]
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.0-26-generic
Network:   Card: Broadcom Limited NetXtreme BCM5754 Gigabit Ethernet PCI Express
           driver: tg3
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full
           mac: 00:19:----

Drives:    HDD Total Size: 1250.3GB (50.2% used)
           ID-1: /dev/sda model: Samsung_SSD_840 size: 250.1GB
           ID-2: /dev/sdb model: ST31000528AS size: 1000.2GB
Partition: ID-1: / size: 229G used: 57G (27%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: No active sensors found. Have you configured your sensors yet? mobo: N/A gpu: 54.0
Info:      Processes: 244 Uptime: 4 days Memory: 3673.4/4387.2MB
           Client: Shell (bash) inxi: 2.3.8

And YES - I know this is an old system - I am going to be replacing it hopefully in the next month or so with an Intel i5 system.   I have a 250gb Samsung EVO 840 Installed as my main drive.

 

I have tried running Firefox without extensions (safe mode) and have had some improvement but not measurable.    Where I see a distinct slow down is when I post an entry on my personal blog (Joomla with RsBLog).  the title entry freezes the browser some for about 20 seconds.   There is a lag with entry.  I have tried the same in Chrome and Brave browsers and have not seen that issue.  Before anyone says to use those, I am sticking with Firefox. 

 

Also, Youtube videos at least stutter badly and I have to drop them down to 480p for any stability.    Normal web browsing is fine except for loading web sites such as Google (which usually loads instantly on other systems), take a few seconds to render and load.  Again, with other browsers, it is much faster.  And again, I will not be moving away from Firefox. 

 

Share this post


Link to post
Share on other sites

Posted (edited)

The only problem do testing with safe mode is no ad-blocker... Do you use one? Do you have Flash installed? Assuming you have reinstalled Firefox...

 

Dual core Intel Pentium D? 4GB RAM? Ouch! We still have some Dual Core 2 systems at work (with 4GB) and they can get blogged down browsing so not sure what you are expecting. I would think you would be better severed with an LTS version of Ubuntu on an old system.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.