Sign in to follow this  

Raspberry Pi issue

Recommended Posts

giantsnyy    57

Hi Everyone,

 

I want to start off by saying that I know essentially nothing about Debian based Linux distros.  I work almost exclusively with SLES, and don’t really know where some configs and logs are stored in Debian.  If I’m configuring something wrong please let me know.

 

My RasPi experiences some weird issues.  Every 2-3 days it will randomly block certain services. For example, I run a few development sites off Apache.  Anything in the root Apache folder is visible, but if I attempt to access a folder, I’ll get error 403.  Same thing for additional sites I configured in Apache.  If I try to SSH into the box, I get “Connection Reset by Peer”.  I can access MariaDB, but only with accounts that aren’t root.  My Ubiquiti UniFi controller web interface stops working, as well as guest WiFi access, but I can still configure it from the iOS app and my AP’s still provision.  I can access the console without a problem.  I checked /var/log/messages and it clears on reboot.

 

Either pulling the plug and resetting it or running an init 6 fixes it.

 

i have a Raspberry Pi 2 running Raspian Stretch. I did a clean install last week.  It’s been doing this to me since Raspian jessie.  This wasn’t an issue with Wheezy.

 

Thanks in advance,

Mike

 

Oh, and I thought I should mention that I tried posting this on the Raspberry Pi forums, but since it was my first post it required moderator approval - three days later my post completely disappeared from my history and isn’t on their forums. I guess they rejected me.

Share this post


Link to post
Share on other sites
Haggis    986

Thats weird

 

I dont think the Pi has anything to do with this though, it would not affect your wifi AP etc. Unless your trying to acces the controller through the pi?

 

403 accessing a folder on wordpress for example is usually because its set in the .htaccess to deny 

Share this post


Link to post
Share on other sites
giantsnyy    57

It doesn't usually affect the AP - with the exception of my guest access portal.  Restarting the Pi reprovisions the AP's so they lose connectivity for a few seconds.  The Pi is the unifi controller.

 

The 403 error is only weird because it's for folders I don't have problems accessing when the Pi isn't doing this.  As of last night, it now has taken to giving me 403 errors for the root directory too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.