Change Screen Resoloution when comp is off?


Recommended Posts

markjensen

Actually, singleuser has a bit of extra hassles...

He should be able to use runlevel 3, instead. It is normal boot, but no X. :)

(but I think consensus is that use CTRL+ALT+F2 to get to a nice terminal. Log in and repair. :))

Link to post
Share on other sites
Widdowmaker

WHAT are you guys rambling about? I have a user file for myself, if i try to change somthign liek a setting it wants root pass. MY cousin is VERY used to linux (he has never used windows) and it was easy enough to guess my pass word. Its only 12 digits long.

Ill try ctrl+alt+f2 but i aint sure how to edit the file.

Im download knoppix as we speak. though i am not sure it is the right version, or even right lanuage, let alone what to do with it.

*sigh* i supose i could just reformat and re install it all... god i dont know if i can deal with that crap again.

Oh BTW When i boot up it gives me a dual boot screen that offers me Red HAt 9 by default or DOS. DOS just boots me into windows. There is no command prompt. And what is GRUB?

EDIT: Ok i figured out grub, kinda. i tried ctrl+alt+f2 and nothign happens. i tried adding 1 to the end of the file. Still no luck. could somone dumb it down for me a bit? I can use linux ok its just thatr iv never had to do any of this at all.

Edited by Widdowmaker
Link to post
Share on other sites
markjensen
I have a user file for myself, if i try to change somthign liek a setting it wants root pass. MY cousin is VERY used to linux (he has never used windows) and it was easy enough to guess my pass word. Its only 12 digits long.
12 digits should be enough. Unless you used something like the name of a person you know. Best thing is to combine maybe 2 random words from the dictionary (or a few random letters), include a couple of letters, or some symbols. For example: range48fast. That one is a good password. My normal root pw is less complicated than that. But, you get the idea. :)
Ill try ctrl+alt+f2 but i aint sure how to edit the file.
This is something you should learn... But you can save that for a later date, if you promise to go back and learn the BASICS of vi. ;) It may very well be what saves your butt years down the road. :D
Im download knoppix as we speak. though i am not sure it is the right version, or even right lanuage, let alone what to do with it.
It will be good enough to boot from and use! There are (simple) tricks to learn how to make your filesystems writeable (Knoppix defaults to READ ONLY for safety reasons - prevent users from accidentally damaging thier own hard drives).
When i boot up it gives me a dual boot screen that offers me Red HAt 9 by default or DOS. DOS just boots me into windows. There is no command prompt. And what is GRUB?
The term "DOS" is just generic for the Microsoft partition. You can change that to "Windows XP Pro", or "Virus Catcher", or anything else you want once you are booted. And "GRUB" is a boot loader program (LILO is another, older one). It allows you to select what partiton to boot (or different modes, or even advanced recovery options).

I think that handles your questions for now. :D If you run across anything else that you are wondering about, just ask! :)

Link to post
Share on other sites
Widdowmaker

The version of knopix i got didnt work. And i tried the ctrl+alt+f2 and nothing happened. And my problem persists....

Link to post
Share on other sites
markjensen

Ok.... I think you are going to need to edit a file (maybe). All of your information on how X is allowed to set up your video is stored in /etc/X11/XF86Config. In fact, the main /etc/ directory is the main storage place for configs.

The file is a text file, and can be edited if you can bring your system up in runlevel 3 (I think instructions on how do this from the LILO or GRUB boot-up screen was posted earlier). Runlevel 3 will be a text-only mode, and will allow you ot make changes that prevent you from booting up in normal graphical mode (runlevel 5).

When you boot up into runlevel 3, enter cd /etc/X11 to change to the directory with the config we want to change. Once there, let's do a ls first, just to see all the files. I think this may show us that we have a "backup" file there (I hope!). It may be called XF86Config.backup, or maybe XF86Config.old, or maybe even XF86Config~ for a file name.

If a backup exists, we can su to root (you will need to enter your root password after hitting ENTER on your su command). As root, we can delete and modify any file on the system. IF a backup file exixts, then delete the XF86Config file, and rename the backup file to XF86Config.

rm XF86Config

mv XF86Config.backup XF86Config

Then type shutdown - r now or /sbin/shutdown - r now to reboot your system.

If there is no backup file then we will need to EDIT XF86Config. We will use vi to do this. The section that we need to remove higher resolutions on is "Screen". Mine looks like this:

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Depth     16
                Modes    "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

In your case, if 1600x1200 is too high, you can just remove it from the list of modes.

vi can be fun (tricky) to learn at first. If you get here and need help, let us know. :)

Link to post
Share on other sites
kjordan2001

I'm sorry, but I just have to laugh that a 6 year old did that :laugh:

And how'd he guess your 12 digit password? You didn't just do 123456789ABC did you? :rofl:

Link to post
Share on other sites
Southern Patriot
the thought that popped to mind was attempting to change the tv channel when the tv is off

Hey, I've still got a TV around somewhere that is entirely capable of that. I guess most of you are too young to remember TV's that had dials on the front for the channel. Usually two seperate ones, one for VHF and one for UHF.

Link to post
Share on other sites
Widdowmaker

I tried to boot up in runlevel 3 but it wont let me, wither that or i am doing it wrong. Please help, you guyys are great.

Link to post
Share on other sites
markjensen

Ok... I think that it *should* be able to come up, and allow CTRL+ALT+F2, or be forced to boot into runlevel 3. Either way, you *should* have gotten a prompt in a monitor-friendly text mode...

Now, since you are saying that neither of those are working, then I would tend to think that you have more serious issues here, as your computer is not booting up normally... :(

That leaves us GRUB or LILO repair options. I have used GRUB to repair and force a boot to a forgotten partition (using root(1,1) or something like that). But, you are now officially beyond my realm of knowledge.. :(

Since you can get online, you might want to google an answer a bit more...

Last think I can think of (and I am too lazy to see if it had already been suggested, and you tried it already), is try 'linux rescue', or some option like that at the GRUB prompt. I think GRUB has some rudimentary help, and Google will fill in the blanks for promising options.

Good Luck! I will keep monitoring this thread, just in case I can offer any additional help...

Mark

Link to post
Share on other sites
Widdowmaker

I guess i am bad at explaining things. I mean i added 1 to the end of a file (not sure if i did it to the RIGHT file) and it said booting up in Runmode 1... OK then it loaded some hardware andset Runmode 5... ok

THen it gave me the error...

So what is the name of the file i add 1 to? where in the name do i ADD 1? sorry if i seem like a noob, but i am.

So cureent questions are.

What file do i add 1 to the end of?

Where do i add 1 in the name?

once i add the right stuff ot the right file what do i type to fix it? i mean liek somthing i can just folow. I saw your previous post but that didnt quite make sense.

And an added question, while i am at it cna i make linux display in 1280X1024? it is what i run windows at.

EDIT: And WHERE do i hit ctrl+alt+f2? I mean, do i do at at the dual boot screen? or the one with all the OK's?

Link to post
Share on other sites
markjensen

You know.. I was thinking, too.. And I have a few more ideas... (some based on your comments back)

I mean i added 1 to the end of a file (not sure if i did it to the RIGHT file) and it said booting up in Runmode 1... OK then it loaded some hardware andset Runmode 5
You want runlevel 3. Really, the only two modes you will really ever need are 3 (text) and 5 (GUI). Yo don't really add 1 to the file, you tell GRUB to pass a parameter that will force a specific runlevel (overriding your default GUI runlevel).
And WHERE do i hit ctrl+alt+f2? I mean, do i do at at the dual boot screen? or the one with all the OK's?
You do it after Linux is booted (or as it is booting - putting up the [ OK ] to the checks and startups).

BUT... Here is what I just remembered:

If you are booted into the GUI (whether you can see it or not), you can use CRTL+ALT+- (that's the minus key on the keypad), or CRTL+ALT++ (that's the plus key on the keypad) to change resolutions "on the fly".

I think that this is the very simple solution to your problem!

Once you get the resolution to a mode that your card and monitor support, you will see your desktop again! (then you can edit your X11 file to only allow valid modes) ;)

Link to post
Share on other sites
notchbak

yep that definantly seems to be the answer he needs .. ( crtl + alt + - ) and if the screen refresh rate is the issue. then hopefully he can get the resolution down low enuf that it will accept the refresh rate.

good job markjensen !!!

Link to post
Share on other sites
markjensen
good job markjensen !!!

Errrr..

It only took me since Jan 26th to come up with that... :blush: :pinch: :no:

lol

Link to post
Share on other sites
Widdowmaker

dont be congrating yet. I turned it on to linux and i knew i was at the login screen. I typed my name and pass and heard the HD revv up. i knew i was in linux now. I waited for the HD to stop and for it all to go quieet and once it did i did ctrl+alt++ and waited. Nothing. so i type in root pass and try again. Nothing.

Now, I hit ctrl+alt+f2 during all the OK's and it just starts rebooting form the start.

So so far i fi understood this thread coreectly

CTRL+ALT+F2 dont work

Runlevel 1 and 3 dont work (not sure i did that right)

CTRL+ALT++ or - dont work

Editing a file or booting correctly into runlevel 3 might work, but i havent bene able to do that. Also, while i am at this am i able to change the Refresh rate back down to 65 hertz? That is best my monitor supportys.

Link to post
Share on other sites
Kokolores

how about switching off your monitor after grub did its job and you're booting into linux? then wait a while for linux to boot into graphical mode (your monitor still switched OFF). do a CTRL + ALT + F1 (or any key from F1 to F6). switch your monitor back on and you should see a terminal with a login prompt.

thus you would avoid that your monitor gets screwed up by the misconfigured graphical X system.

BTW unix systems only deal with passwords up to a length of eight characters. if you use more characters the superfluous ones are ignored.

Link to post
Share on other sites
LordHatrus

err.... I can't see why there's anything wrong with booting into a Live linux (i.e. knoppix) <Which, of course, uses an entirely different kernel, on an entirely different drive (CD-rom/ramdisk) and needless to say config scripts> and mounting your Linux hard disk, and changing the config....

but otherwise, how hard is it to come by a monitor that does 1600x1200???

Don't see this as a bad thing.... see this as an oppurtunity to get yourself a nicer monitor!!! :laugh: :)

Link to post
Share on other sites
Widdowmaker

See post on first page, knoppix dont work for me, or i didnt burn it right. THere were about 100 different versions and i didnt know which one to take. As for the nice monitor argument, yea, thatd be great. You got money? Cause i dont.

Link to post
Share on other sites
markjensen
BTW unix systems only deal with passwords up to a length of eight characters. if you use more characters the superfluous ones are ignored.

That info is a bit old...

The older DES system had a limit of 8 characters, but the MD5 system allows much longer. In theory, pretty much infinite, as it makes an MD5 out of it. In practice, the input buffer may have a limit of 255 characters or some other arbitrary limit.

Link to post
Share on other sites
markjensen

In case you haven't read the official RedHat instructions here:

http://www.redhat.com/docs/manuals/linux/R...-runlevels.html

Here is the quote:

If using LILO, access the boot: prompt by typing [Ctrl]-[X]. Then type:

linux <runlevel-number>

In this command, replace <runlevel-number> with either the number of the runlevel to boot into (1 through 5), or the words single or emergency.

If using GRUB, follow these steps:

* In the graphical GRUB boot loader screen, select the Red Hat Linux boot label and press [e] to edit it.

* Arrow down to the kernel line and press [e] to edit it.

* At the prompt, type the number of the runlevel you wish to boot into (1 through 5), or the words single or emergency and press [Enter].

* You will be returned to the GRUB screen with the kernel information. Press the key to boot the system.

Try the LILO or GRUB instructions, based on whether you use GRUB or LILO (The RedHat default is to use GRUB)

Link to post
Share on other sites
Widdowmaker

Ok this is what it says

INIT: Runmode 3

then it does like 100 OK's.

Then at the very end it says

INIT: Runmode 5

then it finishs one last file and it boots into run mode 5.

Any idea why? And yea i tried those instructions. Word for word. But they dont tell you where to put in the 3 in the kertnal file.

Link to post
Share on other sites
markjensen
Ok this is what it says
INIT: Runmode 3

then it does like 100 OK's.

Then at the very end it says

INIT: Runmode 5

then it finishs one last file and it boots into run mode 5.

Any idea why? And yea i tried those instructions. Word for word. But they dont tell you where to put in the 3 in the kertnal file.

Hmmm...

I am going to load up a computer here with Linux (if I can d/l an ISO quickly enough) and post better step-by-step instructions. I do need to know for a fact if you use LILO or GRUB. I think it is GRUB, but you need to be certain when you tell me.

It may not be until after 3:00am my local time before I can get the answer to you, if I have to wait until I get off of work.

I will do what it takes to get you into runlevel 3. :yes:

The fact that you see the text in runlevel 3, and then see it switch to runlevel 5 on you shows that the problem *can* be fixed. I think that a step is being missed (maybe one that isn't in the instructions).

I'll post again when I have a better answer.

Mark

Link to post
Share on other sites
Widdowmaker

I hereby nominate the above poster, mark. TO be titled "The most dedicated, helpful, and nicest newoinian ever".

Seriously, thanks. I just want to get this working again.

Awaiting better step by step instructions. (not that what i have doesnt help, it does. i just dont know whats going wrong.)

Link to post
Share on other sites
markjensen

Ok, here it is: (mind you that this is on a Mandy laptop while I type it in my Fedora destop online)

After BIOS does its self-checks, GRUB puts up the following:

GRUB version 0.93 (638K lower / 64448K upper memory)

linux
linux-nonfb
failsafe
floppy


Use the ^ and v keys to select which entry is highlighted.
Press enter to boot the selected OS, 'e' to edit the
commands before booting, or 'c' for a command-line.

I press e at this time, and the middle part with the selections changes to:

kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 quiet devfs=mount acpi=off&gt;
initrd (hd0,0)/boot/initrd.img

On my first line (titled 'kernel', i press e again.

The screen changes completely to this:

[ Minimal BASH-like line editing is supported.  For the first word, TAB
  lists possible command completions.  Anywhere else TAB lists the possible
  completions of a device/filename.  ESC at any time exits. ]

&lt;unt acpi=off vga=788_

Now, the last part is really just the continuation of the 'kernel' command that was listed before.

To make this work, you have to hit the SPACE bar first, to put a blank between the last parameter (in my case, "vga=788") and the requested runlevel. So, since I want runlevel 3, I typed " [spacebar] 3", then hit ENTER.

It put me back to the screen listing kernel and initrd.

I hit b to boot, and when it finished with all the OKs, it left me at a text login prompt.

Perhaps you did not hit the spacebar? The instructions did not mention it, but I noticed it when I first typed the '3', it made my vga mode say 7883, and I knew that could not be right.

Try this above, following the instructions posted earlier, but use the spacebar where I mention it for runlevel 3. I'll be that something similar happened to you, and the time you entered 3, it made it part of the parameter before it because there was no space.

GOOD LUCK!

Mark

Link to post
Share on other sites
Widdowmaker

YAY! I got into run level 3! It was the space that was a problem.

BOO! I typed in dir and found out i am on the desktop. i then typed /ect/X11 and it said "Directory Does not Exisit."

WTF? That was the right thing to type right? I mean. Why would it just stop working like that? Directory does not exist?!?!

Also while we are at it. How do i set my refresh rate back down to 65 hertz.

Link to post
Share on other sites
markjensen

Hmm...

First, you want to type ls, not dir... :rofl: But, I understand what you mean.

You said you typed /ect/X11? That isn't right, either... :(

You need to do a cd to change directory. You should be able to type the first letter or two of the directory and press TAB to auto-complete.

Ok, so you get to runlevel 3, that's good! :)

Now, login as root (and here is where we can do some damage, so be careful!)

enter your root password.

At the # prompt, type cd /etc/X11 (remeber you can use TAB to complete dir names, if you want)

Your current directory should change. Type pwd to print working directory.

It should respond with /etc/X11

Do a ls to see what is there. You will see some dirs, and your XF86Config file.

WIth any luck you will see the plain file, and maybe one that looks like a backup copy.

If you see a backup, rm XF86Config to erase the bad copy, and then mv XF86Configback XF86Config (use whatever backup name you find) to rename the old backup file.

Other alternatives (should this not work, or no backup exists), is to:

* edit XF86Config by hand

* run xf86conf to answer questions and make a new one from scratch

or

* possibly run xf86cfg to make a new XF86Config file via low-res GUI.

You might be better off with the second option, but I have never had to do this before, so it is unproven grounds for me, too.

Again, best of luck to ya!

Mark

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.