April patch issues

Recommended Posts


Has anyone had any issues with April's patches for Windows 10? My PC woke in the middle of the night to apply patches and then rebooted a few times and then went back to sleep. This morning I am having all kinds of issue. I can't get the desktop to load and Task Manager is hosed after using it once. I was able to launch task manager to run Firefox to post this. Anyone else heard of any issues this month?

Link to post
Share on other sites

I had a customer that reported of slow boot time and his touch pad pad not working. (Lenovo Laptop) I put it down to corruption as he may have closed his laptop down during the update process before it finished, but I'm not entirely sure what happened.


Ended up talking him through a Windows 10 "reset" which was challenging  when you only have a keyboard. But it worked (although he had to re install his apps obviously)

Link to post
Share on other sites

The update started installing as I turned my PC off. It never did, and I had to do it manually. I'd never experienced that before.

Link to post
Share on other sites

it looks like the april update has some issues across all OS versions.
It kind of nuked most of my Surface2 apps :(

Link to post
Share on other sites

No issues with three machines here. 

Link to post
Share on other sites
  • 2 weeks later...

some new April 2018 updates for Windows 10 have been released out-of-band this late April.


KB4093105 for Win10 v1709:



KB4093117 for Win10 v1703:



KB4093120 for Win10 v1607:



these should resolve some of the problems with the earlier April 2018 updates

Link to post
Share on other sites

I have had to run a  command after I updated a couple of them.  NO Settings windows would open.  Control Panel was fine, but when trying to open any of the Settings apps, it wouldn't even try to open them.


If you run into that, search for CMD, Run As Administrator, paste that in and execute: powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\ImmersiveControlPanel\AppxManifest.xml


I have had this behavior BEFORE this update, as well.  This command has fixed it every time.

Link to post
Share on other sites

My issue is a strange power button issue.


Powering off from the start menu shuts the PC down like normal but when i try and start it again by pressing the power button nothing happens, so i have to switch the power supply switch off on the back for 30 seconds to make the power button work again.

If i power it down by pressing the power button i can then start it again by pressing the power button, i don't use sleep or hibernation so i am well confused....




So after it not working 20 odd times from my testing, i put it into sleep mode and since then shutting it down has worked several times on the trot, so not sure if i still have an issue or not.

Edited by SnoopZ
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.