• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Windows 7 64 bit shows red cross on network icon

Recommended Posts

zillah2004    0

Dear folk

 

My desktop windows 7 64 bit was working fine til I walked up yesterday and there was a red cross on the network icon!!!

 

Ethernet cable working fine as when i hooked it to my laptop everything is working fine , means problem lies within the desktop and nothing wrong with cable or router port.

 

Troubleshoot that I had done so far :

 

Restarted desktop 3 times, uninstalled LAN driver, connected new Ethernet cable

 

What else I need to check to find out what is going on ?

 

Thanks

Share this post


Link to post
Share on other sites
helpifIcan    39

One possibility is that you may have received an update that corrupted the lan driver. Go to either the DTs manufactures web site and download a driver, or to the lan chip mfgs site.

Share this post


Link to post
Share on other sites
zillah2004    0

Thanks helpifIcan

What i did I shutdown desktop and unplug power cable and waited for a while and now it is working ,,,,,,,,,,,,,credit to JohnC_21 from bleepingcomputer.com

Share this post


Link to post
Share on other sites
helpifIcan    39

Great glad it was a simple fix.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.