Installing Magisk 17.1

Recommended Posts

Sir Topham Hatt

Can anyone tell me how I install this?


I usually click "direct install" or something but now it gives me an option to "patch boot img file" (which then asks me to find a file?) or "download zip", of which I don't then know how to install it from there.



Link to post
Share on other sites
Brandon H

sounds like the phone is still locked down.


I'd double check the bootloader is unlocked and that a custom recovery (preferably TWRP) is installed.


if the direct install is still failing then you can install Magisk through your custom recovery; the zip file can be downloaded from the XDA thread :)


They even have a nice guide if you'd like to check it out:




been just been getting back to rooting myself recently on a couple devices and I gotta say I like Magisk a lot better than SuperSU. seems a lot more stable overall and some nice extra features built in.

Link to post
Share on other sites
Sir Topham Hatt


I appear to have lost root access at some point.

*sigh* - now time to relearn how to gain it again!


It's what annoys me because the guides online don't correspond to my phone.


For example, when booting into TWRP (which is out of date anyway!), I don't have the option to view the files on the device, and so can't select the downloaded magisk zip file.


Can't update the TWRP because when I type whatever I need to into Powershell, it says "waiting for device", which is great.  But when booting into Fastboot then it says "error: cannot lad twrp..."


I remember why I try not to bother with this stuff...

Edited by Sir Topham Hatt
Link to post
Share on other sites
Brandon H

what device you have? updating TWRP is super easy and then you can go from there


you can either update TWRP through fastboot and cmd prompt or it can be updated directly inside TWRP by switching the flash option from .zip to .img

if using fastboot there are specific drivers needed for windows. especially if using windows 10 as the official adk drivers don't work on 10


once i know your device i can usually find you the right version pretty easily




edit: though if your TWRP install isn't too old you should be able to just flash the file and it will restore root. only if the flash fails would you really need to update TWRP :)

Link to post
Share on other sites
Sir Topham Hatt


I'm using a one plus 3t.


I can use powershell and it recognises the device (using adb devices), so I guess my adb is working okay?

But I have no idea what to type to update twrp or flash magisk.


Tried updating twrp in the official twrp app but it just fails, I guess because I'm not rooted.


Tried to enter twrp recovery but it then can't find the magisk zip to install. 


I guess downloading the latest twrp recovery.img then patching the latest magisk to that wouldn't work? 

But then I still need to somehow install it on the phone but recovery didn't recognise the internal memory (photos, apps, videos), only the system memory, so not sure how to install new twrp. 

Edited by Sir Topham Hatt
Link to post
Share on other sites
Brandon H

You'll need to download the file onto your phone. I usually just put it in the usual downloads folder


Then in twrp in the flash menu you should be able to browes to the folder you saved the zip to.


The same thing goes for updating TWRP; once in the flash menu you should see a button to switch to img and then you can select your saved TWRP.img to flash


If you need help this guide has great step by step for both installing through TWRP or through fastboot.


This is the same guide I posted above


P.s. I hate messing with fastboot sometime because even if it detects your phone you may not have the right version of the driver installed if using the official adk drivers ...

Link to post
Share on other sites
Sir Topham Hatt

This is where we have the problem.


When in the twrp recovery, it doesn't recognise any folders, apart from those that the system uses (sdcard folder is empty!).


So I can't browse to the /downloads/ folder to flash the magisk zip. 


But I can't use a root explorer to put the file in the system section somewhere because I'm not rooted.

Edited by Sir Topham Hatt
Link to post
Share on other sites
Brandon H

there should be a switch drive button to select your SD card but if that for whatever reason is not working TWRP also allows mounting a USB drive if you have an OTG cable.


if that doesn't work we can look into fixing your fastboot drivers; you may just need to update the drivers if you haven't in a long time to support the confirm connection dialog on the phone.

could also try fastboot from within TWRP (in the advanced menu); may cooperate better then when booted into Android

Link to post
Share on other sites
Sir Topham Hatt

Well when in recovery, I swipe to say I'm happy for changes, go to "install" which shows the folder "sdcard" but it's empty.

Going up a level shows lots of folders - all empty.

Clicking on "select storage" shows "internal storage 0Mb" and "USB-OTG 0Mb", the latter of which doesn't do anything.


I can connect it to my PC and use ADB to control it (IE, it recognises there's a phone attached and I used it to reboot into fastboot).

Link to post
Share on other sites
Brandon H

now that is odd indeed.


looking over at XDA I found a thread that is exactly your situation | if you didn't post this then it may be a known issue.


it sounds like a factory reset is required to correct the issues; worth looking over the thread at least, some users seem to have some ideas on it over there :)


edit: someone had a great idea on the thread that may work for you; you can boot directly into the new TWRP img file without installing it; try this to see if it's still unable to read your directories.




Oh, ok, I thought that the system is broken too. That's ok then, your memory chip is fine.
Can you boot an up-to-date TWRP from fastboot and try to access data?
Try with


fastboot boot twrp-3.2.3-0-oneplus3.img



if you can actually see your files after booting into the newer version then you can perform your flashes and continue as normal.



it sounds like this is a common issue on the device if using encryption

Link to post
Share on other sites
Sir Topham Hatt
On 9/12/2018 at 3:29 PM, Brandon H said:

looking over at XDA I found a thread that is exactly your situation 

It's me also ?
I did that thing of panicking and posting everywhere (well, two places!).  But a combination of you explaining more simply has helped.
Managed to boot to the latest TWRP, then use that to install magisk, which then enabled root again, so I could update to the latest TWRP!
Now doing a Titanium Backup for good measure!


Although the experience did make me think seriously about the OnePlus 6T... however I'll see how things like the battery go as I dropped it a few months ago and have noticed the battery is a fair bit not as great.
Although it's still under warranty so could always send it back I suppose.

  • Like 1
Link to post
Share on other sites

If you are in TWRP and it's not listing folders (Does it just list them all as random characters?) then your phone is encrypted, that's why it's not rooted also most likely. You'll need to install a version of TWRP that allows you to enter your encryption pin.


Reboot into fastboot mode and then connect the phone to your computer.


If you already have adb like you said then you should also have fastboot.


The command for flashing the TWRP zip is "fastboot flash recovery <filename>" where <filename> is the name of the particular TWRP version zip you downloaded. The zip has to be in the same folder as fastboot obviously. 


To be honest, if you're having encryption problems you might just have to back up the contents of the phone and do a full wipe and reinstall your rom, make sure you get a decrypt compatible TWRP version this time though.

When I do a full wipe I usually :


  1. Back up all contents using Filezilla Client on my computer and an app on the phone called FTPServer Pro
  2. Perform this command in fastboot : "fastboot -w" - That performs a full data wipe
  3. Go into TWRP which should now allow access because the fastboot wipe removes encryption too, wipe all the other partitions
  4. Reboot back into TWRP or go into fastboot and flash the TWRP version I want using the method I gave you above
  5. Flash the rom again

If you want to keep the contents of the phone decrypted when you're in TWRP there's a zip you should look up called noverity but just be aware anyone who has the phone could do so also and have full access to the contents.

Edited by PsYcHoKiLLa
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.