• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

New phone, unlocked, but can not get service

Recommended Posts

jnelsoninjax    10,285

I had to buy a new phone due to my Moto E4 becoming damaged, so I went to Walmart and bought a Verizon prepaid ZTE Blade Advantage, bought the unlock code via Ebay and I received 2 different codes, the first one unlocked the phone for the session, the second one seems to have done it permanently. The issue is when I place my SIM into the phone and boot, I get a message from Phone Services that says "Attention, no service" I have contacted my carrier regarding this and they have verified that everything is fine on the back end. The odd issue is when I put the Verizon sim back into the phone, the same error message is displayed, however it prompts me to tap here to get Verizon service. Does anybody have any clue as to what is going on here, and how I can fix it?

Share this post


Link to post
Share on other sites
jnelsoninjax    10,285

I put the sim into another phone and it works fine, it must be the phone, but idk why.

Share this post


Link to post
Share on other sites
Circaflex    3,428

Try inserting your SIM back into the phone, then verify the APN settings are correct. Chances are, you need to update those.

Share this post


Link to post
Share on other sites
jnelsoninjax    10,285
1 hour ago, Circaflex said:

Try inserting your SIM back into the phone, then verify the APN settings are correct. Chances are, you need to update those.

I did that already (APN settings)

Share this post


Link to post
Share on other sites
Marujan    43

install AT&T sim to new phone? saying the same error?

 

make hard reset

Share this post


Link to post
Share on other sites
jnelsoninjax    10,285
Just now, Marujan said:

install AT&T sim to new phone? saying the same error?

 

make hard reset

No the phone is from Verizon, the carrier I am using a MVNO that uses AT&T and I have done a factory reset

Share this post


Link to post
Share on other sites
adrynalyne    9,904
3 hours ago, jnelsoninjax said:

I put the sim into another phone and it works fine, it must be the phone, but idk why.

It’s an LTE only phone and Verizon uses different frequencies than ATT. I’ve not looked to see what the phone supports but chances are it doesn’t support ATT frequencies. 

Share this post


Link to post
Share on other sites
Circaflex    3,428
40 minutes ago, adrynalyne said:

It’s an LTE only phone and Verizon uses different frequencies than ATT. I’ve not looked to see what the phone supports but chances are it doesn’t support ATT frequencies. 

Good call, I didn't even think about the bands being the issue.

Share this post


Link to post
Share on other sites
jnelsoninjax    10,285
7 hours ago, adrynalyne said:

It’s an LTE only phone and Verizon uses different frequencies than ATT. I’ve not looked to see what the phone supports but chances are it doesn’t support ATT frequencies. 

That would appear to be the issue, I found a website that says it is only compatible with 2 of the 4 LTE bands on AT&T so I am going to assume that is the issue.

Share this post


Link to post
Share on other sites
Circaflex    3,428
On 10/19/2018 at 2:38 AM, jnelsoninjax said:

That would appear to be the issue, I found a website that says it is only compatible with 2 of the 4 LTE bands on AT&T so I am going to assume that is the issue.

Will you be able to return the phone without any issues?

Share this post


Link to post
Share on other sites
jnelsoninjax    10,285
31 minutes ago, Circaflex said:

Will you be able to return the phone without any issues?

Doubt it, Wal-Mart does not take opened electronic devices back very well, I will give it to my niece to use with her service (Unreal mobile, MVNO for Sprint.

  • Like 1

Share this post


Link to post
Share on other sites
Circaflex    3,428
11 minutes ago, jnelsoninjax said:

Doubt it, Wal-Mart does not take opened electronic devices back very well, I will give it to my niece to use with her service (Unreal mobile, MVNO for Sprint.

Dang, thats a bummer. Hopefully it didn't cost much. I might have an Nexus 5 laying around, I will look for it.

Share this post


Link to post
Share on other sites
Brandon H    2,099
17 minutes ago, jnelsoninjax said:

Doubt it, Wal-Mart does not take opened electronic devices back very well, I will give it to my niece to use with her service (Unreal mobile, MVNO for Sprint.

sometimes they'll work with you if you explain you purchased the wrong service provider model but often times you're correct; it's like talking to a brick wall trying to return an open electronic item

 

glad you have an alternate solution for the phone; at least it's still getting used :)

Share this post


Link to post
Share on other sites
jnelsoninjax    10,285
2 minutes ago, Brandon H said:

sometimes they'll work with you if you explain you purchased the wrong service provider model but often times you're correct; it's like talking to a brick wall trying to return an open electronic item

 

glad you have an alternate solution for the phone; at least it's still getting used :)

It is good that I can offer to my niece, she has never had a 'new' phone, her mother always gave her hand me downs, and this is the least I can do for her.

Share this post


Link to post
Share on other sites
jnelsoninjax    10,285

Well I tried the unreal sim in the phone and it does not work either... so idk what is going on with the phone, but it would seem that it only works with Verizon.

Share this post


Link to post
Share on other sites
Brandon H    2,099
On 10/22/2018 at 7:17 PM, jnelsoninjax said:

Well I tried the unreal sim in the phone and it does not work either... so idk what is going on with the phone, but it would seem that it only works with Verizon.

a lot of time the phones labeled 'Verizon Prepaid' are set to only work with Verizon activation/sim cards. AT&T does the same thing with their 'AT&T Prepaid' labeled phones. even Unlocking the device doesn't seem to make a difference.

 

maybe they have it locked down via the ROM image; you could try flashing a custom ROM and see if it recognizes the SIM

Share this post


Link to post
Share on other sites
jnelsoninjax    10,285
10 hours ago, Brandon H said:

a lot of time the phones labeled 'Verizon Prepaid' are set to only work with Verizon activation/sim cards. AT&T does the same thing with their 'AT&T Prepaid' labeled phones. even Unlocking the device doesn't seem to make a difference.

 

maybe they have it locked down via the ROM image; you could try flashing a custom ROM and see if it recognizes the SIM

Interesting thought about the custom ROM, can you point me in the right direction to find one?

Share this post


Link to post
Share on other sites
Jim K    11,116

Have you taken it to an AT&T shop ... to see what they have to say?

 

I'm guessing it will not work ... since it is an exclusive for Verizon.

Share this post


Link to post
Share on other sites
jnelsoninjax    10,285
18 minutes ago, Jim K said:

Have you taken it to an AT&T shop ... to see what they have to say?

 

I'm guessing it will not work ... since it is an exclusive for Verizon.

No, I bought it from Walmart, and use a NVMO who doesn't have any physical stores, and when I talked with the carrier support they said that everything was fine on my account to swap to another phone.

Share this post


Link to post
Share on other sites
Brandon H    2,099
20 hours ago, jnelsoninjax said:

Interesting thought about the custom ROM, can you point me in the right direction to find one?

XDA has a search by device. if it's a common model the search should bring it right up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.