• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Can't see network PC and can't connect to networked drives

Recommended Posts

BoricuaCharles    0

This is driving me crazy. I had never had issues sharing drives from one PC on a network and allowing other devices to access them but now it seems like a nightmare to make any of it work. I have one PC sharing all the drives on the network but I am unable to see these drives from my second PC. I can't even see the PC on the network from the second PC but I can see the second PC just fine from the other one. The system doesn't seem to work both ways. I was able to set up the drives a month ago by manually entering the PC name even though  I could not see the PC on the network through explorer. but because the second PC was having hard drive issues I had to restore Windows and send it to be repair. A temporary replacement also had issues with network drives but I was eventually able to get them to work though every time the PC restarted the drives never reconnected instantly, always took a little bit for them to work properly. Now that I got the original second PC back from being repaired I can't connect to the network drives, it says I don't have permission even though nothing was changed on the first PC.  I have tried so many things and nothing seems to make it as easy as it was before. Here's what I have done so far:


1) I have 2 Windows 10 PCs, a desktop (PC A) and a laptop (PC B). PC A is the main PC with the extra drives. I went into each drives properties and went into the sharing tab and shared each giving full permission to everyone on the network to access the drives. I also shared the main drive on the laptop just in case I needed it.


2) I have the 2 PCs set to the same workgroup and network, one through ethernet, the other on WiFi.


3) I checked the following services as told by several sites to make sure they were running: Function Discovery Discovery Resource Publication  (Running) (automatic), UPnP Device Host service  (Running) ( manual) and Computer Browser (Running) (Manual)


4) I made sure smb 1.0 was on


5) I pinged PC A from PC B and it was fine


6) I released and renewed the ipconfig


7) I made sure the PC time setting were the same on both PCs though oddly enough before I did this I managed to get PC A to show up on PC B's explorer screen after turning on smb 1.0 but I didn't have access to it, now I can't see it at all again


8) I tried setting up the network drives by entering the PC name manually, it worked a month ago but now I can't access the drives (see image below for error)


I'm sure I have tried other things but I can't remember them all right now. I just want to be able to see PC A from any PC on the network but I can't and now I can't even set up the network drives manually because of the error below. Nothing was changed on PC A, I don't understand why I can't access it anymore even though it worked a few weeks ago just fine when set up manually. I am able to see PC B from PC A just fine and set up network drives on PC A from PC B just as it supposed to be done. But I can't get it done from other PCs. Can someone please tell me what I could be doing wrong that I can't simply see PC A on the network page of explorer?


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.