• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

IPX Networking with a hub

Recommended Posts

barbapopa    0

i had this problem in the previous betas, and here it is again. i'm using @home, and we have 2 ip addresses. the cable modem is going into the hub, and the two computers are then plugged into the hub as well. under 98/me, i could enable tcp/ip and get my @home access, as well as enabling IPX and file/printer sharing. all i had to do was go to tcp/ip->bindings, and uncheck file/printer sharing for that protocol, to make sure security was OK.

i was still able to share drives/folders/whatever over IPX between the two computers, as well as use tcp/ip for @home. I can't seem to do this in WinXP. I couldn't do it in the beta, because it'd enable the firewall every time i'd try to set up ipx, but in the final i still can't seem to find the right combination of options.

anyone else have this problem? anyone gotten around it? I really need IPX, and this was part of the reason i scrapped the old beta and went back to win98. i was waiting for the final, hoping this would be easier to address.

any help would be appreciated, as i'm sick of transferring stuff over @home just to get files to my basement computer.

-barbapopa

Share this post


Link to post
Share on other sites
barbapopa    0

i guess no one else has had this problem as of yet.

it's really annoying, since I can't use my network, except for TCP/IP.

damnit.

Share this post


Link to post
Share on other sites
Errahem    0

Ahah, so I'm not alone. I'm also experiencing this problem. During the beta, I had XP on my own computer, and just 98 on another computer. Since I could network the two with the hub when 98 was on both, I thought perhaps it was incompatibility between the two OSes. Now that XP is final, I installed it on both computers, ran the network setup wizard and chose the option for multiple computers connected directly to the internet through the same hub (you know, hub connected to @home cable modem, and computers connected to hub). STILL couldn't share. I've been going mad with it, and am trying to figure out why MS put an option in the network wizard that doesn't work. I've tried disabling the personal firewall on both computers, and that did jack, so now I'm just waiting.

Share this post


Link to post
Share on other sites
Alanb    0

I think you'd do well if you put two NIC cards in one computer and one in the other. The cable modem would connect up to one of the two NICs in the host computer, with the other NIC connected to the hub. Then, the client computer's NIC would also connect to the hub.

In this way you would need but one IP address and wouldn't have to pay for the extra IP address.

This is the way I do it, and it works splendidly. I don't notice any degradation in speed of my connection.

Alanb

Share this post


Link to post
Share on other sites
barbapopa    0

yeah, i might have to try that. XP just won't do IPX this way. Maybe when I get XP installed on the other computer, things might be a little better, but right now, i can't do much. Of course, the annoying thing is that the base computer must be on at all times for the other one to have access.

Share this post


Link to post
Share on other sites
Roger H.    777

If I read that right you're trying to share your files and your internet connection between 2 computers. You either need to set up one of them as a server or you'll need to get a router. If you want to have one set up as a server then all you'll have to do is put 2 NICs in one PC and connect that PC to the cable modem/DSL and then connect the other free NIC to the hub and then connect the other PC the the hub. IF you do it using a router then it's basically the same idea. You'd just connect the router to the cable/DSL modem and and connect both PCs to the router and then let the router assign all the IPs required. It's pretty easy so let me know if any of that work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.