• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

neowin.com no longer working?

Recommended Posts

PNWDweller    147

I usually use the .com as a shortcut since it was redirecting to .net (I know, not too much to enter.   neowin.net)   It looks like it has either been taken or moved to a different company?

 

$nslookup neowin.com
Server:        127.0.0.53
Address:    127.0.0.53#53

Non-authoritative answer:
Name:    neowin.com
Address: 54.172.165.25

$nslookup neowin.net
Server:        127.0.0.53
Address:    127.0.0.53#53

Non-authoritative answer:
Name:    neowin.net
Address: 5.10.17.162
Name:    neowin.net
Address: 5.10.17.165
Name:    neowin.net
Address: 5.10.17.164
Name:    neowin.net
Address: 5.10.17.163

 

Share this post


Link to post
Share on other sites
Barney T.    2,315

Yes, it doesn't redirect for me either.

Share this post


Link to post
Share on other sites
Christopher Andreason    4
Posted (edited)

Facebook requires that you whitelist redirect URIs, since otherwise people could login with Facebook for your service, and then send their access token to an attacker's server!
And you don't want that to happen

 

if i use Google Chrome version 73.0.3683.86 then this will happend every time

 

if i trying to login to my neowin profile but use the login with Facebook i willl get this error message below

 

Facebook login message: “URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings.”

I have also tried to send information about this but got no answer

 

 

this is just some examples 

 

Other thing is if you're using "/" end of the URLs you must add that URL to app settings of Valid OAuth redirect URIs. Example:- https://www.example.com/index.php/ if this url if youre using in the redirect url you must set that to app settings.

 

Make sure your App IDs and Secret Keys are correct. If you are using separate development, staging and production apps for testing, the App IDs and Secret Keys are all different for each app. This is often the problem.
 

Make sure you have the callback URL set properly in your app config file (see below). And then add this as same URL under "Facebook Login" settings where it says "Valid OAuth redirect URIs". It should look like this (depending on your environment):

http://localhost/auth/facebook/callback http://staging.example.com/auth/facebook/callback http://example.com/auth/facebook/callback


Make sure your app domain is set to the correct domain for each environment, including both "www" and "no-www". Facebook also requires these domains to match the URL of your website or app platform. You will have to select "Add Platform" to add this.

 

page where I found more information about this: https://stackoverflow.com/questions/37001004/facebook-login-message-url-blocked-this-redirect-failed-because-the-redirect

 

 

but when i did trying to login to my profile with

 

Microsoft Edge 42.17134.1.0/Microsoft EdgeHTML 117.17134 then it work to login to google account  (stil the same problem with Facebook account)

 

 

Edited by Christopher Andreason
works only with goolge login added an other Example

Share this post


Link to post
Share on other sites
devHead    1,963
9 hours ago, PNWDweller said:

I usually use the .com as a shortcut since it was redirecting to .net (I know, not too much to enter.   neowin.net)   It looks like it has either been taken or moved to a different company?

 


$nslookup neowin.com
Server:        127.0.0.53
Address:    127.0.0.53#53

Non-authoritative answer:
Name:    neowin.com
Address: 54.172.165.25

$nslookup neowin.net
Server:        127.0.0.53
Address:    127.0.0.53#53

Non-authoritative answer:
Name:    neowin.net
Address: 5.10.17.162
Name:    neowin.net
Address: 5.10.17.165
Name:    neowin.net
Address: 5.10.17.164
Name:    neowin.net
Address: 5.10.17.163

 

And you don't simply bookmark the site with the correct URL because...?

  • Like 1

Share this post


Link to post
Share on other sites
Christopher Andreason    4

tried to do this -->Reauthorization required Microsoft account 

 

We cannot complete your request

invalid_request: The provided value for the input parameter 'redirect_uri' is not valid. The expected value is a URI which matches a redirect URI registered for this client application.

tried to do this which gives a result failed to "Reauthorization required Microsoft account"

 

 

Share this post


Link to post
Share on other sites
Christopher Andreason    4
10 hours ago, PNWDweller said:

I usually use the .com as a shortcut since it was redirecting to .net (I know, not too much to enter.   neowin.net)   It looks like it has either been taken or moved to a different company?

 


$nslookup neowin.com
Server:        127.0.0.53
Address:    127.0.0.53#53

Non-authoritative answer:
Name:    neowin.com
Address: 54.172.165.25

$nslookup neowin.net
Server:        127.0.0.53
Address:    127.0.0.53#53

Non-authoritative answer:
Name:    neowin.net
Address: 5.10.17.162
Name:    neowin.net
Address: 5.10.17.165
Name:    neowin.net
Address: 5.10.17.164
Name:    neowin.net
Address: 5.10.17.163

 

neowin.net or neowin.com
both can point to the same place and you can fix this by sending the user to the right page/hyperlink/URL

where from the domain the address and pointing this further here you can point both neowin.com and neowin.net to lead to exactly the same website

Share this post


Link to post
Share on other sites
PNWDweller    147
3 hours ago, devHead said:

And you don't simply bookmark the site with the correct URL because...?

I have a few reasons, but the most pressing is laziness.  TBH - when I type in neowin's address, I found it easier for me to just hit neowin [ctrl+enter] to autocomplete to the .com in my browser.  Again, simply laziness.  But, I remember a few years back when it was a big deal for the site to finally procure .com from someone who had it.   And my bookmarks are a complete mess.  So - there's that as well. :)

Share this post


Link to post
Share on other sites
adrynalyne    11,109
Posted (edited)
3 hours ago, devHead said:

And you don't simply bookmark the site with the correct URL because...?

Oh if I could tell all my clients stuff like this. But no, I make it redirect for them which is what anyone in this industry should be doing unless it’s not a public facing site or the domain isn’t owned by them. 

  • Like 1

Share this post


Link to post
Share on other sites
DaveLegg    962

Only just seen this. Looks like we forgot to update the DNS when we moved the site off Amazon EC2. I've updated the records now, so it should work again for you shortly.

 

It looks like I may need to make a change on the servers to avoid certificate issues with the redirect. I'll do that this evening.

Share this post


Link to post
Share on other sites
SnoopZ    214
2 minutes ago, DaveLegg said:

Only just seen this. Looks like we forgot to update the DNS when we moved the site off Amazon EC2. I've updated the records now, so it should work again for you shortly.

 

It looks like I may need to make a change on the servers to avoid certificate issues with the redirect. I'll do that this evening.

I guess that is why it is showing as a security risk in my browsers when accessing it?

Share this post


Link to post
Share on other sites
DaveLegg    962
Just now, SnoopZ said:

I guess that is why it is showing as a security risk in my browsers when accessing it?

Yeah, at the moment it will be responding with the neowin.net certificate, which doesn't match the .com domain you asked for.

Share this post


Link to post
Share on other sites
SnoopZ    214

This is still not working for me.

Share this post


Link to post
Share on other sites
adrynalyne    11,109
Posted (edited)
1 hour ago, SnoopZ said:

This is still not working for me.

That’s because it has an invalid SSL. Someone threw the .net ssl on the .com 😉

 

Port 80 redirects to 443 which redirects to .net. Well would if it had the correct SSL. 

 

@DaveLegg why don’t you redirect port 80 to 443 on .net and be done with it? Browsers only default to 443 if there is an ssl in place. An invalid one is worse than none at all. 

 

Edited by adrynalyne

Share this post


Link to post
Share on other sites
DaveLegg    962
8 hours ago, SnoopZ said:

This is still not working for me.

Apologies, I got distracted working on some other bugs. This will be fixed over the weekend

Share this post


Link to post
Share on other sites
DaveLegg    962

This is now resolved

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.