• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0

PC Tuneup Prior to 1903

Question

bikeman25    62
Posted (edited)

Hello All

 

Lately been doing terrible in some online games,  a lot of deaths,   Games doing terrible in Battlefield 4,  Sometimes Grand Theft Auto 5.

 

Over the course of last 5-6 months have done the following on system

 

Install Avast Free Antivirus/ Uninstall Avast Free,  Use Defender and Malwarebytes Free for a few weeks, then switch back

Replaced Toshiba 1TB storage drive with Western Digital Black 1TB storage drive,  restored image of said drive

 

(Boot Drive is Western Digital 250GB SSD) 

Storage/extra game drive--is Western Digital 1TB

 

 

Should I opt for a complete system clean install prior to 1903, and then do inplace upgrade to 1903 whenever released?

 

Just wanna do better in my games on my Desktop

 

Edited by bikeman25

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
bikeman25    62

Would a System Reset of 1809, then upgrade to 1903 be wise to do?   or waste of time

 

 

Share this post


Link to post
Share on other sites
  • 0
Jim K    12,611

Here is the problem with your question ... and why probably no one has answered.  It is vague.

 

You've "been doing terrible in some online games,  a lot of deaths" ... ok ... and???

 

Are you suffering from poor performance, micro stuttering, network issues (latency, etc.)...

 

What is your issue ... aside from dying in games?

Share this post


Link to post
Share on other sites
  • 0
bikeman25    62

Well not noticeable lag that I can feel,   Might be just nothing wrong, performance seems fine to me,  no micro stuttering either that I notice.    Guess will decide if doing over top upgrade of 1903 or clean install when out, and fix it up then,  boot drive is only 250gb, but guess reserved storage in 1903 won't be a big deal really.  

 

Ping in game is usually between 17-22ms, so that isn't bad I don't think

 

sfc /scannow fine

 

despite switching Antivirus programs a lot last 6 months, maybe just me doing bad lately for some reason, and nothing really wrong

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.