• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Head's up if you have a high quality Creative X-FI Titanium audio card and update to 1903

Recommended Posts

DevTech    1,517

Head's up if you have a high quality Creative X-FI Titanium audio card and update to 1903

 

Windows will not update the device driver automatically (as of the time of this post) and will not spew out an error.

 

It will say the device is working normally but there will be NO SOUND.

 

The solution is to manually update the driver from a Reddit link where apparantly Creative has pledged to be more responsive to driver updates and will monitor Reddit for user issues.

 

https://www.reddit.com/r/windowsinsiders/comments/b3xw73/creative_xfi_issue_resolved_with_latest_drivers/

 

 

Once you update the driver from there, it will show as a Microsoft driver and it most importantly will MAKE SOUND WORK AGAIN!

 

  • Like 2

Share this post


Link to post
Share on other sites
DevTech    1,517

Similar thread in the Neowin Windows Forum:

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.