• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

VMWare VM of Lubuntu 18.04 problem with tools

Recommended Posts

SoCalRox    246

HP Elitebook 840 G3, 8GB RAM, i5, 256 GB SSD, Windows 10 1903, running VMWare Workstation Player 15.1.0 build-13591040 (most current)

 

Guest: Lubuntu 18.04 amd64 allocated 4GB and 100GB of disk, shared folders enabled and working.

 

Problem is simple- I cannot get it to share the cursor with the host- I have to hit ctrl-alt to get my cursor back in the host. I have tried both open-vm-tools and the vmware-tools-distrib to no luck. I also cannot share the clipboard (is that available in player, or does that need full Workstation?)

 

Suggestions appreciated!!!

Share this post


Link to post
Share on other sites
theefool    9
Posted (edited)

I saw a similar issue on workstation pro.  I don't have player installed, but check preferences under settings and see if you have under "Input" an option for "Optimize mouse for games."  Try changing this to never.  

 

This fixed my issue.

 

I saw an old post for fusion with same results.

  • Thanks 1

Share this post


Link to post
Share on other sites
SoCalRox    246

Thanks, peeps. I'll try. It's weird- it worked just fine and in the middle of a session, it just stopped. I messed with it and it started working again but I don't know what I did. It just started suddenly again. Weird...

 

Updated: I didn't find the gaming mouse anywhere around Workstation Player or Fusion, but after a lot of looking, I found it in Workstation Pro. I found "preferences.ini" and at the end was a gaming mouse preferences that is not in Player, but I added it manually, and BINGO! we're back in business! THANKS!!!
 

Share this post


Link to post
Share on other sites
Mindovermaster    1,779
Posted (edited)
20 minutes ago, SoCalRox said:

Thanks, peeps. I'll try. It's weird- it worked just fine and in the middle of a session, it just stopped. I messed with it and it started working again but I don't know what I did. It just started suddenly again. Weird...

 

Updated: I didn't find the gaming mouse anywhere around Workstation Player or Fusion, but after a lot of looking, I found it in Workstation Pro. I found "preferences.ini" and at the end was a gaming mouse preferences that is not in Player, but I added it manually, and BINGO! we're back in business! THANKS!!!
 

Great!

 

Looks like you have the posting issue, too... I made a thread in Support about this..

 

 

  • Like 1

Share this post


Link to post
Share on other sites
SoCalRox    246

YES!!! I noticed that yesterday for the first time!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.