• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Deleting WindowsApps folder?

Recommended Posts

nytiger73    8

Hello - 

 

I just did a Windows re-install and I am trying to do some cleaning up of my files and folders.  I have the WindowsApps folder on my 😧 drive which is a 2TB SSD.  I usually install games and some apps from the Windows Store onto this drive.  It is currently taking about 200 GB of space on my SSD and I want to get rid of it.  The thing is...I can't.  No matter what I try, I get various errors and I can't delete it to free up all of that space.  The error I get is attached to this post.  I should note that as far as I can tell, there is nothing accessing this folder.  I've rebooted numerous times to try to free up anything that might be accessing this folder.

 

I've tried taking ownership of the folder, took ownership of the root of the drive and giving myself Full Control, booting into safe mode. I even created a new user account and took ownership using that account  to no avail.  I discovered this issue, when I tried to change the save location of Apps to the D Drive and I received an error (a rather generic one at that)  I guess the last step would be to copy of the contents of the folder that I want to keep on there (about 1TB of games) over to my E: drive and format it, but I'd really rather not do that.  Has anyone run into an issue like this?  If so, how did you solve it so you were able to delete this folder.   

 

How the heck do I get rid of this godforsaken folder?!?  HELP!!

Annotation 2019-12-03 130743.jpg

Share this post


Link to post
Share on other sites
nytiger73    8

Pretty much, yes.  The only thing I didn't do was use the Add / Remove Programs folder to filter what was installed on that drive and remove them first.  The games that were installed in this folder were from my old Windows installation so, there was no way to remove what was in there using this method.  I ended up doing what I didn't want to do and copied out what I wanted to save and then formatted the drive.  I'll have to be more mindful in the future before reformatting my system to remove what is installed first so I don't run into this again.  It would be nice if Microsoft made it a little easier to get rid of this folder.  I get that it's encrypted files and folders and if it's a UWP app, but this is just insane that you can't delete a simple folder, even after a fresh install.

Share this post


Link to post
Share on other sites
goretsky    1,065

Hello,


The WindowsApps directory is where Universal Windows Platform applications (formerly known as Windows Store Apps, more formerly known as Modern apps, and even more formerly known as Metro apps) are installed.  These applications are sandboxed for greater security and, as a result, access to the directory is limited.  You could possibly create a WindowsApps directory on another drive and create a hard junction to redirect the directory to that location (e.g., create D:\WindowsApps and redirect C:\Program Files\WindowsApps to it), however, I have no idea what the results would be, so it would definitely require some experimentation on your part.

 

Regards,


Aryeh Goretsky

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.