• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

5.1 surround not working in Chrome

Recommended Posts

Elliot B.    1,653
Posted (edited)

I downloaded this YouTube video in both MKV and MP4 formats using 4K Video Downloader and MediaInfo confirms both contain 6-channel AAC LC audio.

 

The downloaded files, when played in PotPlayer v1.7.21126 (released in February 2020), definitely contain separate channels. It worked perfectly as intended.

 

However, when I play the video in YouTube (highest quality available; 1080p) in Google Chrome v80 (released in February 2020), I only get stereo (or fake surround - the rear channels play primarily through the front speakers).

 

Same issue in Internet Explorer 11.719.18362 and Microsoft Edge 44.18362.449.

 

Windows is set up correctly as, as I said, PotPlayer played the individual channels in the downloaded video file fine and all games work in surround as they should.

 

Any ideas?

Edited by Elliot B.

Share this post


Link to post
Share on other sites
Elliot B.    1,653
20 minutes ago, Circaflex said:

Have you tried the following?

https://superuser.com/questions/820845/how-to-get-5-1-audio-in-google-chrome

 

enable chrome://flags/#try-supported-channel-layouts

The flag no longer exists in Chrome v80 and adding it does nothing, unfortunately.

Share this post


Link to post
Share on other sites
Circaflex    3,582

tried adding this to the shortcut?  --force-wave-audio

Share this post


Link to post
Share on other sites
Elliot B.    1,653
On 3/19/2020 at 11:41 PM, Circaflex said:

tried adding this to the shortcut?  --force-wave-audio

Also depreciated :(

Share this post


Link to post
Share on other sites
Brandon H    3,511

I did a bit of googling and the following is the most recent relevant page I've found

 

https://support.google.com/chrome/thread/21248703?hl=en

 

some say having both --disable-audio-output-resampler --try-supported-channel-layouts flags on their shortcut works and others say none of the flags work so it appears it's hit/miss or google is breaking something with the flags with each update.

 

unfortunately you may just be out of luck in the web browsers. you could see if Firefox supports audio channels properly.

Share this post


Link to post
Share on other sites
Elliot B.    1,653
3 hours ago, Brandon H said:

I did a bit of googling and the following is the most recent relevant page I've found

 

https://support.google.com/chrome/thread/21248703?hl=en

 

some say having both --disable-audio-output-resampler --try-supported-channel-layouts flags on their shortcut works and others say none of the flags work so it appears it's hit/miss or google is breaking something with the flags with each update.

 

unfortunately you may just be out of luck in the web browsers. you could see if Firefox supports audio channels properly.

Nope, no change :( Depreciated in v80, I feel.

Share this post


Link to post
Share on other sites
+Zlip792    495

As suggested by @Brandon H, this is the latest solution which seems to work for people as old as 6 days ago.

 

I think you should give it another try but force closing all Chrome instances via Task Manager (assuming that you are using Windows) and then adding the flag in the Target field on Chrome shortcut properties (via Alt + Enter).

 

image.png

--try-supported-channel-layout

 

Once added, double check via chrome://version that the flag is working.

 

Further, with Chrome 79, the Google has added another Sandbox to move "Audio Component" out of process.

 

You can disable to check around whether it works fine after it or not:

 

https://support.google.com/chrome/thread/23003477?hl=en

 

via Registry:

 

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome
reg:dword AudioSandboxEnabled = 0

 

via flag (in shortcut):

 

--disable-features=AudioServiceOutOfProcess

 

It could be that Chrome's new sandbox feature is not compatible or supported with Windows multi-channel sound API or third party driver. So it is worth it to try again.

 

You should try these things:

 

1) Disable Out of Process features - try without other flag (sometime flags get deprecated because Google assume them to be ready to ship without any flag)

2) Try with multi-channel flag (by force closing all Chrome instances)

3) Disable Out of Process features with the multi-channel flag

Share this post


Link to post
Share on other sites
Elliot B.    1,653
Posted (edited)
On 3/22/2020 at 11:30 PM, Zlip792 said:

As suggested by @Brandon H, this is the latest solution which seems to work for people as old as 6 days ago.

 

I think you should give it another try but force closing all Chrome instances via Task Manager (assuming that you are using Windows) and then adding the flag in the Target field on Chrome shortcut properties (via Alt + Enter).

 

image.png


--try-supported-channel-layout

 

Once added, double check via chrome://version that the flag is working.

 

Further, with Chrome 79, the Google has added another Sandbox to move "Audio Component" out of process.

 

You can disable to check around whether it works fine after it or not:

 

https://support.google.com/chrome/thread/23003477?hl=en

 

via Registry:

 


HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome
reg:dword AudioSandboxEnabled = 0

 

via flag (in shortcut):

 


--disable-features=AudioServiceOutOfProcess

 

It could be that Chrome's new sandbox feature is not compatible or supported with Windows multi-channel sound API or third party driver. So it is worth it to try again.

 

You should try these things:

 

1) Disable Out of Process features - try without other flag (sometime flags get deprecated because Google assume them to be ready to ship without any flag)

2) Try with multi-channel flag (by force closing all Chrome instances)

3) Disable Out of Process features with the multi-channel flag

I only have:

 

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Adobe

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft

 

However, I did try closing Chrome and using:

 

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --try-supported-channel-layout --disable-features=AudioServiceOutOfProcess

 

Still not working 😞

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.