• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Stop devices randomly switching on the monitor/coming out of sleep etc?

Recommended Posts

kalkal    564

This has seriously been driving me insane forever now, I can't really believe I haven't looked into it before.

 

Wake on lan is off, I've turned off every device I can find from switching on my computer via device manager but still, at total random, if my display is off, it'll switch back on, if my PC is set to sleep, it'll randomly switch back on and I don't always want to do a full shutdown when I'm in and out the room.

 

What can I do to figure out why my pc is randomly waking from sleep? Event viewer doesn't seem to have shed much light on the situation.

Share this post


Link to post
Share on other sites
Jim K    14,439

Command prompt -->

powercfg -lastwake

 

?

 

....so nothing under "Source" -"Power Troubleshooter" in Event Viewer?

 

 

Share this post


Link to post
Share on other sites
kalkal    564

I've cleared the event logs so it's easier to read and it's not bloody doing it now I want it too 😆 

 

Will just have to wait longer :)

Share this post


Link to post
Share on other sites
Jim K    14,439

Yea, next time it wakes without you wanting it to ... try the powercfg -lastwake and see if it sheds any light on the issue.

 

Also...could it be Windows Update waking the computer? I do not have Windows in front of me at this time to dig into that further (on my phone)...just a thought.

Share this post


Link to post
Share on other sites
Jim K    14,439

@kalkal

 

...to follow up (now that I'm at my computer) ... if the powercfg -lastwake doesn't give you an answer ... it very well could be Windows Update.

 

 

Capture.thumb.JPG.2b39db75f1815694f9097c9e28b020a2.JPG

 

This is under task scheduler > Microsoft > Windows > UpdateOrchestrator

 

 

It could also be another program/task scheduler entry ... you can run the following in Powershell (run as Admin) which will give you a listing of all Task Scheduler entries which will "wake to run"

 

Get-ScheduledTask | where {$_.settings.waketorun}

 

You will get something like...

 

Capture1.thumb.JPG.b719914ab648d548a94590a00729774c.JPG

 

Anyway ... hope one of these things help you find your issue.

  • Like 1

Share this post


Link to post
Share on other sites
kalkal    564
12 minutes ago, Jim K said:

@kalkal

 

...to follow up (now that I'm at my computer) ... if the powercfg -lastwake doesn't give you an answer ... it very well could be Windows Update.

 

 

Capture.thumb.JPG.2b39db75f1815694f9097c9e28b020a2.JPG

 

This is under task scheduler > Microsoft > Windows > UpdateOrchestrator

 

 

It could also be another program/task scheduler entry ... you can run the following in Powershell (run as Admin) which will give you a listing of all Task Scheduler entries which will "wake to run"

 


Get-ScheduledTask | where {$_.settings.waketorun}

 

You will get something like...

 

Capture1.thumb.JPG.b719914ab648d548a94590a00729774c.JPG

 

Anyway ... hope one of these things help you find your issue.

Interesting, I haven't poked around scheduled tasks for a long time, I forgot they can wake the computer, I will also look into updating backup scan too.

 

I wonder if when it's fixed... I can actually just enable my mouse or keyboard to wake again, I actually like being able to do that but I've turned off as much as possible in an attempt to stop unwanted wakes. Will have to see what happens 🙂

 

Thanks for the advice!

Share this post


Link to post
Share on other sites
kalkal    564

So it happened.... however I'm not sure how to do anything about it...

 

XgpAJF8.png

Share this post


Link to post
Share on other sites
Jim K    14,439

The VID/PID is for your Logitech unifying receiver 

 

http://www.linux-usb.org/usb.ids

(lengthy list but you can search for the PID [product ID] which will be under the VID [Vendor ID])

 

So ... for some reason it seems that your mouse (probably) is waking up the system.

  • Like 1

Share this post


Link to post
Share on other sites
Steven P.    15,012
39 minutes ago, Jim K said:

The VID/PID is for your Logitech unifying receiver 

 

http://www.linux-usb.org/usb.ids

(lengthy list but you can search for the PID [product ID] which will be under the VID [Vendor ID])

 

So ... for some reason it seems that your mouse (probably) is waking up the system.

Interesting.. I also have a Logitech unifying receiver and it isn't waking the screen on mine, it is only used for my K800 keyboard though, my G502 is wired.

 

Logitech updated the Setpoint app last year (after 3 years or something) maybe check if you have the latest version. https://support.logi.com/hc/en-us/articles/360025141274-SetPoint

Share this post


Link to post
Share on other sites
adrynalyne    13,111
42 minutes ago, Jim K said:

The VID/PID is for your Logitech unifying receiver 

 

http://www.linux-usb.org/usb.ids

(lengthy list but you can search for the PID [product ID] which will be under the VID [Vendor ID])

 

So ... for some reason it seems that your mouse (probably) is waking up the system.

I used to have that issue. The slightest shift counts as movement. I just turn my mouse off. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.