• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Windows 7 startup issues.

Recommended Posts

Wanyoike Alex    5

So i decided to upgrade my RAM on my PC and the problem started when i installed the second 2GB stick i was adding to bring the total to 4GB. Initially after installing the new RAM in the extension slot, there were the 5 long beeps and flashing red light to indicate an error in memory. I realized it must have been the new RAM and removed it. 

 

After booting the computer again, it would get to the windows 7 start up logo and just freeze. At this point, I am stuck between reinstalling the OS and resetting the CMOS battery but then i'm afraid if i reset the CMOS the computer might develop some new issues. What do you think fam?

Share this post


Link to post
Share on other sites
+devHead    2,098

Wait, you're still running Windows 7?  Wow.

Try reseating the RAM again, or move the original stick to the other slot.

  • Like 1

Share this post


Link to post
Share on other sites
minimeau    236
35 minutes ago, devHead said:

Wait, you're still running Windows 7?  Wow.

Try reseating the RAM again, or move the original stick to the other slot.

I’m going run Windows 7 til 2030 lol

  • Like 2
  • Haha 1

Share this post


Link to post
Share on other sites
Wanyoike Alex    5

Oh yes i am... You have no idea how stable this operating system is. Although I have 2 machines, the desktop is on windows 7 but the laptop has windows 10.

Share this post


Link to post
Share on other sites
Wanyoike Alex    5

minimeau, i have already tried all that and nothing changed. I decided to reinstall the OS and everything up and running. Thank you for your response!!

Share this post


Link to post
Share on other sites
Peresvet    364

Are the two RAM sticks identical?

 

Which slots did you insert them in?

Share this post


Link to post
Share on other sites
minimeau    236
10 hours ago, Wanyoike Alex said:

minimeau, i have already tried all that and nothing changed. I decided to reinstall the OS and everything up and running. Thank you for your response!!

Nothing gonna change...I was just kidding. I’ve got Win10

Share this post


Link to post
Share on other sites
Wanyoike Alex    5
14 hours ago, Peresvet said:

Are the two RAM sticks identical?

 

Which slots did you insert them in?

There is one black DIMM slot and the other 3 are white, i even later realized that they had different frequencies and that might have been the genesis of my problems.

Share this post


Link to post
Share on other sites
Peresvet    364
Posted (edited)
5 hours ago, Wanyoike Alex said:

There is one black DIMM slot and the other 3 are white, i even later realized that they had different frequencies and that might have been the genesis of my problems.

If the second RAM stick that you've inserted is not identical to your original one, then you should make sure that you have the "dual channel mode" turned off in bios.

 

If both are identical, you can safely activate the dual channel mode and try loading an XMP profile for those RAM sticks in BIOS to make sure your settings are optimal.

Share this post


Link to post
Share on other sites
Wanyoike Alex    5
Posted (edited)

  🙏

22 minutes ago, Peresvet said:

If the second RAM stick that you've inserted is not identical to your original one, then you should make sure that you have the "dual channel mode" turned off in bios.

 

If both are identical, you can safely activate the dual channel mode and try loading an XMP profile for those RAM sticks in BIOS to make sure your settings are optimal.

Thanks so much... I will get to it 🙏pan widget

  • Like 1

Share this post


Link to post
Share on other sites
+devHead    2,098
On 4/2/2020 at 5:40 AM, Wanyoike Alex said:

Oh yes i am... You have no idea how stable this operating system is. Although I have 2 machines, the desktop is on windows 7 but the laptop has windows 10.

Of course I have an idea how stable Windows 7 is; I ran it for its entire life and during the whole Windows 8 and 8.1 releases. It was just that good.  But I have Windows 10 on my main PC now.

  • Like 1

Share this post


Link to post
Share on other sites
Dhruv Mehta    0

If Windows 7 won't boot properly and doesn't show you the Error Recovery screen, you can get into it manually. First, power the computer completely down. Next, turn it on and keep pressing the F8 key as it boots. Select “Repair Your Computer” and run startup repair.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.