• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Laptop keypad issue

Recommended Posts

Deep_Level_Shark    6
Posted (edited)

I'm using Windows 8.1 in Laptop HP Pavilion 15-n012tx

 

When I run in Normal Mode , laptop keypad does not  work. 

 

How do I fix the keypad issue in Normal Mode ?

 

Following attempts have been made but still  unsuccessful :

 

1. updated Keypad driver with manual browse and select driver from Device Manager

2. updated Keypad driver with  automatic driver update from Device Manager

3. Opened Kaypad inside. Cleaned dust 

4. scanned laptop using Malewarebytes and cleaned.

 

None of these resolved keypad issue.

 

But when I run in Safe Mode , laptop keypad works fine. I can press any key and it works.

 

What is the issue and how do I fix the keypad issue in Normal Mode ?

 

 

 

 

 

 

 

 

Edited by Deep_Level_Shark

Share this post


Link to post
Share on other sites
Jim K    15,726

Is it set correctly?


Per the manual

Quote

 

Integrated numeric keypad

Set at the factory to function like an external numeric keypad. To alternate between this numeric function and the navigational function (indicated by the directional arrows on the keys), press the num lock key.  The keypad function that is active when the computer is turned off is reinstated when the computer is turned back on.

 

 

Any exclamations in Device Manager?  Other than that...I have nothing.

Share this post


Link to post
Share on other sites
Nick H.    10,690

I seem to remember that there is an option in the BIOS that disables the numberpad. Although I'm not sure that the option would be enabled/disabled depending on a normal boot and a safe boot.

 

Have you tried running a USB key with another OS to see if that changes things?

Share this post


Link to post
Share on other sites
yuanyasmine    1

As you seem to have discovered already, your problem is a software issue.

Try booting into safe mode and running MSCONFIG.

Click Start-Run then type MSCONFIG and click OK.

Click the startup tab and click the button to disable all. Then click ok and restart when prompted to do so. Boot normally and see if you still have the problem. If not, then return to MSCONFIG and start enabling items one at a time until you hit on the one causing the problems.

You should also note that your issue could be spyware/virus related. You might try getting Adaware AND Spybot search and destroy. Run them both and see what they find.

Share this post


Link to post
Share on other sites
Deep_Level_Shark    6
Posted (edited)

Update:

 

I have progressed some more steps in troubleshooting.

 

If I run in safe mode+ Minimal -----------> Keypad working fine.

If I run in safe mode+ Network-----------> Keypad not working .

 

https://imgur.com/a/Mx9MXML

 

What steps I can go next ?

 

Edited by Deep_Level_Shark

Share this post


Link to post
Share on other sites
Vince800    326

As  you're in msconfig, what happens if you go to General > Diagnostic startup and reboot.

Share this post


Link to post
Share on other sites
Deep_Level_Shark    6
1 minute ago, Vince800 said:

As  you're in msconfig, what happens if you go to General > Diagnostic startup and reboot.

Keyboard works fine with this.

Share this post


Link to post
Share on other sites
Vince800    326

Interesting. If you go to Services > Hide all Microsoft services. Do you have a long list of things and do any of these appear to be related to keyboards? I'm wondering if you have some kind of "helper" software which is conflicting with the driver.

Share this post


Link to post
Share on other sites
Deep_Level_Shark    6
Posted (edited)
31 minutes ago, Vince800 said:

Interesting. If you go to Services > Hide all Microsoft services. Do you have a long list of things and do any of these appear to be related to keyboards? I'm wondering if you have some kind of "helper" software which is conflicting with the driver.

Hide all Microsoft services showing this. 

there is one "Touch Keyboard and Handwriting panel service" (Microsoft corporation)  

 

IMG-20200622-WA0002.jpg

IMG-20200622-WA0003.jpg

IMG-20200622-WA0000.jpg

IMG-20200622-WA0001.jpg

Edited by Deep_Level_Shark

Share this post


Link to post
Share on other sites
Deep_Level_Shark    6
Posted (edited)

Now formatted system  with windows 10.

 

same issue.

 

keypad working in safe mode only

keypad  not working in normal mode 

 

This is frustrating.  ....... Windows older versions  were much better. Never faced such kind of issues.

 

 

Summary of troubleshooting

 

In Windows 8.1:

keypad working in safe mode+minimal only

keypad  not working in normal mode

 

 

Formatted laptop with Windows 10

In Windows 10:

keypad working in safe mode+minimal only

keypad  not working in normal mode 

 

Is this a software issues / hardware issue ?  Is there any issue with keypad ?

 

I am clueless where exactly the issue is.

 

 

Edited by Deep_Level_Shark

Share this post


Link to post
Share on other sites
+warwagon    13,976

Is it happening after the very first boot of the clean install of windows 10? Or is it after you get some drivers installed or after you get software installed such as Avast.

 

Was windows 10 clean installed using a Microsoft Windows 10 ISO or did you use some kind of restoration?

 

If it happens after the first boot, and when using a Windows 10 ISO, i'm suspecting maybe the intel management engine. You could see if they let you turn that off in the bios.

Share this post


Link to post
Share on other sites
Deep_Level_Shark    6
Posted (edited)
26 minutes ago, warwagon said:

Is it happening after the very first boot of the clean install of windows 10?

in fact during windows 10 installation time , I could not type also  but since choices are optional so that I could skip and  install finally.

 

26 minutes ago, warwagon said:

Was windows 10 clean installed using a Microsoft Windows 10 ISO

ISO

 

26 minutes ago, warwagon said:

i'm suspecting maybe the intel management engine.

Where do I see that ? I entered into BIOS by F10.  I dont see anyhting called "intel management".  There are 3 menus there naming "intel" though

 

In BIOS , under security I find these 

 

Intel (R) At support System  < Enabled>

Intel (R) At suspend  < Disabled>

Intel (R) At PBA support System  < Disabled>

 

 

Are you talking abut these ? any action required on these ?

Edited by Deep_Level_Shark

Share this post


Link to post
Share on other sites
+warwagon    13,976
12 minutes ago, Deep_Level_Shark said:

in fact during windows 10 installation time , I could not type also  but since choices are optional so that I could skip and  install finally.

 

ISO

 

Where do I see that ? I entered into BIOS by F10.  I dont see anyhting called "intel management".  There are 3 menus there naming "intel" though

 

In BIOS , under security I find these 

 

Intel (R) At support System  < Enabled>

Intel (R) At suspend  < Disabled>

Intel (R) At PBA support System  < Disabled>

 

 

Are you talking abut these ? any action required on these ?

The Intel AT support Is Intel "Anti Theft" ... so maybe that has something to do with it. You could always try disabling it and see if your keyboard works.

Share this post


Link to post
Share on other sites
Deep_Level_Shark    6
Just now, warwagon said:

The Intel AT support Is Intel "Anti Theft" ... so maybe that has something to do with it. You could always try disabling it and see if your keyboard works.

okay.  Checking that.  Will update here soon after restart.

Share this post


Link to post
Share on other sites
Deep_Level_Shark    6
5 minutes ago, warwagon said:

The Intel AT support Is Intel "Anti Theft" ... so maybe that has something to do with it. You could always try disabling it and see if your keyboard works.

did this change. 

restarted.

same issue. 

Keypad not working

Share this post


Link to post
Share on other sites
+warwagon    13,976
2 minutes ago, Deep_Level_Shark said:

did this change. 

restarted.

same issue. 

Keypad not working

Sent you a PM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.