There are many great features available to you once you register at Neowin, including:

  • Richer content, access to many features that are disabled for guests like commenting on the front page
  • Access to a great community, with a massive database of experience on hard & software issues, gaming and recreational activities, and more
  • Access to the Neowin IRC - you could make a friend from across the world and talk to them live
  • Access to Neowin contests & subscription offers and forums that are not open to guests/li>
  • It's simple, and FREE! · Register here

Forum upgrade to version 4.5


 Share

Recommended Posts

At 12PM CET the forum will go offline for an upgrade to 4.5 which is a major version update from our 4.4.x version.

 

It brings with it may new features and improvements (including better moderation tools, such as banning people from a topic) you can read about some of the changes here https://invisioncommunity.com/news/company/welcome-to-invision-community-45-r1206/ (note that Matt links to individual topics about features, because there are many changes). 

 

Hopefully our upgrade will go smoothly, but if it doesn't we can always roll back. In any case please be patient while we figure out problems should they arise.

Link to comment
Share on other sites

Will this improve how twitter embeds load onto topics? On anything not Chrome (i.e Firefox, Safari), a tweeter embedded causes any post anchor on page load to lose it's focus and you have to scroll around to find it.

Link to comment
Share on other sites

CSS is looking broken atm. Missing a lot of graphics assets and threads randomly only take half the window width...

 

Tried to reply to a post earlier with an image and it didn't automatically show the image like usual.

Link to comment
Share on other sites

16 minutes ago, FloatingFatMan said:

CSS is looking broken atm. Missing a lot of graphics assets and threads randomly only take half the window width...

 

Tried to reply to a post earlier with an image and it didn't automatically show the image like usual.

Yes, some things are broken right now, for the moment I have set the default theme as default so that topics and forums display properly.

Link to comment
Share on other sites

smoother upgrade than the original 4.0 release lol but yeah our custom themes do need some adjustments due to changes in 4.5

 

hopefully they should be cleaned up soon :) 

Link to comment
Share on other sites

6 minutes ago, BudMan said:

Any sort of estimate on how long the upgrade might take? 2 hours?  20 hours?

update was already completed early this morning. went surprisingly smooth.

was already completed when I first hopped on the forums for today like 7ish hours ago lol

 

now we just have to make some corrections/adjustments to our Orion themes which could take a bit of time since the main person that used to help maintain them isn't with Neowin anymore :(

Link to comment
Share on other sites

Can't use Neowin on my phone now easily, basically everyone's posts in the forum is missing the header for who's posted a reply so it's just a load of text or picture with a line separating them.

Link to comment
Share on other sites

16 hours ago, Brandon H said:

update was already completed early this morning. went surprisingly smooth.

was already completed when I first hopped on the forums for today like 7ish hours ago lol

 

now we just have to make some corrections/adjustments to our Orion themes which could take a bit of time since the main person that used to help maintain them isn't with Neowin anymore :(

 

I don't wish to tell you guys how to run the place buuuuut, don't you think sorting the themes out on a copy of the site might have been a good idea before doing the upgrade? ;)

 

This default skin is fugly...

 

Link to comment
Share on other sites

1 hour ago, FloatingFatMan said:

 

I don't wish to tell you guys how to run the place buuuuut, don't you think sorting the themes out on a copy of the site might have been a good idea before doing the upgrade? ;)

 

This default skin is fugly...

 

IIRC, I think they do do this before they apply it to the regular Neowin site.

Link to comment
Share on other sites

1 hour ago, DocM said:

Dark Mode is broke in Forums, but the switch is visible in the articles. Any ideas?

 

the normal Orion theme is being fixed up first and then the alternate colors (darkside included) will get corrected

  • Like 2
Link to comment
Share on other sites

The icon for liking a post is just it's shadow, Orion theme:

image.png.db37493e24d5d0421003ed70976a6ca4.png

On Microsoft Edge (Chromium) and iPad Safari.

Link to comment
Share on other sites

1 minute ago, Mindovermaster said:

I don't even see the dark theme... Think they took it off to fix it...

Darkside is currently set to subscribers only due to its incomplete state; that are some parts of it that make it hard to use right now.

 

Once the main Orion theme is back to near perfection then the color variances (Darkside and Pro) will be tweaked and re-enabled for everyone :)

  • Like 2
Link to comment
Share on other sites

18 minutes ago, primortal said:

The icon for liking a post is just it's shadow, Orion theme:

image.png.db37493e24d5d0421003ed70976a6ca4.png

On Microsoft Edge (Chromium) and iPad Safari.

 

I see that, too. I'm on WaterFox 2020.07 (fork of FireFox)

Link to comment
Share on other sites

1 minute ago, shockz said:

Where's the edit button?

 

In IPB's genius they moved most post options including edit and report into the 3 dot menu in the upper right of the post...

Link to comment
Share on other sites

Just now, Brandon H said:

 

In IPB's genius they moved most post options including edit and report into the 3 dot menu in the upper right of the post...

I think we'll be bringing it back out of the menu shortly! It's mad they've hidden it away

Link to comment
Share on other sites

1 minute ago, DaveLegg said:

I think we'll be bringing it back out of the menu shortly! It's mad they've hidden it away

it makes sense for mobile view but definitely not for desktop view

Link to comment
Share on other sites

2 minutes ago, Mindovermaster said:

Why are there 2 report links? lol...

 

One next to quotes and one in the 3 dots menu?

I'm in the middle of tweaking that menu so the edit & report options are easier to access (making it so you don't need to click the three dots first) - They should be gone from the menu now

4 hours ago, primortal said:

The icon for liking a post is just it's shadow, Orion theme:

image.png.db37493e24d5d0421003ed70976a6ca4.png

On Microsoft Edge (Chromium) and iPad Safari.

This should be fixed now

Link to comment
Share on other sites

11 minutes ago, DaveLegg said:

This should be fixed now

Yep, all fixed.  Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.