Icons missing from shortcuts / empty, white, shortcuts; how come?


Recommended Posts

kiddingguy
Posted (edited)

I just reinstalled Windows 10, because of missing icons/images on my games.

There were quite a lot - plus some other issues on my previous installation - which made me decide to do a reset.

 

However, I just found  at this issue keeps occuring.

Anyone else having this issue (not only on games - which are installed on a different drive), but also on programs directly installed on my C-/Windows-drive.

 

Are you have this as well?

And what can be the cause of it?

 

EDIT:

These games are from different stores: Steam, Epic, Origin etc.

 

Games.jpg

Link to post
Share on other sites
kiddingguy
Posted (edited)

Also this one didn't help... 

What to do now?

 

I have restored/reset Windows from the Asus-image already on my Windows 10 notebook.

I wasn't able to download a Windows Cloud version...

 

Might it be that the imaged version is corrupt somehow? And that I better can start from scratch - and a brand new copy of Windows 10 ISO?

Or is my SSD somehow broken/corrupt? 

 

Or... maybe run a a regcleaner from CCleaner?

Edited by kiddingguy
Link to post
Share on other sites
adrynalyne

Take the idea of a registry cleaner, stick it in the furthest reaches of your mind, and then put a mental lock on it that you will never unlock.

 

So let me see if I got this.

 

So you used the Asus image on your notebook, I assume this is a recovery, and it still had the problem?

 

Or did you also restore your data, and then re-introduce the problem?

Link to post
Share on other sites
kiddingguy
Posted (edited)
36 minutes ago, adrynalyne said:

Take the idea of a registry cleaner, stick it in the furthest reaches of your mind, and then put a mental lock on it that you will never unlock.

 

So let me see if I got this.

 

So you used the Asus image on your notebook, I assume this is a recovery, and it still had the problem?

 

Or did you also restore your data, and then re-introduce the problem?

RegCleaner didn't fix it.

Yes, I did the restore/reset from Asus image on my laptop.

I have reinstalled everything [so no restore of my data]. And the icons like 'Cyberpunk' en 'Word In Conflict' were there for a while, and than magically disappeared.

 

The curious thing is... app like MS Office, Adobe Acrobat etc are there and shown.

Link to post
Share on other sites
adrynalyne
Posted (edited)
29 minutes ago, kiddingguy said:

RegCleaner didn't fix it.

Yes, I did the restore/reset from Asus image on my laptop.

I have reinstalled everything [so no restore of my data]. And the icons like 'Cyberpunk' en 'Word In Conflict' were there for a while, and than magically disappeared.

 

The curious thing is... app like MS Office, Adobe Acrobat etc are there and shown.

Silly question: Does F5 on your desktop do anything?

 

Are these using bad icons coming from games using game services like Steam, etc?

Link to post
Share on other sites
Nick H.
1 hour ago, adrynalyne said:

Take the idea of a registry cleaner, stick it in the furthest reaches of your mind, and then put a mental lock on it that you will never unlock.

 

1 hour ago, kiddingguy said:

RegCleaner didn't fix it.

In his defence, ardrynalyne as much as told you that it wouldn't. Registry cleaners are just terrible programs, almost always making any changes for the worse. They should never be used.

 

I'm not sure that I have any advice on this. For Steam games at least, it looks like the shortcuts are web URLs. Have you checked your link associations to make sure they are correct? For example, making sure that steam:// automatically uses the Steam launcher? For example, check here and here as well.

  • Like 1
Link to post
Share on other sites
Fleet Command
Posted (edited)

Suggestion 1: Set and reset the icons manually.

 

Try this for each one of those bad icons:

  1. Select the item
  2. Press Ctrl+Enter to open the Properties dialog box.
  3. Check the "General" tab and see if the "Type of file" value is "Shortcut (.lnk)". Proceed if the answer is yes.
  4. On the "Shortcut" tab, press the "Change Icon..." button. Two things might happen:
    1. The correct icon is already selected: Select something else, press "OK".
    2. The correct icon is not selected: Hunt down the correct icon file on your hard drive. It is usually in the game's installation folder.
  5. Press OK to apply the changes.
  6. If you deliberately changed the icon to something incorrect in step 4, repeat steps 1, 2, and 4 again to set icon to the correct one.

 

You probably see what I'm getting at with these instructions, so if the answer to the third step was "No", you might still be able to set and reset the icon for whatever file type you have there.

 

Suggestion 2: Tell Steam or Epic Launcher to create an icon for you. If I remember correctly, in Steam, you do so by right-clicking on the game's name in Library's entry. In the Epic Launcher, you have to do so from the hamburger menu.

Link to post
Share on other sites
kiddingguy
Posted (edited)

@Fleet CommandNope, didn't work either.

@adrynalyne Yes, F5 - also Refresh - didn't do the trick either.

 

Kinda strange, right? This behavior?!

 

Cyberpunk.jpg

Link to post
Share on other sites
BimBamSmash

Aren't these supposed to be executive or shortcut files? Why is it saying that file type is a URL?

Link to post
Share on other sites
Jim K
19 minutes ago, BimBamSmash said:

Aren't these supposed to be executive or shortcut files? Why is it saying that file type is a URL?

They are "URL" from Steam.  I don't know what he did or how to fix it ... but it should look something like this...

 

Capture.JPG.234e056f2f29e069985c6dc8c528d4e3.JPG

 

Capture1.JPG.d338f040ccb5e2bf181ce66ab2e70deb.JPG

 

(highlighted the differences)

Link to post
Share on other sites
kiddingguy

YESSSS!! I got them back!

 

What did I do... just followed the solution from 'henvaen6 18 Sep, 2017 @ 12:02am" at https://steamcommunity.com/discussions/forum/1/392183857628047411/

 

"My steam icons just disappeared today, but I found the solution by accident. Windows had apparently forgotten how urls work so the default app for opening them was reset. Just rightclick the shortcut and select properties. Then you'll see there's no app for opening a url so click select and pick "internet browser", this both made the shortcuts work and refreshed all the icons.
If you pick steam, which seems like the right choice all the shortcuts will open steam and have the steam icon, this includes all url shortcuts that are not shortcuts to steam games."

Cyberpunk2.jpg

  • Like 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.