I can't install Nvidia GeForce Game Ready DCH drivers.


 Share

Recommended Posts

It appears that the Standard Nvidia Game Ready drivers are no longer being offered.  DCH appears to be the only option.  Makes sense since Intel and AMD only supply DCH drivers.

 

My recollection is that I haven't been able to install Nvidia DCH drivers since I installed 20H2 when it became available on Windows Update.  Prior to 20H2 I was using the DCH drivers. As a result of not being able to use the DCH drivers I have been using the Standard drivers. The first thing I notice when installing the DCH drivers is that my screen does not go blank or change resolution as the Standard drivers do during the install. This is my first indication the install will fail. The message when done is the the Nvidia Installation Failed. It is not the more common message of a compatibility issue. I have tried everything I can think of, short of installing Windows clean, to try and get the DCH drivers to install. These include.

1. An in place update of Window 10. Not to be confused with a clean install.
2. Ran the 3rd party DDU program to get rid of all traces of Nvidia. In Safe Mode as well as Normal mode.
3. Ran the install program as Admin.
4. Checked the box on the Nvidia install screen to perform a clean install.
5. Installed over my current Standard driver.

6. Ran Nvidia's cleanup utility.

7. Used various uninstall program utilities.

8. Deleted every reference to Nvidia in my Registry as well as driver files which usually start with nv.

9. Manually extracted the DCH drivers into their own folder and ran setup from there. Ran as Admin too.

 

I use the Realtek DCH audio drivers and never had a problem installing them.  It's possible upgrading to Windows 11 might let me install the Nvidia DCH drivers.  I plan to upgrade using Windows Update not a clean install.  I have too many programs that I would have to install again and I really don't have the time or energy to do so.  If the Standard drivers are no longer available I am basically 'stuck' on version 472.12 forever. 

 

There must be something on my system that is causing the DCH packaging for the drivers to fail.  I am hoping someone with way more knowledge of Nvidia DCH packaging can point me to the problem. Perhaps there is a file in the DCH package that needs changing.  As mentioned I regularly install the Realtek DCH drivers.

 

Nvidia support was of no help whatsoever.

 

You're my only hope Neowinians 🙂



 

Edited by Pork Chopper
Link to comment
Share on other sites

I'll take a stab at it.

 

Quote

What is the difference between NVIDIA Standard and DCH Display Drivers?

Functionally, there is no difference between NVIDIA’s Standard and DCH drivers. While the base core component files remain the same, the way DCH drivers are packaged and installed differs from previous (Standard) drivers. When directly comparing the two driver types, the DCH driver package has a smaller size and a faster installation time than the Standard package.

 

If I read that correctly from Nvidia.. the DCH vs. Standard is as you have explained, a difference in packaging and installing. Drivers are the same.

 

One thing I've learned early on back in the day, is even if you're on an "admin" level acct, the actual Admin acct works a bit differently. Try turning that acct on, and installing thru that. Use the same path as you did on your normal acct. DDU via safe mode, then log into the Admin to install.

 

To turn on the admin acct, click on Start, Run.. type in CMD. Right click and run as admin. In the DOS window type:

net user administrator /active:yes

 

Log off your acct, and it will be an option on the login screen. May take a few to set up if you've never used it.

 

If it works.. and you want to turn that acct off, do the same as above, only replace the "yes" with a "no". =  net user administrator /active:no

 

 

Link to comment
Share on other sites

Unfortunately running under an Administrator account still results in the failed install.  I also used a couple of third party programs to run the actual setup file as TrustedInstaller and Admin with the same error message.  I believe it's the packaging that is having the problem.  IMO the driver hasn't even reached the point of being installed.  This is borne out by the fact that my screen doesn't go through the blank screens and change of resolution I get when I install the Standard drivers. 

 

I extracted the DCH package and one interesting file is called ListDevices.txt. It has all the Nvidia cards within it.  My card in Device Manager under Device Description shows "NVIDIA GeForce RTX 2080 Ti." Other entries show it as PCI\VEN_10DE&DEV_1E07&SUBSYS_24873842.  The ListDevices.txtfile has the following in it as it pertains to my type of card:

 

    Line 69:     DEV_1E07 "NVIDIA GeForce RTX 2080 Ti"
    Line 70:     DEV_1E07&SUBSYS_143510DE "NVIDIA GeForce RTX 2080 Ti"
    Line 733:     DEV_1E07&SUBSYS_A503174B "NVIDIA GeForce RTX 2080 Ti"
    Line 853:     DEV_1E07&SUBSYS_87261043 "NVIDIA GeForce RTX 2080 Ti"
    Line 2401:     DEV_1E07&SUBSYS_37181028 "NVIDIA GeForce RTX 2080 Ti"
    Line 4827:     DEV_1E07&SUBSYS_37111462 "NVIDIA GeForce RTX 2080 Ti"
    Line 5487:     DEV_1E07&SUBSYS_371B1462 "NVIDIA GeForce RTX 2080 Ti"
    Line 5904:     DEV_1E07&SUBSYS_B50319DA "NVIDIA GeForce RTX 2080 Ti"

 

The first entry looks like a generic name and matches the name in Device Description as stated above except for the DEV_1e07 prefix.  However the other entries do not match my card's full name.  I could add my card to the list but it's broken down in sections and I don't know which one to add it to.  If you have the same DCH package extract it, it is just a zip file, and have a look see for yourself.  There is also a CFG file there which might hold a clue.

 

As requested.

 

Edition    Windows 10 Pro
Version    21H1
Installed on    ‎1/‎12/‎2021
OS build    19043.1320
Experience    Windows Feature Experience Pack 120.2212.3920.0

 

 

Nvidia_Fail.png

Link to comment
Share on other sites

I recently read that you can install DCH over Standard.  It was on the Nvidia site.  Besides you would think running DDU would remove all traces of Standard.

Link to comment
Share on other sites

Thinking about the situation some more I would think that if my card was not in the ListDevices.txtfile I would get the "not compatible" error message. I still feel the problem lies in what is in the package.  Perhaps DDU is not cleaning out everything from my Standard install.  The bottom line is I will be relegated to using the current Standard driver until I build a new machine which is a good impetus to start looking around for my components :-).  For curiosity sake I would like to solve this first if possible.

Link to comment
Share on other sites

Something must be corrupt somewhere, just save all that hassle and reset your windows install in settings/update & recovery :) 

Link to comment
Share on other sites

If you mean an in place install of Windows as opposed to a clean install I already did that which didn't help. 

 

I just found on the Nvidia site a reg file to enable debugging during install.  I'll try that next.

Link to comment
Share on other sites

Interesting.  At one point I tried installing the DCH driver via Device Manager.  It also failed but I got an Access Denied 5 message.  Now I ran the Reg file from Nvidia to enable installation logging and also got an access denied 5 message.  I tried various programs that let me take ownership of the Reg Key in question but that didn't work.  Also I am able to add the keys manually by editing the Registry.  There are too many to do this.

Link to comment
Share on other sites

Got the reg file to merge.  Ran the DCH install again and I see Access denied 5 in the log file.  Here is the pertinent info:

 

dvi:                     Default installer: Enter 11:13:52.333
     dvi:                          {Install DEVICE}
     inf:                               {Install from INF Section - Section001} 11:13:52.333
     inf:                                    Flags         - 0x001005ee
     inf:                               {Install from INF Section - exit(0x00000000)} 11:13:52.349
     dvi:                               {Writing Device Properties}
     dvi:                                    Strong Name=oem42.inf:0f066de3e9306272:Section001:30.0.14.9649:pci\ven_10de&dev_1e07
     dvi:                               {Writing Device Properties - Complete}
     inf:                               AddService=nvlddmkm,0x00000002,nv_nvlddmkm_serviceInstallRS__01,nv_nvlddmkm_RS_eventlogging  (nv_dispi.inf line 599)
     dvi:                               Add Service: Modified existing service 'nvlddmkm'.
     inf:                               {Install from INF Section - nv_nvlddmkm_serviceInstallRS__01} 11:13:52.364
     inf:                                    Flags         - 0x00100004
!!!  inf:                                    Unable to create registry key
!!!  inf:                                    Error 5: Access is denied.
!!!  inf:                                    Error setting registry value HKCR\Directory\Background\shellex\ContextMenuHandlers\NvCplDesktopContext
!!!  inf:                                    Error 5: Access is denied.
!!!  inf:                                    Error parsing section [nv_nvlddmkm_serviceInstallRS__01], key=AddReg.
!!!  inf:                                    Error 5: Access is denied.
!!!  inf:                                    Error parsing section [nv_nvlddmkm_serviceInstallRS__01]
!!!  inf:                                    Error 5: Access is denied.
     inf:                               {Install from INF Section - exit(0x00000005)} 11:13:52.442
!!!  dvi:                               Unable to process registry directives for Inf Service Section 'nv_nvlddmkm_serviceInstallRS__01'
!!!  dvi:                               Error 5: Access is denied.
!!!  dvi:                               Error while installing services.
!!!  dvi:                               Error 5: Access is denied.
!!!  dvi:                               Cleaning up failed installation
!!!  dvi:                               Error 5: Access is denied.
     dvi:                          {Install DEVICE exit (0x00000005)}
!!!  dvi:                          Cleaning up failed installation (00000005)
!!!  dvi:                     Default installer: failed
!!!  dvi:                     Error 5: Access is denied.
     dvi:                {DIF_INSTALLDEVICE - exit(0x00000005)} 11:13:52.442
!!!  dvi:                Error(00000005) installing device!
     dvi:           {Install Device - exit(0x00000005)} 11:13:52.442
     dvi:      {Core Device Install - exit(0x00000005)} 11:13:52.442
     ump: {Plug and Play Service: Device Install exit(00000005)}
!!!  ndv: Device install failed for device.
!!!  ndv: Error 5: Access is denied.
     ndv: Installing NULL driver.

Link to comment
Share on other sites

Either your registry is corrupt, or there is a conflicting entry still in there the install program is rebounding from.

 

During a system check from an installer, it's looking for a list of yes and no, a long list.. and if they match, it proceeds.. if not, well here we are. 

 

If you want to fight the battle to win the war, the best option now would be to hand this over to Nvidia.. not that I expect any of their actual engineers will get on it... or, bite the bullet as it were, back everything up and do a fresh install. Wipe the entire drive (eliminate and recreate the install partition). MS will have a driver ready for it if you're connected to the net during install, so have your drivers ready to rock when it's done.

 

New 1's n 0's have a tendency to work better together.

Link to comment
Share on other sites

On 27/10/2021 at 06:58, Sensi said:

You cannot install DCH drivers if you have the standard drivers already installed, you will need to download and install the GRD(game ready drivers) from here: https://www.nvidia.co.uk/Download/index.aspx?lang=en-uk#

 

Untitled.jpg

not true... 

 

I did it on 3 PCs, the installer will simply remove the standard driver before doing the actual installer. worked fine.

Link to comment
Share on other sites

I installed 21H1 on a USB stick using Hasleo's WinToUSB program (Neat tool).  Lo and behold no problem installing the DCH drivers. So do I do a clean install of Windows along with installing everything I have or just wait until I build a new machine in which case I will have to install all my stuff.   Now that I have a working system with the DCH files maybe I can figure out the problem.  I already plan to merge the main Nvidia Registry entry onto my 'real' system.

  • Like 1
Link to comment
Share on other sites

Problem solved.  I did an in place install of Windows 10 and successfully installed the DCH drivers. Thanks guys for your suggestions.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.