GRUB entry for Kernel 2.6.8


Recommended Posts

Codegen

vmlinuz-2.6.8.1 is there. Yes, I did make install. But there isn't an initrd-2.6.8.1

Link to post
Share on other sites
raid517

default saved
timeout 15
color cyan/blue white/blue
foreground ffffff
background 2f5178
splashimage /boot/grub/mepis.xpm.gz

title MEPIS at hda2, kernel 2.4.26
kernel (hd0,1)/boot/vmlinuz-2.4.26 root=/dev/hda2 nomce vga=788 hdc=ide-scsi hdd=ide-scsi 
savedefault

title MEPIS at hda2, kernel 2.6.7
kernel (hd0,1)/boot/vmlinuz-2.6.7 root=/dev/hda2 nomce psmouse.proto=imps vga=788 
savedefault

title Custom Test1 at hda2 2.6.8.1
kernel (hd0,1)/boot/linux-2.6.8.1 root=/dev/hda2 nomce psmouse.proto=imps vga=7$
savedefault

title Windows at hda1
rootnoverify (hd0,0)
chainloader +1
savedefault

title MEMTEST
kernel /boot/memtest86.bin

Well I just tried this on debian to see if I could work out what was going on. What I did was the above. But unfortunately the new kernel wasn't listed in my boot menu either - and that is after running update-grub.

Maybe grub expects a new intrid to be present too? Unfortunately I never quite got round to working out how to create an initrd either. Sorry i can't be more help.

GJ

Link to post
Share on other sites
Fred Derf

With initrd you don't need to add the filesystems to the kernel as anything other than modules. That keeps the RAM footprint down a bit.

You need to compile the kernel the debian way:

http://www.l0t3k.net/biblio/linux/debian/e...-recompile.html

Personally I find this a tad confusing. It boots the INITial RamDisk before loading the ReiserFS module but the initrd file in stored on my ReiserFS partition. That sounds like a Catch-22 to me but so long as it works then I don't care.

It's like RAID5. I don't really unstand how one drive is enough parity to cover the entire array but it seems to just work so I'll leave it be and be happy.

Link to post
Share on other sites
Codegen

I'll try that when I wake up again this morning :p (quarter past 1 here)

Link to post
Share on other sites
vuerro

If u: rpm -q kernel

do u see the kernel listed there?

and if u: rpm -q kernel-source

do u see the right sourcecode?

otherwise u could do: rpm -qa | grep kernel

Does it matter that it doesn't seem to have installed a new 2.6.8.1?

I'll try it anyways, nothing to lose, and I'm bored anyways

Review the complete topic (launches new window)

But as u told me that u rpm-ed the kernel It should be there

Link to post
Share on other sites
Fred Derf
I'll try that when I wake up again this morning :p (quarter past 1 here)

The instructions I posted were for Debian since raid517 had mentioned that.

Now that I reread the thread I see that you run Suse. There may be sections pertaining to the creating of an initrd that may help you but you probably can't follow the instructions I posted step for step.

Sorry, if that was confusing.

Debian users, however, should take note of it.

Link to post
Share on other sites
Codegen
If u:    rpm -q kernel

do u see the kernel listed there?

and if u:  rpm -q kernel-source

do u see the right sourcecode?

otherwise u could do:  rpm -qa | grep kernel

But as u told me that u rpm-ed the kernel It should be there

Ok, I'm gonna make this clear this time

I AM NOT USING AN RPM

Link to post
Share on other sites
vuerro

(so I missed a word..., re-read the thread and saw it this time.. u happy now)

then I would suggest to make an RPM doing the following;

make rpm

or u can try it any other way.. (make install did not work for me either)

1. make oldconfig
2. make dep
3. make clean
4. make bzImage 
5. make modules
6. make modules_install
7. make rpm (<--- I know this should not be nessesairy, but it did make it work)


8. /sbin/mkinitrd /boot/[i]initrd-2.4.18.img[/i] [b]2.4.18[b]
[i]new image name[/i] /lib/modules/[b]kernel version folder[/b]

9. manually edited grub (by looking at the line's before and not forgetting anything/leaving anything out)

Use it or not, this worked for me.

happy hunting (Y) :ninja:

Edited by vuerro
Link to post
Share on other sites
Codegen

I only mentioned it 5 times :rolleyes:

Anyways, Back on topic, it's doing the make rpm thing now.

Link to post
Share on other sites
vuerro
I only mentioned it 5 times :rolleyes:

Anyways, Back on topic, it's doing the make rpm thing now.

u are right :blush: :alien:

/ontopic

i searched on www.google.com/linux for "make initrd"

It gave me a link to a redhat (as I'm using Fedora Core 2, I found it the best link)

that was my solution.

Link to post
Share on other sites
Codegen

There is now an initrd-2.6.8.1, but I still get the blank screen. I'll post my mnu.lst when I get a chance.

Link to post
Share on other sites
Codegen

# Modified by YaST2. Last modification on Sat Aug 14 20:35:36 2004

color white/blue black/light-gray

default 0

timeout 8

gfxmenu (hd0,5)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###

title Linux.old

kernel (hd0,5)/boot/vmlinuz-2.6.4-52-default root=/dev/hdb6 vga=0x31a splash=silent desktop resume=/dev/hdb5 showopts

initrd (hd0,5)/boot/initrd-2.6.4-52-default

###Don't change this comment - YaST2 identifier: Original name: windows###

title Windows

root (hd0,0)

chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###

title Failsafe

kernel (hd0,5)/boot/vmlinuz root=/dev/hdb6 showopts ide=nodma apm=off acpi=off vga=normal noresume nosmp noapic maxcpus=0 3

initrd (hd0,5)/boot/initrd

title Linux 2.6.8.1

kernel (hd0,5)/boot/vmlinuz-2.6.8.1 root=/dev/hdb6 vga=0x31a splash=silent desktop resume=/dev/hdb5 showopts

initrd (hd0,5)/boot/initrd-2.6.8.1

Link to post
Share on other sites
raid517

If you are getting a blank screen during start up and you have configured grub correctly, then it means you forgot to include support for framebuffer devices in your kernel. You should choose device drivers->graphics support->Vesa [*]->Console display driver support[*]-> Video mode selection support [*]->Framebuffer Console support[*]->Logo configuration and then yes to all the next three options. Then you get to pick a nice pretty logo too during boot up.

GJ

Link to post
Share on other sites
Codegen

oops, I thought that was for laptops.

Link to post
Share on other sites
Codegen

Well, now I get this for a couple of seconds and then it goes blanky blanky

post-30-1093059266.jpg

Link to post
Share on other sites
Codegen

whoops, I modulized somehting.

Link to post
Share on other sites
ootput

:no:

So it was his Kernel config after all... :crazy:

Link to post
Share on other sites
Codegen

Well, making some progress

now I get:

kernel panic: unable to mount vfs.

I'll post a pic in a sec.

Link to post
Share on other sites
Codegen

Here we go:

edit: well, you can handle looking at it sideways, can't ya?

and I find it strange that is is pointing to hd0,0, as in menu.lst it is set to hd0,5

post-30-1093061373.jpg

Link to post
Share on other sites
JustGeorge

Oh hell....I just installed SUSE 9.1. What does it have in store for me :(

Link to post
Share on other sites
ootput
Here we go:

edit: well, you can handle looking at it sideways, can't ya?

and I find it strange that is is pointing to hd0,0, as in menu.lst it is set to hd0,5

==Disclaimer==

I haven't read this thread in its entirety

You grub.conf seems to be configured incorrectly.

At your grub prompt (access it via the menu,) try issuing the various boot/root commands whilst tab-completing to verify the location of your /boot + / partitions.

Link to post
Share on other sites
Codegen

If it helps, here is my grub.conf

root (hd0,5)

install --stage2=/boot/grub/stage2 /boot/grub/stage1 d (hd0) /boot/grub/stage2 0x8000 (hd0,5)/boot/grub/menu.lst

quit

~

~

~

~

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.