• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

LAN's and multiple users, how do I do it?!?

Question

Slacker    6

I have two accounts set up on my XP computer, one for myself and one for guests. So far everything works great except for one thing. While I have access to my LAN the guest account does not.

Everytime I try accessing my workgroup I get an error about not having access, contact system admin, etc... I have tried giving access so that the guest account can access shared items on the LAN but have been unsuccessful. I tried looking in gpedit.msc but had no success finding a setting to allow access.

Doe anyone have an idea for me that might fix this problem. I'm sure that there is a setting to allow access to shared LAN items I'm just having trouble finding it. Can anyone help?

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
Krome    204

You're not very clear but I assume you are trying to share internet? In that case, use some kind of proxy... it's painless...

Share this post


Link to post
Share on other sites
  • 0
ahodes1    0

Make sure Guest is enabled on BOTH computers and that the Guest account has explicit NTFS access to the folders he/she needs.

Share this post


Link to post
Share on other sites
  • 0
Slacker    6

Actually, what I mean is that when I am in the guest account I cannot access network resources at all. Internet does work, but I cannot view or browse the workgroup. The guest account is active on all computers, they simply cannot view or browse the network.

Share this post


Link to post
Share on other sites
  • 0
Keldyn    1

moved to internet and networking

Share this post


Link to post
Share on other sites
  • 0
wd40    17

That is because the Guest account doesn't have privileges on the network to view things. You should add Guest to a group like Power Users or something. Then that account should be able to view the network also.

Be warned however that by doing that there is a slight security risk because now the guest account will have more privileges.

To do the above task follow these steps.

1. Right click on My Computer and select Manage

2. Go to Local Users and Groups and then Users

3. Double click on Guests and click Member Of tab at the top

4. Click Add

5. Below where it says "Enter the object names to select" type in Power Users and either click Check Names (to verify it works) or OK

6. And there you have it.

That should do the trick for you.

Oh I almost forgot one more thing that might work... in gpedit.msc

did you check out this?

Computer Configuration>Windows Settings>Security Settings>Local Policies>User Rights Assignment and look at the top policy titled Access this computer from the network.

Share this post


Link to post
Share on other sites
  • 0
Slacker    6

I tried using gpedit.msc, I figure that there must be a setting somewhere in there to d owhat I want. The problem though is not to allow a guest user access my computer from elsewhere on the LAN but to allow a guest on this computer access other computers on the LAN.

The way I see it, the setting should be in gpedit.msc under User ConfigurationAdministrative TemplatesNetworkNetwork Connections.

I can't find a setting that seems right, would someone else know that which I don't know.

My only other option would be to add the guest user to the "users" group, and I don't really want to do that.

Any more suggestions?

Share this post


Link to post
Share on other sites
  • 0
Slacker    6

Looks like that is close than anywhere I went to, but I don't have that setting listed in my local security policy thingy. I can't account for the discrepancy, but I really don't have that setting...

Share this post


Link to post
Share on other sites
  • 0
Krome    204

Why da heck you want to do that to Guest account slacker... On any XP box that I install, I always turn of Guest account... and I even delete guest privilege to some of the security settings... never ever touch Guest account or even use it... Create another account... just don't enable guest account...

Share this post


Link to post
Share on other sites
  • 0
ahodes1    0

Also try in any folder going to Tools then Folder Options and uncheck "Use Simple File Sharing". This seems to change a lot of file sharing things back to the way 2000 worked, i.e. you can configure NTFS permissions, share folders, administrative shares like C$, and whatnot. Give it a try, you never know.

Share this post


Link to post
Share on other sites
  • 0
Slacker    6

I finally gave int and created a second guest account. The new guest account has access to network resources and has very much the same security as the regular guest accont. I simply turned off (not disabled) the true guest account and all is the way that I want it to be except that I cannot name the new guest account "guest" or "guests"; I have settled for "visitor". I still think that the built in guest account could work the way I want it to, just as all Microsoft documentation says, but I'm too lazy to tinker that deep. I'm happy with the way it is now.

Thanks to all who suggested anything, as well as those who at least considered my problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.