cant find drivers for Sound Blaster Live! 24-bit


Recommended Posts

zeonsoldier

Well... way back when I originally posted my link, I could not find the drivers anywhere... at all... ever... When I did run accross them, it took an hour to download, so I decided to provide it myself on a higher speed connection.

If you say the problem now is not the drivers availability, but rather the software on the CD, I can try making an ISO out of the CD and posting that link instead. And I will make all my best efforts to keep the link active for as long as possible, and update it if needed.

Link to post
Share on other sites
  • 2 weeks later...
xtreme35967

Anyone used this card on Vista RC1 or RC2 yet? In both OS versions and with the XP Driver and the Vista Beta driver the Mic will not work and the 5.1 Surrond Sound will not work. Thanks

Link to post
Share on other sites
Cyryl The Wolf

:|

Uhh... Well... Looking at your system specs, I sure hope that you're NOT using Vista RC's as your primary operating system...

:no:

I haven't tried a mic with it. I honestly can't even help you with that one since I don't have a standard analog mic to begin with. All I've got are USB headsets for mic.

The best I can do is to tell you to make sure you get the PROPER Surround Mixer software installed (good luck finding that on Creative's website...) and to make sure that your MIC INPUT/OUTPUT are not muted by the system. I have also seen systems where you simply can't hear anything until you enable the MIC BOOST. (Usually +20 dB.)

Windows SHOULD have the basic functionality that you need in order to do this. All within the standard Windows Volume adjustment console.

By the way... In the future... Everyone...

PLEASE make sure you specify whether you are using the PCI or USB (External) version of this sound card. It will help eliminate confusion during the troubleshooting process.

I managed to help one guy in the Czech Republic with this problem so far. It took some work between the different time zones and much texting. But we figured it out.

For the record, the extra software that comes with the PCI version apparently DOES work with the USB (External) version of this sound device. Install the USB drivers for the External version and then install the software that comes with either the PCI or USB version and you should be good to go. This includes:

-Creative Device Control

-Surround Mixer

-GRAPHIC EQUALIZER (Without this you will NOT be adjusting bass or treble. Not even using the Windows volume adjustment console!)

I will be preparing modular updates and posting them on my mirror server that I rent. You will be able to download the drivers, CT Equalizer, Surround Mixer and Device Control SEPERATELY; as needed.

The only thing you may have to worry about is languages. The default language will be English.

I will also be making the ISO of the CD available for download once I rip it. Then all you'd have to do is use your burner to burn the ISO image to CD or use Daemon Tools to run it.

Cyryl

Link to post
Share on other sites
Cyryl The Wolf

Wuh-oh... I just noticed that you're also having trouble with the 5.1 features.

Ask yourself... How are you connecting your speakers currently?

You know that ORANGE hole on the sound card? Sometimes it's digital. Sometimes it's not. (The industry doesn't seem to be able to make up it's mind on that one for some damn reason...)

THAT, people...is usually the CENTER/SUB channel. Make sure that if you're using a real set of 5.1 speakers that have the FRONT L/R (green), REAR L/R (black) and CENTER/SUB (orange) channels...the cables coming from the speakers will be colored the same. (With possible varying shades of these colors...)

The one that people get confused is the CENTER/SUB channel. They plug the CENTER/SUB cable into the DIGITAL output sometimes. I'll be honest when I say that I'm not sure that even I fully understand how they intended some of these outputs to be used...

But I sure as hell figured it out when I bought my Logitech Z5500's. :) Took some time and a lot of getting pi$$ed off but I sure as hell got it.

The next thing to keep in mind is to make sure that you switch ALL of your software to 5.1, Surround, EAX, etc. This includes the Surround Mixer control panel that SHOULD come with the card but apparently sometimes DOESN'T, despite Creative Labs' insistence that they include it with EVERY card they ship...WITHOUT FAIL...

(I finally got one, BTW. I had to :angry: curse'em out. :angry: But it was for the greater glory!!! :p )

This also includes all of your games and multimedia applications.

There are MANY locations where you must make these settings. It's AGGRAVATING. But once you do it...it becomes a piece of cake after some practice.

Don't forget to switch your card to 96KHz and 24-bit using the Device Control console! (Defaults are 44KHz and 16-bit.)

Using Surround Mixer to test your speakers' connections is also very helpful. Use the TEST button under the speaker settings.

That's it for now. See how far that gets you.

Cyryl

Link to post
Share on other sites
  • 1 year later...
TCO-Busted
Wuh-oh... I just noticed that you're also having trouble with the 5.1 features.

Ask yourself... How are you connecting your speakers currently?

You know that ORANGE hole on the sound card? Sometimes it's digital. Sometimes it's not. (The industry doesn't seem to be able to make up it's mind on that one for some damn reason...)

THAT, people...is usually the CENTER/SUB channel. Make sure that if you're using a real set of 5.1 speakers that have the FRONT L/R (green), REAR L/R (black) and CENTER/SUB (orange) channels...the cables coming from the speakers will be colored the same. (With possible varying shades of these colors...)

The one that people get confused is the CENTER/SUB channel. They plug the CENTER/SUB cable into the DIGITAL output sometimes. I'll be honest when I say that I'm not sure that even I fully understand how they intended some of these outputs to be used...

But I sure as hell figured it out when I bought my Logitech Z5500's. :) Took some time and a lot of getting pi$$ed off but I sure as hell got it.

The next thing to keep in mind is to make sure that you switch ALL of your software to 5.1, Surround, EAX, etc. This includes the Surround Mixer control panel that SHOULD come with the card but apparently sometimes DOESN'T, despite Creative Labs' insistence that they include it with EVERY card they ship...WITHOUT FAIL...

(I finally got one, BTW. I had to :angry: curse'em out. :angry: But it was for the greater glory!!! :p )

This also includes all of your games and multimedia applications.

There are MANY locations where you must make these settings. It's AGGRAVATING. But once you do it...it becomes a piece of cake after some practice.

Don't forget to switch your card to 96KHz and 24-bit using the Device Control console! (Defaults are 44KHz and 16-bit.)

Using Surround Mixer to test your speakers' connections is also very helpful. Use the TEST button under the speaker settings.

That's it for now. See how far that gets you.

Cyryl

I really don't knwo what you peoples problems are. It seems that the people are not very Techy here. Every thread I read it takes forever for anyone to make a wise remark. Anyway here is the answer to your Very late QUestion. By now I would bet that you have replaced you great card.

Here is the answer to this very easy problem. 1.) You didn't receive a CD-ROM because you purchased a OEM model. 2.) you are all tellin him to look in Areas for a model he doesn't own, he needs Drivers for a Sound Blaster Live! Value 24 Bit ( I have this Very same Series Card Just a different model # and it was a sinch to find drivers for). Look on Creative Download page. Make sure it is a Live! Value nothing else will work. 3.) Creative Drivers Suck I would Suggest that you use a Third Driver Control Panel Called KX Audio Project. For you Vista Users out there it is the only way you will make your Surround Sound work on the releases of VISTA. Keep in mind the user interface will not work yet but all the functions of the card will be functional.

The News Link to the site is here, find all the information about the KX Audio control panel on this page. You can also find the download of the Driver pack on the right. http://kxproject.lugosoft.com/index.php?skip=1

The latest Driver download page is here http://kxproject.lugosoft.com/down.php?language=en

I promise that if you have listed your Card Model correctly this will work. If it doesn't work it is becuase you are looking for drivers for a card that you don't own. This would be why none of the driver packs are working. Some day I hope that i will find a techy responce here that matters and that will work without seeing 50+ responses of wrong answers. That is astounding if you ask me and really sad.

Cyryl The Wolf your long posts of babbling and whinnying I bet are also not really needed. All they will do is leave the one in question dissatisfied and stress out even more. Whining should never be introduced to others looking for help!

Ya'll have a great one Glade I was the one to give the answer to your question! Hoep you didn't give up on your card. despite the price these cards will actually out do the retail versions with the manufacture drivers, and own with the control panel that I listed above.

Link to post
Share on other sites
  • 4 months later...
Cyryl The Wolf

Wow. This was in 2004? Amazing...

And of course...the thread ends with an elitist DOUCHE BAG who thinks that posting links to the KX Project is going to somehow be better than having the REAL DEAL.

Just in case you ever see this... I am COMPLETELY aware of the differences between RETAIL and OEM. That was rather unnecessary of you. I had bought it RETAIL; as I'm sure that I stated above somewhere in all of the text - which seems to bother you so horrendously.

Also, what you UTTERLY FAILED to understand is that the drivers on CL's website are NOT comprehensive. They don't include ANY software you can use to adjust the settings. SEPERATELY there was the Audio Console that you use to adjust the frequency of the sound output but NOT the treble and bass. THAT is the biggest issue that people are having.

As for the stories that I told... I told them for a reason. I shared my experience with others so that they can compare their own and rule out certain issues. THIS IS WHAT FORUMS ARE FOR. No one here was bein' a dick about anything until YOU showed up and spouted off.

Way to be a dick...DICK.

Whatever. Seems to me that my information proved PLENTY useful here as I am STILL receiving emails from people telling me of their own experiences and requesting the download of the REAL drivers from me.

And I accommodate them...because I am not a DICK...dick.

At any rate... Just looking to see what all has happened here since I originally posted this. It's been a long while and the requests are on the upswing.

For all of you who are still looking for the REAL drivers and not that crap KX project software... I just released a torrent of the contents of the ORIGINAL CD. You can find them in the various popular torrent sites. This is NOT illegal software, either. So this should not be an issue. Just look for my release by my name or the obvious search terms and you should find them.

I'll be seeding this one out for a while. :)

Later all. (Except the DICK. You don't need to be part of all of this since you clearly don't care.)

Cyryl

Link to post
Share on other sites
  • 11 months later...
Cyryl The Wolf

Hey!!!

Here's an update. Since I've been getting more and more requests for the drivers... Just the other day, I came across this site and it was the JACKPOT to end all jackpots!

Enjoy folks! I'll be downloading ALL of those images to archive them since I've had requests for some of the other images as well.

http://hosted.filefront.com/BadBoyforum

Easy deal. Find the one that you're looking for and download it. I've already tested the one for the 24-bit card.

Let me know if you guys have any more questions. I'll still take them and give answers. I still haven't come to hate Creative Labs any less since my first post here. In fact, the entire internet seems pretty ****ed off at them. Go figure, eh? :D

See you all later! Keep it up and spread the link! There are many out there who still need our help.

Cyryl

Link to post
Share on other sites
  • 1 year later...
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.