• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Xnest & OS X

Recommended Posts

malebolgia    0

When I'm using my Linux box at work I enter Xnest :1 -query hostname -geometry 800x600 in a Linux terminal to X login to another Linux machine on the network. Will this same command work with the same effects in OS X?

When I tried it I got this error:

_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root

Fatal server error:
Unable to open display "".

Share this post


Link to post
Share on other sites
rezza    1

well, try setting the owner of /tmp/.X11-unix to root ;)

chown root.root /tmp/.X11-unix

Share this post


Link to post
Share on other sites
malebolgia    0
well, try setting the owner of /tmp/.X11-unix to root ;)

chown root.root /tmp/.X11-unix

584889747[/snapback]

When I try that command I get:

chown: separation of user and group with a period is deprecated

chown: root: Invalid argument

Share this post


Link to post
Share on other sites
rezza    1

So OSX doesn't have a root user then? maybe you could create one just to get this working. Oh, and try using a colon instead of a period.

Share this post


Link to post
Share on other sites
thekore    0

try just setting the owner to root using the following:

chown root /tmp/.X11-unix

Share this post


Link to post
Share on other sites
malebolgia    0

That got rid of the file permissions line, but the other two lines remain.

Fatal server error:
Unable to open display "".

Share this post


Link to post
Share on other sites
Spacedog    0
So OSX doesn't have a root user then? maybe you could create one just to get this working. Oh, and try using a colon instead of a period.

584890061[/snapback]

In Mac OS X, root is disabled by default.

Share this post


Link to post
Share on other sites
malebolgia    0
In Mac OS X, root is disabled by default.

584892574[/snapback]

How do I enable root?

Share this post


Link to post
Share on other sites
Spacedog    0

Quick and simple explanation: here (hope this help).

(EDIT: I think you can skip directly to the 'Addendum' at the bottom of the page: Start NetInfo Manager, and from the top menu bar pull down the "Security" item and select "Enable root user".)

Share this post


Link to post
Share on other sites
Southern Patriot    912
That got rid of the file permissions line, but the other two lines remain.

Fatal server error:
Unable to open display "".

584891718[/snapback]

Are you sure that you have X11 installed on your Mac? It's not installed by default. That might be the problem. Also, you might need to manually start it before running that command.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.