:FIX: HL2 Lagging in battles


Recommended Posts

Glatz

In Half-life 2 for some reason when I get into a an area with a lot of monsters the game goes from like 80-100 fps to like 10-20 fps. Well after a little digging I found a way to fix this problem. I am posting it here just in case anyone else is experiencing this same problem. Also I think this tweak would speed up the game itself.

First, you open notepad and paste this into it:

cl_forcepreload "1"

sv_forcepreload "1"

cl_smooth "0"

Second, you save that file as autoexec.cfg in the cfg folder of half life 2, something like

C:\Program Files\Valve\Steam\SteamApps\(your profile name)\half-life 2\hl2\cfg

*You can also put this file into the cs folder too and it will help cs.

Third, you just go and play. The autoexec.cfg file is automaticly executed when half-life starts. So if there are any other commands you want to be done every time hl2 starts this is the file to put them in, like cl_showfps "1" so you see the fps all the time.

Link to post
Share on other sites
DigitalN.

hmmm, I dont really get any lag in battles, but just to make sure I dont I better do this :p

Link to post
Share on other sites
Xtreme $niper

So what exactly does this do anyways.

Link to post
Share on other sites
ForeverUnknown
So what exactly does this do anyways.

584940785[/snapback]

that's what i would like to know

Link to post
Share on other sites
JohnO

While this thread is open how do you pick open gl or direct 3D for some reason my system has giant lag(fps) even thought i get 90+ on the source test

Link to post
Share on other sites
JadeWolf324
While this thread is open how do you pick open gl or direct 3D for some reason my system has giant lag(fps) even thought i get 90+ on the source test

584940796[/snapback]

u cant...its written entirely in DX9

Link to post
Share on other sites
Circaflex

its only d3d there is no opengl for hl2

Link to post
Share on other sites
JohnO

So, any idea why I get this fps problem? I have no background apps running and my drivers are 66.93 on a 6800GT

Link to post
Share on other sites
muzzle79
So, any idea why I get this fps problem? I have no background apps running and my drivers are 66.93 on a 6800GT

584940819[/snapback]

Post your specs system wise and your settings.

Link to post
Share on other sites
psychoticDEMENTO

It might that buggered sound issue. :/

Link to post
Share on other sites
ForeverUnknown

yeah load times are ridiculous. that sound issue is really starting to bother me now too

Link to post
Share on other sites
Kupo-Cheer
It might that buggered sound issue. :/

584940830[/snapback]

Which sound issue? I know when I had it set on only 4 speakers for sound there was a bug where the front speakers would play the sounds differently so it sounded like there was a weird echo all the time, but setting it to 5.1 fixed that.

Link to post
Share on other sites
JohnO

I have a 2500+ O'Cd to just 2ghz

1 gig geil 3200 ram

soundblaster live

6800GT

what else?

The system is 100% stable

I have nothing running when I game, therefore it has to be a HL problem

Link to post
Share on other sites
ForeverUnknown
Which sound issue? I know when I had it set on only 4 speakers for sound there was a bug where the front speakers would play the sounds differently so it sounded like there was a weird echo all the time, but setting it to 5.1 fixed that.

584940872[/snapback]

audio studdering. it gets really bad at times

Link to post
Share on other sites
Kupo-Cheer
,Nov 17 2004, 22:18]Anyone fix the load times? :|

584940839[/snapback]

Yeah, the load times are really annoying, but I kinda figure thats only because I lack memory (256mbs...)

Link to post
Share on other sites
Kupo-Cheer
audio studdering. it gets really bad at times

584940884[/snapback]

Yeah, that audio studdering I get is also an issue with memory I have because the whole game studders when its accessing the hard drive...

Link to post
Share on other sites
Xtreme $niper

Eh the only problem im having is load times.. Thats about it.

Link to post
Share on other sites
ForeverUnknown
Yeah, the load times are really annoying, but I kinda figure thats only because I lack memory (256mbs...)

584940890[/snapback]

i have 1gb of ram. it takes so long to load i have time to get up, take a pee, and be back just in time

Link to post
Share on other sites
JohnO

^^^So does it sound like I have audio problems?

What could remedy this?

Link to post
Share on other sites
Kupo-Cheer

Anyone else have a weird video problem where half the screen (near the middle) seems to flicker or something when you are trying to run fullsacreen, because I'm stuck to using windowed mode because of this... I can try to post a screenshot of it but its gonna take forever for me to load it up and change the video settings so I'm reluctant to do it...

Link to post
Share on other sites
bakerster
i have 1gb of ram. it takes so long to load i have time to get up, take a pee, and be back just in time

584940907[/snapback]

Same here.

You can actually take a **** too.

Link to post
Share on other sites
Kupo-Cheer
i have 1gb of ram. it takes so long to load i have time to get up, take a pee, and be back just in time

584940907[/snapback]

I have time to get up, fix a snack and get a drink, complain to my mom, yell some more, then sit back down and get comfortable just in time to have the game come studdering back into existence. (well, I'm off to go finish the game now...)

Link to post
Share on other sites
psychoticDEMENTO
^^^So does it sound like I have audio problems?

What could remedy this?

584940914[/snapback]

Nothing that I know of at this point, supposedly setting the audio quality down and setting to 2 speakers works, don't take my word on it, although it did sorta work for me. :)

Link to post
Share on other sites
Glatz

Well one thing I have heard about for fixing the audio has to do with the ffdshow codec, it seems that if you had that codec and made sure that with the mp3 options it is disabled you would get a lot less stuttering.

For what these settings do, I believe they force the engine to preload some thing for that area. What exactly, I am not too sure, but I havn't noticed any increases in loading times. Actually because of the ign article on tweaking for hl2 and some other stuff I did, like defragging with perfectdisk, I have seen a decrease in loading times.

Pretty much these settings just help. If you do try them and you see worse conditions just delete the autoexec.cfg file.

Edited by Glatz
Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.