• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

[HOW TO] Installing Wireless Networking

Recommended Posts

blik    1
,Aug 21 2005, 10:52]I get stuck on step 3 at point 4, he says the command isnt found.

586409763[/snapback]

:unsure:

Can you quote the command you're inputting?

Also, what distro are you using?

Share this post


Link to post
Share on other sites
Wannes    38

I am on Fedora Core 4, downloaded yesterday... the command is

ndiswrapper -l

but it says that the command isnt found...

Share this post


Link to post
Share on other sites
blik    1

As root, do

whereis ndiswrapper

Use the path it outputs when calling ndiswrapper...

I think it's going to be /sbin/ndiswrapper -l which you will have to use...

Share this post


Link to post
Share on other sites
Wannes    38

I'll try that right now.

Share this post


Link to post
Share on other sites
Wannes    38

I've tried it and got past it, now I am stuck on saving the document. I can't save it in the directory.

EDIT: wasnt logged in as root therefore he didn't save, going to test it now.

Edited by [a fire chronicle]

Share this post


Link to post
Share on other sites
bachya    0

I've tried this method, and I get everything to work...until I reach the command /sbin/dhclient wlan0. It says "No DHCPOFFERS received - no working leases in persistent database - sleeping."

I'm at my wit's end. Can anyone guide me further? I know Fedora fairly well, but for whatever reason, this just won't work for me. :no:

Edited by bachya

Share this post


Link to post
Share on other sites
sean l    1

This guide was a great help!! thanks a lot.

yeah, neowin has helped me get my linux distro up and running on my lappy.

Share this post


Link to post
Share on other sites
markjensen    98

Cool! :)

Thanks (again) to DjmUK, and the other Neowin *nixers for writing these guides for other Neowinnners! (Y)

Share this post


Link to post
Share on other sites
D.r.a.g.o.n.3.6    0

I Have A MSI Wireless Card which *NIX detects as a Ralink RT2500 which is the chipset it uses. If you have any cards that use this chipset getting wireless is very easy with native drivers. Most Distro's of linux will detect them. I've used this with Gentoo, SuSE 9.3 Pro, and Fendore 3.

Share this post


Link to post
Share on other sites
HoochieMamma    714
I Have A MSI Wireless Card which *NIX detects as a Ralink RT2500 which is the chipset it uses.  If you have any cards that use this chipset getting wireless is very easy with native drivers.  Most Distro's of linux will detect them.  I've used this with Gentoo, SuSE 9.3 Pro, and Fendore 3.

586498088[/snapback]

Whats the model of the card you have?

Share this post


Link to post
Share on other sites
D.r.a.g.o.n.3.6    0
Whats the model of the card you have?

586498092[/snapback]

Off the top of my head not sure its built in to my laptop and Windows Detects as something completely different. Let me take the MiniPCI cover off and ill get the model number for you.

Share this post


Link to post
Share on other sites
soder1011    0

Hi,

I have recompiled Red Hat FC4 to the kernel version 2.6.14.3, now I'm trying to install MadWifi. I am following this guide, halfway down the page:

http://www.neowin.net/forum/index.php?showtopic=292721&st=0

The latest WadWifi RPMs atrpms has is version 2.6.14. When I execute:

rpm -i madwifi-kmdl.....

I get the error:

" Failed dependencies:

/boot/vmlinuz-2.6.14-1.1637_FC4 is needed by madwifi-kmdl... "

Note that my image is /boot/bzImage-2.6.14.3

Should I rename my image to "vmlinuz-2.6.14-1.1637_FC4" and redirect GRUB to it? (Is it okay that my kernel is slightly newer than the RPM?) Or should I downgrade my kernel? Or what?

Thanks a ton!

D

Share this post


Link to post
Share on other sites
kRuNk    0

does this work with ubuntu?

the first guide?

Share this post


Link to post
Share on other sites
Brian    67

You my friend are going to have a HELL of a time. I've been working at it for a very long time now and to no avail. If you are using the AMD64 version look out... I think that is why I couldn't compile ndiswrapper.

You guys rule. I'll try this once my Ubuntu CDs come in the mail. (Shipit will send them to you free so that you have a "hard copy" that won't degrade.)

Share this post


Link to post
Share on other sites
dst    0

hi.

i am having a simmiliar problem as one of the other posters.

i am using Fedora Core 4 and trying to get a LinkSys WMP54GS to work.

i have downloaded my source: 'kernel-2.6.11-1.1369_FC4.src.rpm' from fedora

i then ran the rpm command on that file

it installed to /urs/src/redhat/SOURCES/

however, wheni checked out that directory all i saw was .patch and .config files

looking through i saw a file called linux-2.4.11.tar.bz2

i extrcted this file and found what appeard to be my source.

this doesnt seem right to me so im assuming this is the problem

i then went to install ndiswrapper-1.9 again

i did the suggested make operations

when i entered #make install it gave me the could not find source again. so.. i tried the suggested command and pointed it to where i had found my soure earlier. 'make KSRC=/usr/src/redhat/SOURCES/linux-2.6.11/'

didnt work.

i also tried 'make KSRC=/usr/src/redhat/SOURCES/linux-2.6.11/kernel/' which is where the source files are actuialy located. but that didnt work either

can someone with more linux experience please tell me where to go next. thank you very much to anyone that replys.

Derek

Share this post


Link to post
Share on other sites
merakli    0

I just did all and had the following response. everything looked perfectly fine, but wireless card is still not working.

anyone knows why?

[root@localhost hasan]# cd ndiswrapper-1.11

[root@localhost ndiswrapper-1.11]# make

make -C driver

make[1]: Entering directory `/home/hasan/ndiswrapper-1.11/driver'

make -C /lib/modules/2.6.11-1.1369_FC4/build SUBDIRS=/home/hasan/ndiswrapper-1.11/driver \

DRIVER_VERSION=1.11

make[2]: Entering directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'

LD /home/hasan/ndiswrapper-1.11/driver/built-in.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/hal.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/iw_ndis.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/loader.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/misc_funcs.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/ndis.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/ntoskernel.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/ntoskernel_io.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/pe_linker.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/pnp.o

/home/hasan/ndiswrapper-1.11/driver/pnp.c: In function ??start_pdo??:

/home/hasan/ndiswrapper-1.11/driver/pnp.c:317: warning: ignoring return value of ??pci_set_power_state??, declared with attribute warn_unused_result

CC [M] /home/hasan/ndiswrapper-1.11/driver/proc.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/wrapndis.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/wrapper.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/usb.o

CC [M] /home/hasan/ndiswrapper-1.11/driver/divdi3.o

LD [M] /home/hasan/ndiswrapper-1.11/driver/ndiswrapper.o

Building modules, stage 2.

MODPOST

CC /home/hasan/ndiswrapper-1.11/driver/ndiswrapper.mod.o

LD [M] /home/hasan/ndiswrapper-1.11/driver/ndiswrapper.ko

make[2]: Leaving directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'

*** WARNING: Kernel is compiled with 4K stack size option (CONFIG_4KSTACKS); many Windows drivers will not work with this option enabled. Disable CONFIG_4KSTACKS option, recompile and install kernel

make[1]: Leaving directory `/home/hasan/ndiswrapper-1.11/driver'

make -C utils

make[1]: Entering directory `/home/hasan/ndiswrapper-1.11/utils'

gcc -g -Wall -DUTILS_VERSION=\"1.8\" -o loadndisdriver loadndisdriver.c

make[1]: Leaving directory `/home/hasan/ndiswrapper-1.11/utils'

[root@localhost ndiswrapper-1.11]# make install

make -C driver install

make[1]: Entering directory `/home/hasan/ndiswrapper-1.11/driver'

make -C /lib/modules/2.6.11-1.1369_FC4/build SUBDIRS=/home/hasan/ndiswrapper-1.11/driver \

DRIVER_VERSION=1.11

make[2]: Entering directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'

Building modules, stage 2.

MODPOST

make[2]: Leaving directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'

*** WARNING: Kernel is compiled with 4K stack size option (CONFIG_4KSTACKS); many Windows drivers will not work with this option enabled. Disable CONFIG_4KSTACKS option, recompile and install kernel

mkdir -p /lib/modules/2.6.11-1.1369_FC4/misc

install -m 0644 ndiswrapper.ko /lib/modules/2.6.11-1.1369_FC4/misc

/sbin/depmod -a 2.6.11-1.1369_FC4

make[1]: Leaving directory `/home/hasan/ndiswrapper-1.11/driver'

make -C utils install

make[1]: Entering directory `/home/hasan/ndiswrapper-1.11/utils'

install -D -m 755 loadndisdriver /sbin/loadndisdriver

install -D -m 755 ndiswrapper /usr/sbin/ndiswrapper

install -D -m 755 ndiswrapper-buginfo /usr/sbin/ndiswrapper-buginfo

NOTE: Windows driver configuration file format has changed since 1.5. You must re-install Windows drivers if they were installed before.

make[1]: Leaving directory `/home/hasan/ndiswrapper-1.11/utils'

mkdir -p -m 0755 /usr/share/man/man8

install -m 644 ndiswrapper.8 /usr/share/man/man8

[root@localhost ndiswrapper-1.11]# ls -l /lib/modules/'uname -r'/misc/

ls: /lib/modules/uname -r/misc/: No such file or directory

[root@localhost ndiswrapper-1.11]# ls -l /lib/modules/hasan/misc

ls: /lib/modules/hasan/misc: No such file or directory

[root@localhost ndiswrapper-1.11]# ls -l /lib/modules/

total 8

drwxr-xr-x 4 root root 4096 Apr 1 19:33 2.6.11-1.1369_FC4

[root@localhost ndiswrapper-1.11]# ls -l /lib/modules/2.6.11-1.1369_FC4/misc/

total 2096

-rw-r--r-- 1 root root 2136598 Apr 1 19:33 ndiswrapper.ko

[root@localhost ndiswrapper-1.11]# whereis ndiswrapper ndiswrapper: /usr/sbin/ndiswrapper /usr/share/man/man8/ndiswrapper.8

[root@localhost ndiswrapper-1.11]# whereis ndiswrapper loadndiswrapper wlan_radio_averatec_5110hx

ndiswrapper: /usr/sbin/ndiswrapper /usr/share/man/man8/ndiswrapper.8

loadndiswrapper:

wlan_radio_averatec_5110hx:

[root@localhost ndiswrapper-1.11]# /usr/sbin/ndiswrapper -i /home/hasan/net5211.inf

Installing net5211

[root@localhost ndiswrapper-1.11]# ndiswrapper -l

Installed drivers:

net5211 driver installed, hardware present

[root@localhost ndiswrapper-1.11]# /sbin/modprobe ndiswrapper

[root@localhost ndiswrapper-1.11]# ndiswrapper -m

Adding "alias wlan0 ndiswrapper" to /etc/modprobe.conf

[root@localhost ndiswrapper-1.11]# /sbin/dhclient wlan0

Share this post


Link to post
Share on other sites
Gunho    0

This was a great guide! I'm pretty new to Linux and was able to follow it perfectly.

I am wondering one thing though. Is it possible to create another config/profile to use for 'open' access points so that one doesn't have to edit the original /etc/sysconfig/network-scripts/ifcfg-wlan0 file?

I use WEP key on my wireless router at home, but when i connect at school and work they both are open access. Its a little tireing redoing the config each time I change locations.

I've tried /ifcfg-wlan1 and ifcfg-wlan0:1 files, but to no avail. (though being new to linux its possible i over looked something) I also tried using the GUI netconfig but it yeilded the same effect.

Distro- Fedora Core 4

Kernel- 2.6.11-1.1369

Share this post


Link to post
Share on other sites
Gunho    0

*** WARNING: Kernel is compiled with 4K stack size option (CONFIG_4KSTACKS); many Windows drivers will not work with this option enabled. Disable CONFIG_4KSTACKS option, recompile and install kernel

I think its got something to do with you running the 4k stack size.

Not sure what distro your running but if you check here it should give you some idea of how to enable a larger stack size.

Fedora-NdisWrapper

Share this post


Link to post
Share on other sites
k311    1

THANK YOU!!! I have searched all over google and tried numerous ways of working with ndiswrapper and other options to try and get my network card to work in ubuntu and thanks to your instructions i am sitting here typing to you under my ubuntu desktop connected to my WEP enabled network. Thank you for this guide!

Share this post


Link to post
Share on other sites
zeroday    19

I got to this part:

7.) Type: /sbin/dhclient wlan0 (This activates the wireless connection - FINALLY!)

but I get this error:

Wireless: Error while getting interface flags: no such device (it does this twice)

Bind socket to Interface: no such device.

The card is recognized by Ubuntu, I set up the info in network manager, but I cant get a connection. :/

Share this post


Link to post
Share on other sites
DanManIt    1
I got to this part:

7.) Type: /sbin/dhclient wlan0 (This activates the wireless connection - FINALLY!)

but I get this error:

Wireless: Error while getting interface flags: no such device (it does this twice)

Bind socket to Interface: no such device.

The card is recognized by Ubuntu, I set up the info in network manager, but I cant get a connection. :/

I have the exact same problem.

Share this post


Link to post
Share on other sites
Budious    0

Run iwconfig and see which devices you have listed under the output. If none are listed you need to install drivers, otherwise use the device names listed in place of wlan0.

Share this post


Link to post
Share on other sites
DanManIt    1

Ok, I did that and heres what happened:

dan@dan-desktop:~$ iwconfig
lo		no wireless extensions.

eth0	  no wireless extensions.

eth1	  IEEE 802.11b/g  ESSID:off/any  Nickname:"Broadcom 4318"
		  Mode:Managed  Access Point: Invalid   
		  RTS thr:off   Fragment thr:off
		  Link Quality=0/100  Signal level=-256 dBm  Noise level=-256 dBm
		  Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
		  Tx excessive retries:0  Invalid misc:0   Missed beacon:0

dan@dan-desktop:~$ sudo /sbin/dhclient eth1
[sudo] password for dan:
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFFLAGS: No such file or directory
SIOCSIFFLAGS: No such file or directory
Listening on LPF/eth1/00:16:01:7d:48:0e
Sending on   LPF/eth1/00:16:01:7d:48:0e
Sending on   Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
send_packet: Network is down
receive_packet failed on eth1: Network is down
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
send_packet: Network is down
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
send_packet: Network is down
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 1
send_packet: Network is down
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Still doesnt work...

Share this post


Link to post
Share on other sites
Dm4975    0

I always get to step 3 part 4 when its verifying the windows driver and it tells me it's invalid? :o

any ideas?

Share this post


Link to post
Share on other sites
Dm4975    0

(Disapointed.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.