• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

[HOWTO]Get the NVIDIA drivers working

Recommended Posts

Lechio    15

This process of getting NVIDIA drivers to work with the new 2.6.x kernels

was made on a debian system, but can be easily adapted to other systems aswell.

*The x on the kernel package you need to replace with yor kernel version.

-First you need to get some packages from yor update system (using apt here) :

apt-get install kernel-headers-2.6.x kernel-source-2.6.x gcc nvidia-glx

-After those packages are installed via yor update system you will go and compile

yor kernel from those sources you've just downloaded (go here for details on howto compile a kernel) and in the compilation of the kernel you must disable rivafb module otherwise it may conflict with the NVIDIA drivers.

-Boot up with yor new compiled and installed kernel.

-Get the latest NVIDIA driver from their page: http://www.nvidia.com/object/linux.html

When downloading of the drivers is complete open a terminal and (as root) type telinit 1

it will take you to into single user console mode.

-Run the NVIDIA installer ./NVIDIA-Linux-x86-1.0-6629-pkg1.run

-After the instalation process is finished it's time to edit yor /etc/X11/XF86Config-4

or /etc/X11/X.org file if you are using the X.org Xserver. nano /etc/X11/XF86Config-4 or nano /etc/X11/X.org

Comment or remove Load "GLcore" and Load "dri", also be sure to have Load "glx" on it.

Should look like this after editing:

Section "Module"

#	Load	"GLcore"
#	Load	"dri"
         Load     "glx"

Replace the "nv" driver with the "nvidia" driver on the Device section:

Section "Device"
	Identifier	"NVIDIA Corporation"
	Driver  "nvidia"

In this section you can also have twinview enabled, and a bunch of other options (read the README file from NVIDIA for more details).

Save the file (on nano you press Ctrl+X to save files).

-Edit the file /etc/udev/links.conf ( nano /etc/udev/links.conf ) and add the following lines:

M nvidia0 c 195 0
M nvidia1 c 195 1
M nvidiactl c 195 255

(this is done because the nvidia devs don't get created fast enough by udev at startup)

Save the file.

Start yor Xserver by typing startx and enjoy a full hardware accel Linux desktop.

*/suggestion: apt-get install tuxracer :) */

Share this post


Link to post
Share on other sites
markjensen    98

Perhaps the most-used nvidia option is this one:

Option "NoLogo" "1"

Which turns off the annoying nVidia splash screen. (Y)

Share this post


Link to post
Share on other sites
Prosidius    54

I run kernel 2.6.8, do I have to download the kernel I have or can I get the latest one?

Share this post


Link to post
Share on other sites
markjensen    98
I run kernel 2.6.8, do I have to download the kernel I have or can I get the latest one?

585747214[/snapback]

Well, you already have the kernel binaries. To run the script from nVidia, I think it is likely you will need your kernel sources as well, so it can compile, if needed. The nVidia script is supposed to check for a pre-compiled source, but I don't think I have ever had it find one in the past for me...

An easier (much easier) method would be to use a tool such as apt-get, yum, or other package manager of your choice to install the appropriate binary module for you. What distro are you running?

Share this post


Link to post
Share on other sites
Prosidius    54

Debian. :) I tried to run the installer and it sayed I don't have kernel sources.

Share this post


Link to post
Share on other sites
g-n-t    0

then install the kernel source that matches your kernel in synaptic.

Share this post


Link to post
Share on other sites
MulletRobZ    2

Uh, the file /etc/udev/links.conf is not included in FC4. Tried the normal steps to install the NVidia drivers and still no luck. Here's my log and config files to see if anybody could catch any immediate errors.

Xorg_Config_and_Log_Files.zip

Share this post


Link to post
Share on other sites
Lechio    15
Uh, the file /etc/udev/links.conf is not included in FC4. Tried the normal steps to install the NVidia drivers and still no luck. Here's my log and config files to see if anybody could catch any immediate errors.

Here's a Red Hat page explaining the udev task: udev Red Hat

Don't think you need to go and do all of that work in Fedora.

You only need kernel-headers for the currently running kernel, gcc to

compile the nvidia driver, and the ususal tools that are used to make kernel

modules (i believe that the kernel sources are now called kernel-devel in Fedora).

Then just run the installer, no need to compile a different kernel here.

There are also available kernel modules from yum/apt.

Share this post


Link to post
Share on other sites
MulletRobZ    2

Never mind. Someone else gave me a link where I could get actual RPM files for this and it works without any extra configurations. Going to include it with my remastering project as well as the ATI drivers, but first I gotta make time for this project.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.