Linux Q&A


Recommended Posts

Sensayshun

^You lost me after the first line :p

I'll check the ATi site.

Link to post
Share on other sites
Rix
^You lost me after the first line :p

I'll check the ATi site.

586053634[/snapback]

Right click it, go to properties > permissions, and tick the 'execute' box next to owner ;)

Link to post
Share on other sites
Sensayshun

^Thanks, it gets me somewhere than says that it needs to be run by the 'super user'

As far as I'm aware, I'm the only user, and hence I'm also the admin.

Link to post
Share on other sites
markjensen

Well, most likely, you have set up a root (super user) password that you should never log into. You probably also set up a user account.

Since you got a message stating that you need to be super user, I assume that you are correctly logged in as your regular unpriveleged user.

The best way to run the app is to open up a terminal (also frequently called a shell or console) and type su to Switch User (the default is to switch to 'root', if you don't specify). It will then prompt you for the password. You do remember what you used for the root password, right?

Once you have entered the password, anything you type in the shell from that point on will be as 'root', not as your user. You have permissions to make system-wide changes.

Link to post
Share on other sites
Sensayshun

I don't remember ever setting up a root user, I don't remember that in the setup. And hence I don't know any password for it.

Edit: If I go to root terminal it asks me for my root password and if I tell it the password I would have used there it lets me into 'root terminal' where I'm guessing I can do anything.

Link to post
Share on other sites
Barney T.
If I go to root terminal it asks me for my root password and if I tell it the password I would have used there it lets me into 'root terminal' where I'm guessing I can do anything.

586053881[/snapback]

That is correct........ and where you can mess up if you are not careful...

Barney

Link to post
Share on other sites
markjensen

Yes. If it accepted the root password, you are in.

Now, to run the file... That may be a bit more 'fun', with you being new to this... :ermm:

You can use cd to change directory (just like in the DOS days, if you remember those), and navigate to where your file is stored. The ls (that is a lower-case "LS") will list the files there (like the DOS 'dir' command does).

Once you confirm that you are where your file is, run the following:

./filename

the "./" specifies the current directory, so Linux doesn't look elsewhere for the file, and the filename is the name of the file. ;) You can type the first couple of letters and hit [TAB] to auto-complete (very useful for long or complex filenames).

Link to post
Share on other sites
Sensayshun

Thanks man, I figured out the cd bit, and I vaguely remember the DOS days but I'm on 15 so I'm not brilliant on DOS.

I managed to run the program but at the end it tells me that:

There were errors during installation.

Details can be found in

/usr/share/fglrx/fglrx-install.log

I went there and it says this:

[Message] Kernel Module : Trying to install a precompiled kernel module.

[Message] Kernel Module : Precompiled kernel module version mismatched.

[Error] Kernel Module : No kernel module build environment - please consult readme.

But I don't know what readme they're talking about.

Thanks for the help.

Link to post
Share on other sites
TheTerminator

I cant remeber putting in a SU password, Ive tried all the ones it would have been i think. Do I have to reinstall now?

Link to post
Share on other sites
Deanobear
I cant remeber putting in a SU password, Ive tried all the ones it would have been i think.  Do I have to reinstall now?

586056201[/snapback]

I see you've got Ubuntu installed... there is no "su" password, Ubuntu uses "sudo" yourpassword.

Link to post
Share on other sites
TheTerminator

Oh, that helps a lot then.

So Id type "sudo ********" without the quoates of course. Correct?

Link to post
Share on other sites
Knight'

example

$sudo make install

(it then prompts you for a password)

Link to post
Share on other sites
TheTerminator

what does sudo mean? Im assuming Super User Do ....command.....

Link to post
Share on other sites
Knight'
Well, most likely, you have set up a root (super user) password that you should never log into.  You probably also set up a user account.

586053783[/snapback]

There is no root user in Ubuntu, at least by default.

Link to post
Share on other sites
Knight'
what does sudo mean? Im assuming Super User Do ....command.....

586059216[/snapback]

No idea, though, you're on the right lines ;)

Link to post
Share on other sites
TheTerminator

Ok, Im in linux now, I wanna change my res without my monitor going all screwy. So I have to edit my xorg.conf correct? I open it up and I see this:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

# (Type "man /etc/X11/xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following commands:

#

# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom

# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'

# sudo dpkg-reconfigure xserver-xorg

Section "Files"

FontPath "unix/:7100" # local font server

# if the local font server has problems, we can fall back on these

FontPath "/usr/lib/X11/fonts/misc"

FontPath "/usr/lib/X11/fonts/cyrillic"

FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"

FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"

FontPath "/usr/lib/X11/fonts/Type1"

FontPath "/usr/lib/X11/fonts/CID"

FontPath "/usr/lib/X11/fonts/100dpi"

FontPath "/usr/lib/X11/fonts/75dpi"

# paths to defoma fonts

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

EndSection

Section "Module"

Load "bitmap"

Load "dbe"

Load "ddc"

Load "dri"

Load "extmod"

Load "freetype"

Load "glx"

Load "int10"

Load "record"

Load "type1"

Load "vbe"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "keyboard"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc104"

Option "XkbLayout" "us"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ImPS/2"

Option "Emulate3Buttons" "true"

Option "ZAxisMapping" "4 5"

EndSection

Section "Device"

Identifier "ATI Technologies, Inc. Radeon 9800 XT (RV350 NJ)"

Driver "ati"

BusID "PCI:1:0:0"

EndSection

Section "Monitor"

Identifier "Generic Monitor"

Option "DPMS"

HorizSync 28-49

VertRefresh 43-72

EndSection

Section "Screen"

Identifier "Default Screen"

Device "ATI Technologies, Inc. Radeon 9800 XT (RV350 NJ)"

Monitor "Generic Monitor"

DefaultDepth 24

SubSection "Display"

Depth 1

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 4

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 15

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 16

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1024x768" "800x600" "640x480"

EndSubSection

EndSection

Section "ServerLayout"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

EndSection

Section "DRI"

Mode 0666

EndSection

So all I should do is add "1280x1024" before "1024x768" correct?

So I do. Well I try, but it wont let me type anything. Its like its read only, but I cant find anywhere to change it. Whats the porblem here?

edit: it says in properties>permissions that the owner is root and that I am not the owner so I cant change any permissions. How do I log on as root? Or how do I change it?

Link to post
Share on other sites
Rob2687

You need to do:

sudo nano /etc/X11/xorg.conf

or replace nano with gedit or another text editor of your choice.

Link to post
Share on other sites
TheTerminator

It worked, thanks.

edit, I was able to change it to

# /etc/X11/xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

# (Type "man /etc/X11/xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following commands:

#

# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom

# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'

# sudo dpkg-reconfigure xserver-xorg

Section "Files"

FontPath "unix/:7100" # local font server

# if the local font server has problems, we can fall back on these

FontPath "/usr/lib/X11/fonts/misc"

FontPath "/usr/lib/X11/fonts/cyrillic"

FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"

FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"

FontPath "/usr/lib/X11/fonts/Type1"

FontPath "/usr/lib/X11/fonts/CID"

FontPath "/usr/lib/X11/fonts/100dpi"

FontPath "/usr/lib/X11/fonts/75dpi"

# paths to defoma fonts

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

EndSection

Section "Module"

Load "bitmap"

Load "dbe"

Load "ddc"

Load "dri"

Load "extmod"

Load "freetype"

Load "glx"

Load "int10"

Load "record"

Load "type1"

Load "vbe"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "keyboard"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc104"

Option "XkbLayout" "us"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ImPS/2"

Option "Emulate3Buttons" "true"

Option "ZAxisMapping" "4 5"

EndSection

Section "Device"

Identifier "ATI Technologies, Inc. Radeon 9800 XT (RV350 NJ)"

Driver "ati"

BusID "PCI:1:0:0"

EndSection

Section "Monitor"

Identifier "Generic Monitor"

Option "DPMS"

HorizSync 28-49

VertRefresh 43-72

EndSection

Section "Screen"

Identifier "Default Screen"

Device "ATI Technologies, Inc. Radeon 9800 XT (RV350 NJ)"

Monitor "Generic Monitor"

DefaultDepth 24

SubSection "Display"

Depth 1

Modes "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 4

Modes "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 15

Modes "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 16

Modes "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

EndSection

Section "ServerLayout"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

EndSection

Section "DRI"

Mode 0666

EndSection

----------------------------------------------------------------------------

But now, when I go to system>preferences>screen resolution I still see the same 3 options, did I edit the right file?

Edited by TheTerminator
Link to post
Share on other sites
markjensen

Did you restart X? That file is only read on X init, I believe.

CTRL+ALT+[backspace] will quickly kill X (and it will likely restart automatically, depending on your initdefault).

Link to post
Share on other sites
TheTerminator

I did restart, I also just did a ctrl+alt+backspace and I relogged in and I still only get 3 options. I doubt it matters but Im running 64-bit Ubuntu(I have an athlon 64 3000+)

Link to post
Share on other sites
TheTerminator

anyone have an idea here?

Link to post
Share on other sites
thechitowncubs

It could possibly have something to do with your HorizSync and VertRefresh rates, go look up the spec sheet of your monitor and replace the frequencies you found on the spec sheet with the ones you have in there.

Link to post
Share on other sites
markjensen

Yeah, your VertRefresh is very low for a maximum setting (unless you have an LCD). I would imagine that if you have a CRT that it would help to plug in the right values.

You can usually google your CRT model in a few keywords like "hz vertical specifications" (adding or removing words to adjust your hits). If you can't find anything, post your model here, and we will see what we can dig up.

Link to post
Share on other sites
TheTerminator

K I pretty sure i screwed up my xorg.conf, the visual portion of Ubuntu wont come up anymore, it stays at the Terminal, like dos promt. How can i restore it?

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.