• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

.imwheelrc

Recommended Posts

andrew_f    26

Hey, I'm trying to get my MX700 thumb buttons to work. I am running Ubuntu Dapper Drake and have imwheel installed. I used this page as the guide and used his attatched .imwheelrc (foundhere).

The thing is, the thumb buttons don't work still but now scrolling up and down in firefox makes it change to the previous and next page - the actions which the thumb buttons should do.

Does anybody have any suggestions how I can fix this?

Share this post


Link to post
Share on other sites
andrew_f    26

Okay I've fixed the scrolling by editing the xorg.conf file.

Share this post


Link to post
Share on other sites
Krpano    32

Man, this is something im always fighting with.

I was never able to make my thumb buttons work correctly.

Some time ago i went for this config.

(no extra configs, only these lines into xorg.conf)

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver	  "mouse"
	Option		"CorePointer"
	Option		"Device" "/dev/input/mice"
	Option		"Protocol" "ExplorerPS/2"
	Option	  "ButtonMapping"		 "1 2 3 8 9"
	Option		"ZAxisMapping" "4 5"
#	Option		"Emulate3Buttons" "true"
EndSection

which worked till the first restart, then it was gone even tho i didnt changed anything after.

This has only worked for Firefox and never had any effect for Opera or Nautilus.

One command you can use to find the buttons number assigments is with "xev" at the terminal. (without quotes)

Good luck, and let us know if you find the solution.

:)

Share this post


Link to post
Share on other sites
andrew_f    26

:( Doesn't work... thank you for the effort though :)

Share this post


Link to post
Share on other sites
kongit    0

I have the same mouse as you, and here is what I did to get it to work.

1)

make sure xorg.conf looks like this in mouse area

Section "InputDevice"
	Identifier  "Mouse0"
	Driver	  "mouse"
	Option	  "Protocol" "auto"
	Option		"Device" "/dev/input/mice"
	Option		"Buttons" "9"
	Option		"ZAxisMapping" "4 5"

EndSection

2) install xbindkeys

3) in .xbindkeysrc in home directory have this

"/usr/X11R6/bin/xvkbd -xsendevent -text "\[Alt_L]\[Left]""
  b:8
"/usr/X11R6/bin/xvkbd -xsendevent -text "\[Alt_L]\[Right]""
  b:9

4) restart X

5) mouse back/forward buttons plus wheel should work in browsers etc

postnote. used to the buttons 9 let the forward/backword work, I have tried all sorts of methods remapping and on to get them to work natively with x, however i think they stopped working with xorg might be wrong

oh yeah make sure you have xvkbd installed too

Share this post


Link to post
Share on other sites
j79zlr    0

This is relatively simple. Your .imwheelrc is overly complicated. Remove the Buttons and ZAxisMapping lines from xorg.conf. Your imwheelrc file simply should be:

"(null)"
None, Button4, Alt_L|Left
None, Button5, Alt_L|Right

".*"
None, Button4, Alt_L|Left
None, Button5, Alt_L|Right

Then you need to either add this line to your .xinitrc file:

/usr/bin/imwheel -k -b "89"

or create a script to run at startup that includes:

#!/bin/sh
exec /usr/bin/imwheel -k -b "89" &

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.