Svchost using too much RAM.


Recommended Posts

Logie

G'day,

I've got a computer here which I'm fixing for a freind which they were complaining freezes all the time. I've done registry defrags and Clean Ups, and removed alot of startup entrys using TuneUp Utilities 2006 and Run spyware and adware scans. But it still freezes.

I've opened a task manager and determined that it's an SVCHOST.exe process using about 20MB of Ram and fluxuating upto 100% CPU usage. Does anyone know how I can find out why it's using so many resources and how I can stop it? Cheers.

Link to post
Share on other sites
primexx

not really, because tons of services use svchost....so it's not really easy to isolate.

you could go into services.msc and disable any useless services though and see if that helps.

Link to post
Share on other sites
Farstrider

SVCHOST.exe must NOT be deleted or disabled as it will cause all sorts of problems! The presence of scvhost [Note the spelling is different!] may indicate a virus.

There are two possible problems:

You could be infected with a virus.

You could be under "attack" from an outside source attempting to exploit the RPC vulnerability.

Go to the task manager and look if you can see intersvc.exe running, if it is then this is the program screwing with the pc. It makes the svchost crash and also runs the cpu at % 100. to solve this problem go to Open up Registry Editor (Start Menu -> Run -> regedit). In Registry Editor, go to My Computer -> HKEY_LOCAL_MACHINE -> Software -> Microsoft -> Windows -> CurrentVersion -> Run on the left side locate intersvc.exe and delete it. Restart the computer and the problem is solved!

Link to post
Share on other sites
Logie

Nope, TuneUp Utility's task manager says its 'svchost.exe -k netsvcs.'

Link to post
Share on other sites
furyc0de

Are you running Automatic Updates on this PC? I've had the same issue on numerous systems and found it was the culprit.

Link to post
Share on other sites
Logie

Yep. So I just disable Automatic Updates?

Link to post
Share on other sites
furyc0de

Yup. I've just selected 'Turn off Automatic Updates' in the Automatic Updates control panel and that's resolved it.

Naturally of course, you won't receive automatic updates any longer.

Link to post
Share on other sites
+jamesyfx

I'd disable the security center as well, if you disable automatic updates. Just to stop it from moaning.

Link to post
Share on other sites
Gavin001

Yup its the Automatic updates i had the same problem usually when i first log on! I did once disable the automatic updates etc.. but i think i went overboard because then i couldnt even update from the website :( how do i disable the secruity center so it aint always telling me that its turned off?

Link to post
Share on other sites
Lasker

Yup its the Automatic updates i had the same problem usually when i first log on! I did once disable the automatic updates etc.. but i think i went overboard because then i couldnt even update from the website :( how do i disable the secruity center so it aint always telling me that its turned off?

open windows security center window, on the navigation list on the left there is an option called: CHANGE THE WAY SECURITY CENTER ALERTS ME and just uncheck all the option or the options that you don't want.

Link to post
Share on other sites
Gavin001

open windows security center window, on the navigation list on the left there is an option called: CHANGE THE WAY SECURITY CENTER ALERTS ME and just uncheck all the option or the options that you don't want.

ooooooo and it was so easy :blush:

Thanks so much :D

Link to post
Share on other sites
Lasker

ooooooo and it was so easy :blush:

Thanks so much :D

your welcome :yes:

Link to post
Share on other sites
  • 1 month later...
MarkM

Watch out folks...

Windows defender and Office also use the automatic updates system and cause the CPU to go to 100% via svchost. Turning off auto updates dosn't always fix the problem.

Anyone with this problem should report it to microsoft!!! I have already filed an incident report (SRZ061102000815) and I want to keep the preasure on them to fix this problem!!!! :crazy:

http://support.microsoft.com/oas/default.a...amp;gprid=37013

Mark

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.