• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Vista slow at copying files

Recommended Posts

verbal11    0
That worked for me, I am on RC2, what is remote differetial compression anyway?

More on Remote Differential Compression. http://msdn2.microsoft.com/en-us/library/aa372948.aspx

I just breezed over the article, but I think it bascially compares files on the fly so if you are copying a file from one computer to another and a copy exists on both machines, it will then only transfer over the changes rather than the entire file. Thus saving network bandwidth by only transfering the small changes. I can see how could have an impact on transfer speed because i would assume that the comparison proccess adds to the overhead. So while it's may be transfering less, the time may take longer because it has to first compare the files for changes.

Share this post


Link to post
Share on other sites
Malisk    142
That's ReadyDrive not SuperFetch... everyone benefits from SuperFetch since all it does is load your typical apps into unused memory.

SuperFetch has plenty of problems though, real ones that I've identified by monitoring tools. (this is on RTM, of course)

For me SuperFetch (yes, it was that one; I checked the SvcHost's service list and disabled one by one) totally ruined my performance as I used eMule, and I can imagine other apps being affected too. Vista simply thought "OK, so it's evening and he probably wish to run eMule" and started prefetching -- get this -- an unfinished download of several hundred MB's. It just kept reading, reading, making the drive go wild, so I checked what was going on in the Sysinternals File Monitor and I had a lot of read for one and the same file over and over. As soon as I stoppsed the SuperFetch service, my hard drive went completely silent and my computer became far more responsive as it tried to load applications I started and ran.

I wish SuperFetch would be much more configurable and not a black box sitting doing "something it feels would be right" to improve performance. I don't really want to generalize, but it's such typical Microsoft behavior to hide important customization like this from the user in order to dumb it down enough for the masses. File and directory exclusion filters would work wonders with it. Or at least only prefetch executables and DLL's! There's absolutely no reason I'd like to prefetch an unfinished download for faster access because I'm of course not going to run it.

Keep in mind that SuperFetch is based a whole lot on guesswork and statistics.

Edited by Jugalator

Share this post


Link to post
Share on other sites
maxsquared    0
More on Remote Differential Compression. http://msdn2.microsoft.com/en-us/library/aa372948.aspx

I just breezed over the article, but I think it bascially compares files on the fly so if you are copying a file from one computer to another and a copy exists on both machines, it will then only transfer over the changes rather than the entire file. Thus saving network bandwidth by only transfering the small changes. I can see how could have an impact on transfer speed because i would assume that the comparison proccess adds to the overhead. So while it's may be transfering less, the time may take longer because it has to first compare the files for changes.

Thanks for the explain and link, I would rather choose faster file copying I think.

Share this post


Link to post
Share on other sites
AminoSC    0

As soon as your chipset drivers come everyone will be happy.

Share this post


Link to post
Share on other sites
RaisinCain    0
in synthetic benchmarks or something of the kind? cause last time i tried the retail version of Vista it was pretty slow :| might've been placebo. but damn it sure took long. either it really is slow or microsoft's research into making the user think that a process is going faster was totally bogus :p

& how did thoust get the Retail version?

Share this post


Link to post
Share on other sites
Karl Sheldon    0

Well too add my 2pence worth;

Copying to (XP) compressed Usb drive is fast, from it is slow, same drive to same drive is slow, moving files on desktop very slow, a lot of drive clashes on a 512Mb machine. Disabling this and that has little effect if any - wish I could find the magic switch and get some stability back into hd performance.

Some noticeable things I have found (and not so)

Changing the swap drive to another as in XP does not seem as effective in Vista

Moving the temp drive does make a diff (away from system drive) (user profile, my enviro variables)

Readyboost on a 512Mb Laptop (forced) worth it but give it time, same with superfetch over time it should improve things (or so MS say)

Drop the Aero interface - gives 20Mb back to system and is faster for sure.

Dissabling non used services less effective than in XP as a lot show that they are not running and take nothing from memory, the default is quite well behaved I think.

P2P programs should be away from system drive and temp/swap drives, better to have 4 drives (not partitions it still has to seek) 1 System, 1 Swap, 1 Temp, 1 P2P even better if you can add to that 1 Programs, 1 Data - would help performance defiantly.

Of course more memory the better.

Annoyances;

answers on a postcard please!

Task Bar - if you add a new toolbar it is locked to the taskbar, you don't seem to be able to move it onto the screen and use as a program launcher as in XP (yes taskbar is unlocked)

Calculating time dialog can take longer than operation Doh!

Sometime files get forgotten on a move.

'You need permission' for what, moving a data file of my own Why! - even as administrator

Slow run command !

Program compatibility - what does the compatibility service do !

...

Share this post


Link to post
Share on other sites
l0g0ut    0

turning off Remote Differential Compression works for me. transfering files back at WinXP speed.

Share this post


Link to post
Share on other sites
azz0r_wugg    1

How do you do that?

Control Panel > Uninstall programs > turn off windows features > Untick

Edited by azz0r_wugg

Share this post


Link to post
Share on other sites
Roller_ball    1

:) beat me to it

go into Control Panel\Programs and Features\turn windows features on and off.

its in that list

Share this post


Link to post
Share on other sites
azz0r_wugg    1

Not sure if its any faster as I just got random hang ups when deleting small files.

Share this post


Link to post
Share on other sites
Gurra    0

Any progress in this bug?

Share this post


Link to post
Share on other sites
Stivort    0

I'm having the same problems running on Vista RC1.

None of the solutions posted in this thread have helped.

Trying to copy files accross a network on a gigabit connection. Speeds are dreadful. Maxing out at 3MB/sec.

Any solutions to this problem?

Edited by Stivort

Share this post


Link to post
Share on other sites
Stivort    0

Anyone?

Share this post


Link to post
Share on other sites
Lorraine    0

disabling the windows search service worked for me.

Before, everything just stalled. Deleting, copying, renaming....horrible. Just lots of 'calculating time remaining' boxes and hangs.

Seems ok now.

Share this post


Link to post
Share on other sites
Stivort    0

Thanks for the tip. Seems to have helped. ;)

Share this post


Link to post
Share on other sites
dice89    0

I've tried everything suggested in this thread. Nothing so far has helped with transfering of files within Vista. Even files on the same hard drive take forever. My USB 2.0 travel drive takes forever. Zip files take forever. What's going on? Also. Windows Explorer seems to hang and eat up resources like no tomorrow when I do these things.

Any help would be greatly appreciated.

3.0Ghz

2.00gb Ram

SATA 250GB WD hard drive 7200rpm

NVidia GeForce 7900GS 256mb

Thanks in advance!

Jon

Share this post


Link to post
Share on other sites
hagjohn    2,220
Try to do hard drive defragmantion...and good luck with that...It takes hour to complete. And you can't even see the pogress...total CRAP!

Vista needs service pack..badlyyy

Defrag sucks. No time or % given. Why would windows go to sleep when you have defrag going? I do not mind it going to sleep but it should go to sleep after it finishes.

Share this post


Link to post
Share on other sites
No1B    0

I've found a solution for slow network copying...

Try to disable the Windows Firewall service (and whole Windows Firewall as well).

Regards

Share this post


Link to post
Share on other sites
No1B    0

It was a false alarm but.... I've changed my network card to the one integrated with my MB (nForce2 chipset) and... it is working!!!

Previously I had the '3Com EtherLink 10/100 PCI TX NIC (3C905B-TX)' installed. I haven't got drivers for Vista (drivers for this 3com card aren't provided with Vista) and I used drivers for XP :|

It looks like that this solved my problem.

UPDATE: I think that those (3com) drivers were updated by Windows Update and nothing's changed. Everything is working properly on nForce-based card.

Regards

No1B

Edited by No1B

Share this post


Link to post
Share on other sites
Karl Sheldon    0

Slow at copying files, try the service pack 1 update to Visual Studio !

Its just taken 5 hours on Vista to complete (wow must be a record), XP 2 Hours #!#!

Thats was with NOD32 running - some over head but XP was using far slower AVG Free

Try moving 1-0 shortcuts from the desktop to a folder - takes longer to draw the dialog to infor calculating time than to do the opperation - what is with that then ??

Share this post


Link to post
Share on other sites
CaVleX    0
Hey guys and gals,

I "Think" I solved the answer to the slow copying. I came across this while trying to uninstall the MS SQL sync program. This may work for you I have noticed a HUGE increase on the web and on my network with this. I use Ultimate btw.

Start >> Control Panel >> Programs and Features

Click on " Turn windows features on or off" on the left side of the panel

Takes a sec to load all the features

Uncheck "Remote Differential Compression"

I also unchecked "Print Services" (Since I don't have a printer)

Click "Ok" and you will be all set.

I then copied a 700 movie from one drive to another and it took less then 10 secs.

-+>Aaron

Let me know if it works for you.

This seemed to work for me . Give it a try. 10 times better performance.

Share this post


Link to post
Share on other sites
Gurra    0
This seemed to work for me . Give it a try. 10 times better performance.

Did not help at all, its seems nforce 4 suffer more from this bug, but even my ULI chipset computer has this bad vista feature :(

Share this post


Link to post
Share on other sites
tao muon    0
Slow at copying files, try the service pack 1 update to Visual Studio !

Its just taken 5 hours on Vista to complete (wow must be a record), XP 2 Hours #!#!

Thats was with NOD32 running - some over head but XP was using far slower AVG Free

Try moving 1-0 shortcuts from the desktop to a folder - takes longer to draw the dialog to infor calculating time than to do the opperation - what is with that then ??

Don't know what's going on...

I just copied a previous WinVista Users/Public folder and subfolders to my login and it took about 3 minutes to transfer 12 GB of data.

Share this post


Link to post
Share on other sites
Rahul    0
Hey guys and gals,

I "Think" I solved the answer to the slow copying. I came across this while trying to uninstall the MS SQL sync program. This may work for you I have noticed a HUGE increase on the web and on my network with this. I use Ultimate btw.

Start >> Control Panel >> Programs and Features

Click on " Turn windows features on or off" on the left side of the panel

Takes a sec to load all the features

Uncheck "Remote Differential Compression"

I also unchecked "Print Services" (Since I don't have a printer)

Click "Ok" and you will be all set.

I then copied a 700 movie from one drive to another and it took less then 10 secs.

-+>Aaron

Let me know if it works for you.

Works for me Too

Running Vista business +10

Share this post


Link to post
Share on other sites
Lawliet    0

I have the same problem too. Seems to happen to random files. Quite annoying.

post-135300-1171894888.png

And my HDDs aren't fragmented at all...

post-135300-1171894907_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.