Archived

This topic is now archived and is closed to further replies.

Unable to connect to companyweb after vpn

Recommended Posts

Adam1V    66

On my own person machine, i have create a vpn, connect, manually connected to the domain and it all works fine when i try to accesss http://companyweb/ from home.

How every, from any other machine, after they VPN in, and also on my partners laptop, without messing about with workgroups, or domains, i cannot connect to http://companyweb/

Does anyone have any ideas what i might be doing wrong?

I can ping the server, and also connect to the shares, but not sharepoint :(

Share this post


Link to post
Share on other sites
MazX_Napalm    0

I guess you mean your company intranet?

Add the network DNS as primary and add something like OpenDNS after the company DNS.

Share this post


Link to post
Share on other sites
Adam1V    66
I guess you mean your company intranet?

Add the network DNS as primary and add something like OpenDNS after the company DNS.

Sorry, you may have to explain a bit more :(

and yes, i did mean the company intranet

Share this post


Link to post
Share on other sites
MazX_Napalm    0

I have found that using "static" DNS settings works.

post-57102-1171026230_thumb.png

Add your company's DNS servers as the first ones.

Add public DNS (your isp or something like OpenDNS) AFTER the company ones.

The second step is only necessary where you allow connections without VPN, otherwise when the VPN is turned off the user can't access the internet.

Share this post


Link to post
Share on other sites
brand    0
I have found that using "static" DNS settings works.

<snizzle>

Add your company's DNS servers as the first ones.

Add public DNS (your isp or something like OpenDNS) AFTER the company ones.

The second step is only necessary where you allow connections without VPN, otherwise when the VPN is turned off the user can't access the internet.

Call your company's help desk. They may restrict VPN traffic to only certain servers. If this server is one of the allowed servers, but the DNS isn't (like our VPN), you can add a HOST entry instead; or simply access the server via IP addr ("http://192.168.60.35", etc).

Share this post


Link to post
Share on other sites
Adam1V    66

when im connected internally this is the info i have:

Connection-specific DNS Suffix  . : smallbusiness.local
 Description . . . . . . . . . . . : NETGEAR GA311 Gigabit Ada
 Physical Address. . . . . . . . . : 00-09-5B-BC-EB-85
 DHCP Enabled. . . . . . . . . . . : Yes
 Autoconfiguration Enabled . . . . : Yes
 IP Address. . . . . . . . . . . . : 192.168.1.35
 Subnet Mask . . . . . . . . . . . : 255.255.255.0
 Default Gateway . . . . . . . . . : 192.168.1.1
 DHCP Server . . . . . . . . . . . : 192.168.1.1
 DNS Servers . . . . . . . . . . . : 192.168.1.1
 Primary WINS Server . . . . . . . : 192.168.1.1
 Lease Obtained. . . . . . . . . . : 12 February 2007 07:20:35
 Lease Expires . . . . . . . . . . : 20 February 2007 07:20:35

Should i be adding 192.168.1.1 as the DNS to the VPN connection? or the ISP DNS that the server is connected on?

Share this post


Link to post
Share on other sites
MazX_Napalm    0

Both, but put you network DNS first.

Share this post


Link to post
Share on other sites
Adam1V    66

ive added these DNS to the VPN connection, its still conencted ok, but not companyweb.

you didnt actually say add them to the VPN connection, i presume thats correct?

Adam

post-126346-1171401572_thumb.jpg

Share this post


Link to post
Share on other sites
Adam1V    66

I have read this info from another website, but it appears to be a bit complicated.

Can anyone give me some simple instructions if this advice is correct?

How do you have your network setup? How is the server exposed to the internet?

To access your SharePoint site via http://<external ip>/companyweb externally you would have to setup one of the following:

1-a)Have your SharePoint site extended on an IIS virtual server that is listening on that external IP and the webserver directly connected to the internet b) Your SharePoint site would need to be extended not to the default root of that virtual server, but to /companyweb (or have a subsite/top-level site at /companyweb).

2-Have a firewall that NAT'ed your external IP address to an internal address thus: http://<external ip>/companyweb --> http://<internal IP>/companyweb. And all the other info on #1a above would be true.

3-Have a firewall/translation setup to have http://<external ip>/companyweb --> http://<your SharePoint server>

To me, it sounds like you have just opened the ports to the server, but no way for the external computer to navigate your internal network. That is where link translation comes into play.

Share this post


Link to post
Share on other sites
quigley0    0

have you added the Sharepoint site to trusted sites in IE?

Share this post


Link to post
Share on other sites
Adam1V    66

yes i have, and still nothing :(

IF it help, ive have VPN'ed remotely just now, i can access the attached page which is over the vpn, but not the company web.

post-126346-1171531955_thumb.jpg

Share this post


Link to post
Share on other sites
Adam1V    66

right, i have sorted it now, i knew this would work, i just didnt want to really do it this way if possible.

Ive VPN'ed in, set the workgroup to the domain name (smallbusiness), rebooted, then set the domain to smallbusiness.local and rebooted again. VPN'ed in, and i can connect to the company web instantly.

Adam

Share this post


Link to post
Share on other sites
+BudMan    3,032

Some simple understanding of how name resolution works and what domain suffix search order your machine was using was all that was required.

What workgroup your in has nothing to do with it..

You have a domain --> smallbusiness.local

You have a server where this company web site is hosted.. ie server.smallbusiness.local

You have cname in your dns that points companyweb to server.smallbusiness.local

If your machine does not have a primary domain suffix set, nor any connection specific suffixes set.. then when you ask the DNS for your domain where companyweb. is -- it has no idea.. it KNOWS where companyweb.smallbusiness.local is -- but without a suffix set or a FQDN query.. the dns server has no idea what your asking for.

Here this might help

http://www.microsoft.com/windowsxp/using/n...t/tcpipdns.mspx

How to Configure Windows XP TCP/IP to Use DNS

Check out the "To modify the resolution behavior for unqualified DNS names" section.

Your primary suffix and search list can bee seen from an IPconfig /all

For Example:

C:\>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : p4-24g

Primary Dns Suffix . . . . . . . : local.lan <--- This is mine

Node Type . . . . . . . . . . . . : Hybrid

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

DNS Suffix Search List. . . . . . : local.lan <-- This is the search list

So when If I query for companyweb my machine would by default query for companyweb.local.lan which would be a cname for the actual servers A record. of servername.local.lan

When machines join your AD domain - they would by default have their primary dns suffix set to your domain, which is why they find it no problem. Since your machine is not a member of the domain - you would have to set your primary suffix by hand, or setup a connections specific suffix for your vpn connection or just plain use a FQDN to access your companyweb

http://companyweb.smallbusiness.local

Or http://somethingelse.yourdomina.tld -- All depending on what other sites your hosting on the same server and or whatever host headers you have setup for the site, etc..

Share this post


Link to post
Share on other sites
quigley0    0

When you VPN, if you add the domain to the login, would that not work? i.e.,

Login: DOMAIN\quigley.user

passwd: 1234

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.