• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Hi-speed usb problem

Recommended Posts

Mouldy Punk    11

Whenever I plug in my Zen Touch it says "This device could perform better if it was plugged into a HI-SPEED USB port" (or something along those lines. When I click on the message so it'll tell me what ports I have that are hi-speed, it says I have none.

Now, I'm assuming by "HI-SPEED" it means USB 2.0 right? So it's a bit odd, that despite all the USB ports (with possible exception of the ones on the front my case) being USB 2.0, it's saying they're not?

In device manager I have;

USB controllers:

-Standard OpenHCD USB host controller

-USB Composite device

-USB Root hub

USB controllers:

-PCI Class USB 2.0 Enhanced Host controller

-USB 2.0 root hub

So it's clearly detecting USB 2.0 ports somewhere, but no matter what port I plug my mp3 player into it says that I should plug it into a "HI-SPEED" port.

I've tried removing all USB related stuff in device manager and rebooting so it'll redetect it. I've tried installing the latest nForce4 drivers and the same thing is happening again. Any ideas on how to fix this?

It always used to work, then when I reformatted & reinstalled everything it broke.

Specs;

Win XP Home SP2

AMD 64 3700+

2GB Dual Channel RAM

256mb 6800 GS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.