Archived

This topic is now archived and is closed to further replies.

Install/Uninstall errors

Recommended Posts

bidz    23

Whatever i try to install or uninstall from Windows Vista that uses Microsoft's Installer System, i get this error message:

"The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2203."

I also get a similar errormessage (mentioning Error 2203) when i try to uninstall Vista Codec Pack:

"Error 2203.Database: C:\Windows\Installer\281f756.ipi. Cannot open database file. System error -2147287035."

and i got a similar message when i tried to install the SubInACL Resource Kit Tool from Microsoft:

"Internal Error 2203. C:\Windows\Installer\2a4ccb1.ipi, -2147287035"

I get this message when i try to uninstall a applicaton that uses the Windows Installer system, and also when i try to install new applications (like iTunes and Quicktime, for example, i can't get those installed at all due to this problem). I thought this was a issue with iTunes+QuickTime earlier today when i got the message, but just now i tried to uninstall a few apps (Windows Sidebar Styler just to name one of them) and i got the same identical message that i got when i tried to install iTunes+QuickTime.

I have removed all temp files with the latest CCleaner (and the HDD cleanup utility that ships with Vista), and also cleaned my registry with CCleaner.

I have no spyware/adware/malware/viruses/trojans according to:

Kaspersky Anti-Virus 6.0.2.621 (latest signatures)

Spybot Search & Destroy (latest signatures)

Windows Defender (latest signatures)

And everything else is working perfectly.

Any ideas how i can fix this?

Share this post


Link to post
Share on other sites
bidz    23

Well, i managed to fix it myself.

The solution was to give the SYSTEM account write/change priveliges to my C:\Users\Username folder. For some strange reason the SYSTEM account got it's write/change priveliges removed. Strange. Anyhow, this fixed all my problems.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.