"Error loading operating system" in Ubuntu


Recommended Posts

fatassmichael

Well i've just installed ubuntu 7.04 and get this error msg on reboot, just after POST.

I have 2 HDD's, 1 sata and 1 ide, i'm have installed ubuntu onto the sata disk.

Can anyone help please.

Link to post
Share on other sites
markjensen

Are you single-booting Ubuntu only? What Windows do you have? What option(s) and preparations did you do when you installed Ubuntu?

Does GRUB show up with a choice to boot? Do any of the options work?

Please boot the Ubuntu CD as a LiveCD and open a terminal. Post the output of a sudo fdisk -l (that is a lowercase letter "L", not the number one).

Link to post
Share on other sites
fatassmichael

Hi Mark,

yes i'm single booting ubuntu, i had windows installed on this sata disk previously, i put in the ubuntu live cd and installed from there, went through the options of time zone, keyboard etc, then let ubuntu format the whole disk, then it did its thing, i did not set any advanced options, as i said as soon as the pc does it's POST, i get that error so i get no GRUB options, will post back with outcome of that command.

Thanks

Edit: Here is the outcome

Disk /dev/sda: 160.0 GB, 160041885696 bytes

255 heads, 63 sectors/track, 19457 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System

/dev/sda1 * 1 19083 153284166 83 Linux

/dev/sda2 19084 19457 3004155 5 Extended

/dev/sda5 19084 19457 3004123+ 82 Linux swap / Solaris

Disk /dev/hdd: 122.9 GB, 122942324736 bytes

255 heads, 63 sectors/track, 14946 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System

/dev/hdd1 1 14946 120053713+ 7 HPFS/NTFS

Edited by fatassmichael
Link to post
Share on other sites
markjensen

Hmmm... Looks like Linux on your first SATA drive, and Windows on the second drive.

Ok, still in Ubuntu LiveCD mode, go into that sda1 partition (use the GUI if you like), and find the file /boot/grub/menu.lst Post that here. Let's see where it is trying to point. Though it sounds like it isn't even trying to start up GRUB, which concerns me - not sure if GRUB was installed properly like it should with default options.

Link to post
Share on other sites
fatassmichael

Here is the menu.lst file, i have just copied the relevant part,

title Ubuntu, kernel 2.6.20-15-generic

root (hd1,0)

kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=34ceaab0-0354-41fd-af53-a919749bd9e4 ro quiet splash

initrd /boot/initrd.img-2.6.20-15-generic

quiet

savedefault

title Ubuntu, kernel 2.6.20-15-generic (recovery mode)

root (hd1,0)

kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=34ceaab0-0354-41fd-af53-a919749bd9e4 ro single

initrd /boot/initrd.img-2.6.20-15-generic

title Ubuntu, memtest86+

root (hd1,0)

kernel /boot/memtest86+.bin

quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

Also the IDE drive is just where i store my music, photos etc, no actual OS on it.

Edit: This is also the Device.map file from the GRUB folder

(hd0) /dev/hdd

(hd1) /dev/sda

Which seems to me like its "pointing" to the correct drive :unsure:

Edited by fatassmichael
Link to post
Share on other sites
markjensen

Hey, I just noticed that your config has a SATA drive at sda and a PATA drive at hdd (I thought they were both SATA).

It looks like part of the problem may be in what BIOS presents as the boot order, and what Linux is looking for, Can you go into BIOS and swap boot order?

Link to post
Share on other sites
fatassmichael

My present order is CD, sata, disabled, Which order should i have?

Edit: I tried to switch the boot order but i cannot choose the IDE hdd, i have my bios set up as this, Primary IDE channel = Disabled, for some reason it would not see my sata drive when it was enabled, DVD-RW = Secondary Master, IDE hdd = Secondary Slave, Then the sata hdd.

The sata hdd is listed as the first in the bios and the IDE hdd listed as the second.

Edited by fatassmichael
Link to post
Share on other sites
markjensen

I don't have any experience with mixed SATA/PATA systems, or with Windows on the box (I have only Linux).

Might I suggest disconnecting your NTFS PATA drive, so only your CD/DVD and SATA Linux drive are connected and try a quick re-install. This will make sure that Ubuntu is OK with your basic hardware. Then we will connect the PATA drive and add that in after-the-fact, and see if that causes problems.

Link to post
Share on other sites
fatassmichael

Mark, Thanks for that, i have resorted to installing Opensuse 10.2, which i have had working with this system setup before.

Sorry for wasting your time

Thanks

Mike

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.