Right distro for me?


Recommended Posts

markjensen

2) If you are still having problems, post your /etc/X11/xorg.conf file. That will show us your video mode setup.

3) Fedora doesn't set up sudo. It uses plain users, or root. If you need to admin, just su to root. If you like the sudo thing, you can set that up, although I have never done so.

Link to post
Share on other sites
wst50
2) If you are still having problems, post your /etc/X11/xorg.conf file. That will show us your video mode setup.

3) Fedora doesn't set up sudo. It uses plain users, or root. If you need to admin, just su to root. If you like the sudo thing, you can set that up, although I have never done so.

Here's my xorg.conf file.

# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier	 "single head configuration"
	Screen	  0  "Screen0" 0 0
	InputDevice	"Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver	  "kbd"
	Option		"XkbModel" "pc105"
	Option		"XkbLayout" "gb"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	ModelName	"LCD Panel 1280x1024"
	HorizSync	31.5 - 64.0
	VertRefresh  56.0 - 65.0
	Option		"dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver	  "radeon"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device	 "Videocard0"
	Monitor	"Monitor0"
	DefaultDepth	 24
	SubSection "Display"
		Viewport   0 0
		Depth	 24
	EndSubSection
EndSection

Thanks- it was saying that "William is not in the list of sudoers"

But it's okay, I used su instead.

Link to post
Share on other sites
Barney T.

My Debian xorg.conf: # /etc/X11/xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

# (Type "man /etc/X11/xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"

FontPath "/usr/share/fonts/X11/misc"

FontPath "/usr/X11R6/lib/X11/fonts/misc"

FontPath "/usr/share/fonts/X11/cyrillic"

FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"

FontPath "/usr/share/fonts/X11/100dpi/:unscaled"

FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"

FontPath "/usr/share/fonts/X11/75dpi/:unscaled"

FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"

FontPath "/usr/share/fonts/X11/Type1"

FontPath "/usr/X11R6/lib/X11/fonts/Type1"

FontPath "/usr/share/fonts/X11/100dpi"

FontPath "/usr/X11R6/lib/X11/fonts/100dpi"

FontPath "/usr/share/fonts/X11/75dpi"

FontPath "/usr/X11R6/lib/X11/fonts/75dpi"

# path to defoma fonts

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

EndSection

Section "Module"

Load "bitmap"

Load "ddc"

Load "dri"

Load "extmod"

Load "freetype"

Load "glx"

Load "int10"

Load "vbe"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc104"

Option "XkbLayout" "us"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ImPS/2"

Option "Emulate3Buttons" "true"

EndSection

Section "Device"

Identifier "nVidia Corporation G71 [GeForce 7300 GS]"

Driver "vesa"

BusID "PCI:1:0:0"

EndSection

Section "Monitor"

Identifier "VE175-2"

Option "DPMS"

HorizSync 30-82

VertRefresh 50-75

EndSection

Section "Screen"

Identifier "Default Screen"

Device "nVidia Corporation G71 [GeForce 7300 GS]"

Monitor "VE175-2"

DefaultDepth 24

SubSection "Display"

Depth 1

Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 4

Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 15

Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 16

Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

EndSubSection

EndSection

Section "ServerLayout"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

EndSection

Section "DRI"

Mode 0666

EndSection

I didn't see your display section (I put it in bold).... do you have one?

Link to post
Share on other sites
wst50

Nope. That's... very strange... What do all of those settings mean though? I can see the resolution bits, but the 'depth'? Is that colour depth? You see my problem now- not knowing what that bit means, I don't want to mess with it too much...

Link to post
Share on other sites
Barney T.

My xorg.conf file is more in-depth than you need. It has added color depth. Really, look at this guide:

http://ubuntuforums.org/showthread.php?t=83973

It will help you set up the resolutions and refresh rates (those actually look like they are ok in your set-up).

A more common representation is:

# **********************************************************************

# Screen sections

# **********************************************************************

# Any number of screen sections may be present. Each describes

# the configuration of a single screen. A single specific screen section

# may be specified from the X server command line with the "-screen"

# option.

Section "Screen"

Identifier "Screen 1"

Device "Libretto"

Monitor "Libretto"

DefaultDepth 16

Subsection "Display"

Depth 8

Modes "1280x1024" "1024x768" "800x600" "640x480"

ViewPort 0 0

EndSubsection

Subsection "Display"

Depth 16

Modes "1024x768" "800x600" "640x480"

ViewPort 0 0

EndSubsection

Subsection "Display"

Depth 24

Modes "800x600" "640x480"

ViewPort 0 0

EndSubsection

EndSection

More can be read here:

http://crowsons.net/puters/txt/xorg.conf.fcm.txt

Hope that this helps.

Link to post
Share on other sites
markjensen
My Debian xorg.conf: # /etc/X11/xorg.conf (xorg X Window System server configuration file)

...

I didn't see your display section (I put it in bold).... do you have one?

It's right there at the end:

Section "Screen"
	Identifier "Screen0"
	Device	 "Videocard0"
	Monitor	"Monitor0"
	DefaultDepth	 24
	SubSection "Display"
		Viewport   0 0
		Depth	 24
	EndSubSection
EndSection

Link to post
Share on other sites
wst50

Ooh. I wasn't paying attention properly. I was looking for a massive section like Barney's. Whoops :blush:

Link to post
Share on other sites
Barney T.

Well then.... I guess that the resolutions need to be added in? :huh:

Link to post
Share on other sites
ViperAFK
I don't see why people complain about rarely having to use the command line.

opening terminal, sudo apt-get install VLC

is easier then opening firefox, VLCs website, downloading it, extracting it, installing it, removing the install files from the desktop.

It works for many things...

sudo apt-get install azureus

sudo apt-get install wine

sudo apt-get install apache2

sudo apt-get install snes9x

of course many many more those are just examples I have used.

I thought that part of Linux was completely awesome.. maybe it's just the nerd in me :p

Yeah I actually find that much easier than opening synaptic if I know the package name. Very convenient and I'm not one who really likes the command line. very easy in fedora too yum install xxxxx. Everyone has their own preference though.

Link to post
Share on other sites
wst50
Yeah I actually find that much easier than opening synaptic if I know the package name. Very convenient and I'm not one who really likes the command line. very easy in fedora too yum install xxxxx. Everyone has their own preference though.

I generally have been using yum instead of pirut to install programs this weekend.

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.